Announcement

Collapse
No announcement yet.

Homeseer homepage error: Cannot connect to server

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Homeseer homepage error: Cannot connect to server

    I just installed HS4 (std license) on a rpi4 and all was working fine. This morning, all of a sudden the devices.html page is inaccessible, I get the error below (Cannot access server). I checked all processes were running fine (connected via ssh to the pi). Moreover, other pages are accessible, see below for an example.

    I tried reinstalling HS4 from scratch - decompressing the downloaded file, renaming the previous directory, etc... No luck.

    So in summary:
    1- Everything was working fine this morning
    2- The HS4 web server is running because I can access other pages and do stuff (like add controllers, etc)
    3- It looks that <IP>/devices.html is the only page that is inaccessible
    4- A clean install (brute force reinstating the HomeSeer directory from the download) is not helping - I had to install the controllers again, etc, which worked fine - but the devices page is still inaccessible.

    Since reinstalling the entire directory did not help, I wonder if a configuration and/or cache file is at fault elsewhere in the rpi. I have not been able to determine if there are caches or configs elsewhere.

    Appreciate your help please.

    Miguel
    Attached Files

  • #2
    Adding the log - which is clean (I removed the license number)
    Attached Files

    Comment


    • #3
      Solved by reinstalling the rpi4 OS, updating mono to v6.10, adding the additional mono requirements, and then installing HomeSeer. It looks like HS4 needs the newer version of mono as it was wonky before - the raspbian repository has an older version of mono (v5.x).

      Comment

      Working...
      X