No announcement yet.

HSTouch Client - Won't Connect

  • Filter
  • Time
  • Show
Clear All
new posts

    HSTouch Client - Won't Connect

    Hello folks,

    I'm a few weeks into my HS4 configuration - all going well so far. Today I've decided to get my wall tablet configured, and I'm just having no luck getting the HSTouch Client to connect to HomeSeer.

    My setup:

    - OS: Windows 2016 Server
    - Hardware: Dell R730
    - Interface: Z-Stick
    - HS is running on the Host (not virtual machine)

    To date, everything has been going well. I have over 20 Z-Wave devices connected, and everything has been working as expected.

    I've opened the HSTouch Designer, and it's able to connect to HomeSeer. I've created a very simple "test" app that I wanted to deploy to HSTouch on a new Fire HD 10 Tablet that I'll be using for a wall interface. I've installed HSTouch on the tablet, configured "Server 1" with the IP address of the HS Server, the username I'm using to login to the web console, and the password I'm using to login to the web console.

    No luck - it just spins saying it's connecting. I've since tried creating a new HS user and using that one - no luck.

    I did note that the server currently has 2 physical NICs and 2 virtual NICs. HS seams to start-up using one of the virtual NICs (showing this IP in its logs), but I've confirmed that at least the web interface responds on the physical NICs, as well... so that may be a red herring. None the less, I've tried connecting in HSTouch Client over both the physical and virtual NICs. Same result - it just spins. In HSTouch Designer, I'm connecting using one of the physical NIC IPs.

    Any thoughts? I've tried HSTouch Client on both my Android phone and now Fire HD 10 Tablet - both have the same failed result. Am I just using the wrong credentials? Some other user/password I'm missing? From the HS logs, the last thing it seems to indicate is that the HSTouch Server is started and waiting for clients.

    A bit at a loss! Thanks for your help!

    In your firewall on the HS server, you need to open up inbound access on TCP port 10200, or allow all inbound ports for the HS application.

    10200 is the port HS app listens on for HSTouch client requests.


      zwolfpack Thanks! Yes, was just coming back here to say it was resolved. I thought Windows Firewall was indeed allowing HS4.exe, but there was another down-stream network policy I needed to address. Realized it was a network problem after testing out the local HSTouch and had no issue connecting.

      Thanks again!