Announcement

Collapse
No announcement yet.

HS4 and Homebridge

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HS4 and Homebridge

    Hi

    I am trying to setup homebridge with HS4 but I am getting following error . Any help is appriciated

    [8/4/2020, 7:30:45 PM] Registering platform 'homebridge-config-ui-x.config'
    [8/4/2020, 7:30:45 PM] ---
    [8/4/2020, 7:30:45 PM] Loaded plugin: homebridge-homeseer4@1.0.5
    homebridge API version: 2.6
    [8/4/2020, 7:30:45 PM] Registering platform 'homebridge-homeseer4.HomeSeer'
    [8/4/2020, 7:30:45 PM] ---
    [8/4/2020, 7:30:45 PM] Loading 2 platforms...
    [8/4/2020, 7:30:45 PM] [HomeSeer] Initializing HomeSeer platform...
    [8/4/2020, 7:30:45 PM] [HomeSeer] Start
    [8/4/2020, 7:30:45 PM] [Config] Initializing config platform...
    [8/4/2020, 7:30:45 PM] [Config] Running in Service Mode
    (node:134508) UnhandledPromiseRejectionWarning: TypeError: getStatusInfo.Devices is not iterable
    at HomeSeerSystem.initialize (/usr/lib/node_modules/homebridge-homeseer4/lib/HomeSeerSystemObject.js:477:42)
    at processTicksAndRejections (internal/process/task_queues.js:97:5)
    at HomeSeerPlatform.accessories (/usr/lib/node_modules/homebridge-homeseer4/index.js:96:24)
    (node:134508) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_...ejections_mode). (rejection id: 1)
    (node:134508) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.



    Here is my config.json which looks to be parsing fine


    {
    "bridge": {
    "name": "Homebridge",
    "username": "0E:9D:E2:98:1E:12",
    "port": 51691,
    "pin": "123-45-678"
    },
    "accessories": [],
    "platforms": [
    {
    "platform": "HomeSeer",
    "name": "HomeSeer",
    "host": "http://127.0.0.1",
    "login": "user",
    "password": "password",
    "ASCIIport": 11000,
    "events": [
    {
    "name": "All lights off",
    "eventGroup": "Lighting",
    "eventName": "All lights off",
    "uuid_base": "All lights off"
    }
    ],
    "lightbulbs": [
    18,
    138,
    63,
    60,
    57,
    54,
    51,
    48,
    45,
    42,
    36,
    134,
    133,
    132
    ],
    "accessories": [
    {
    "type": "GarageDoorOpener",
    "name": "MyQ Garage Door Main",
    "ref": 135,
    "closedValue": 3,
    "openValue": 1
    },
    {
    "type": "GarageDoorOpener",
    "name": "MyQ Garage Door Side",
    "ref": 136,
    "closedValue": 3,
    "openValue": 1
    },
    {
    "type": "Lock",
    "name": "Front Door",
    "ref": 22
    },
    {
    "type": "ContactSensor",
    "name": "Backyard Door Sensor",
    "ref": 100
    }
    ]
    },
    {
    "name": "Config",
    "port": 8581,
    "platform": "config"
    }
    ]
    }

    #2
    You have registered "accessories" but outside the category



    These details got to be correct :

    {
    "platform": "HomeSeer",
    "name": "HomeSeer",
    "host": "http://127.0.0.1",
    "login": "user",
    "password": "password",


    And also the devices listed must exist in HomeSeer.


    This is in the wrong place :

    {
    "name": "Config",
    "port": 8581,
    "platform": "config"
    }
    ]




    But also the also that plugin author says you should post questions on Git Hub because he doesn't have a forum here.


    Eman.
    TinkerLand : Life's Choices,"No One Size Fits All"

    Comment


      #3
      Thanks but even this basic setup is not working


      Here is the JSON file

      https://pastebin.com/raw/YUWRMRfF

      Error is



      [8/5/2020, 3:00:27 PM] Loaded config.json with 0 accessories and 1 platforms.
      [8/5/2020, 3:00:27 PM] ---
      [8/5/2020, 3:00:27 PM] Loaded plugin: homebridge-homeseer4@1.0.5
      homebridge API version: 2.6
      [8/5/2020, 3:00:27 PM] Registering platform 'homebridge-homeseer4.HomeSeer'
      [8/5/2020, 3:00:27 PM] ---
      [8/5/2020, 3:00:27 PM] Loading 1 platforms...
      [8/5/2020, 3:00:27 PM] [HomeSeer] Initializing HomeSeer platform...
      [8/5/2020, 3:00:27 PM] [HomeSeer] Start
      (node:173124) UnhandledPromiseRejectionWarning: TypeError: getStatusInfo.Devices is not iterable
      at HomeSeerSystem.initialize (/usr/lib/node_modules/homebridge-homeseer4/lib/HomeSeerSystemObject.js:477:42)
      at processTicksAndRejections (internal/process/task_queues.js:97:5)
      at HomeSeerPlatform.accessories (/usr/lib/node_modules/homebridge-homeseer4/index.js:96:24)
      (node:173124) UnhandledPromiseRejectionWarning: Unhandled promise rejection. This error originated either by throwing inside of an async function without a catch block, or by rejecting a promise which was not handled with .catch(). To terminate the node process on unhandled promise rejection, use the CLI flag `--unhandled-rejections=strict` (see https://nodejs.org/api/cli.html#cli_...ejections_mode). (rejection id: 1)
      (node:173124) [DEP0018] DeprecationWarning: Unhandled promise rejections are deprecated. In the future, promise rejections that are not handled will terminate the Node.js process with a non-zero exit code.



      This is what I have installed

      root@homrsrv:~/.homebridge# npm -g list --depth=0
      /usr/lib
      ├── homebridge@1.1.1
      ├── homebridge-homeseer4@1.0.5
      └── npm@6.14.6


      root@homrsrv:~/.homebridge# node -v
      v12.18.3









      Comment


        #4
        Try this :

        Code:
        {
        "bridge": {
        "name": "Homebridge",
        "username": "0E:9D:E2:98:1E:12",
        "port": 51691,
        "pin": "123-45-678"
        },
        "platforms": [{
        "platform": "HomeSeer",
        "name": "HomeSeer",
        "host": "http://127.0.0.1",
        "login": "user",
        "password": "password",
        "ASCIIport": 11000,
        "events": [{
        "name": "All lights off",
        "eventGroup": "Lighting",
        "eventName": "All lights off",
        "uuid_base": "All lights off"
        }],
        "lightbulbs": [
        18,
        138,
        63,
        60,
        57,
        54,
        51,
        48,
        45,
        42,
        36,
        134,
        133,
        132
        ],
        "accessories": [{
        "type": "GarageDoorOpener",
        "name": "MyQ Garage Door Main",
        "ref": 135,
        "closedValue": 3,
        "openValue": 1
        },
        {
        "type": "GarageDoorOpener",
        "name": "MyQ Garage Door Side",
        "ref": 136,
        "closedValue": 3,
        "openValue": 1
        },
        {
        "type": "Lock",
        "name": "Front Door",
        "ref": 22
        },
        {
        "type": "ContactSensor",
        "name": "Backyard Door Sensor",
        "ref": 100
        }
        ]
        },
        {
        "name": "Config",
        "port": 8581,
        "platform": "config"
        }
        ]
        }

        Make sure your HomeSeer details are correct.

        Your initial code had "accessories" defined twice.


        And I think don't need the HomeSeer Port or can be defined on the next line as "port": (---------your port without quotes),


        or this one :
        Code:
        {
        "bridge": {
        "name": "Homebridge",
        "username": "0E:9D:E2:98:1E:12",
        "port": 51691,
        "pin": "123-45-678"
        },
        "platforms": [{
        "name": "HomeSeer",
        "host": "http://127.0.0.1",
        "login": "user",
        "password": "password",
        "ASCIIport": 11000,
        "events": [{
        "name": "All lights off",
        "eventGroup": "Lighting",
        "eventName": "All lights off",
        "uuid_base": "All lights off"
        }],
        "lightbulbs": [
        18,
        138,
        63,
        60,
        57,
        54,
        51,
        48,
        45,
        42,
        36,
        134,
        133,
        132
        ],
        "accessories": [{
        "type": "GarageDoorOpener",
        "name": "MyQ Garage Door Main",
        "ref": 135,
        "closedValue": 3,
        "openValue": 1
        },
        {
        "type": "GarageDoorOpener",
        "name": "MyQ Garage Door Side",
        "ref": 136,
        "closedValue": 3,
        "openValue": 1
        },
        {
        "type": "Lock",
        "name": "Front Door",
        "ref": 22
        },
        {
        "type": "ContactSensor",
        "name": "Backyard Door Sensor",
        "ref": 100
        }
        ]
        },
        {
        "name": "Config",
        "port": 8581,
        "platform": "config"
        }
        ]
        }



        Eman.
        TinkerLand : Life's Choices,"No One Size Fits All"

        Comment


          #5
          Hi there, I'm getting the same error message that you were.

          Did this end up being a config issue for you mmoud ?

          (I've posted the details of my issue at https://github.com/jvmahon/Homebridg...er4/issues/142) .

          Thanks!

          Comment


            #6
            Greetings,

            Give this a try...

            You'll notice that I had to bind my network adapter.
            I'm running homebridge-homeseer4 v1.0.17 is your plugin up to date?
            I've only included the one contact sensor to simplify things. Try it first.

            Code:
            {
            "bridge": {
            "name": "Homebridge",
            "username": "0E:9D:E2:98:1E:12",
            "port": 51691,
            "pin": "123-45-678",
            "bind": [
            "wlan0"
            ]
            },
            "platforms": [
            {
            "name": "HomeSeer",
            "host": "http://127.0.0.1",
            "ASCIIport": 11000,
            "login": "xxxxxx",
            "password": "xxxxxx",
            "accessories": [
            {
            "type": "ContactSensor",
            "name": "Backyard Door Sensor",
            "ref": 100
            }
            ],
            "platform": "HomeSeer"
            },
            {
            "name": "Config",
            "port": 8088,
            "auth": "form",
            "theme": "blue",
            "tempUnits": "f",
            "lang": "auto",
            "platform": "config"
            }
            ],
            "accessories": []
            }

            ​​​​​​​Roger D

            Comment


              #7
              Thanks Roger. Turns out I didn't have the JSON interface enabled. In another weird twist the tickbox for enabling the ASCII interface in my HS3 became inverted. i.e. Needed to remove the selection to enable the ASCII interface. The plugin author was very supportive when I reached out on Github. The link is in my previous post. Thanks.

              Comment

              Working...
              X