Announcement

Collapse
No announcement yet.

Homeseer motion sensor not triggering events continuously

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Homeseer motion sensor not triggering events continuously

    Hi,

    Relatively new to Homeseer, so sorry if this is a silly question. Trying to get my garage motion sensor to trigger the lights in the garage. I want them to come on when motion is sensed, stay on for 10 min unless there is motion triggered. If motion is sensed again, restart the 10min timer. (For testing i set the value in the event to 1 min)

    It will run the event once, but then wont keep the lights on if im moving around in front of it. Even running the event again a second time takes several minutes before it will fire up again. Is that a homeseer motion device config problem or my event not scripted properly? Thanks for the help.

    Click image for larger version  Name:	garage lights on.JPG Views:	2 Size:	22.8 KB ID:	1418134Click image for larger version  Name:	garage lights off.JPG Views:	2 Size:	27.1 KB ID:	1418133

    #2
    I am doing something pretty similar but if I recall correctly I am resetting the timer. In your case you are just starting it which I think makes it continue rather than restart from 0.

    Comment


      #3
      Also check the timeout duration on your sensors. Some motions wait up to a few minutes before another motion signal is sent. I use mostly Ecolink PIRZWAVE2.5-ECO and keep them in test mode all the time so they timeout in just a few seconds.
      -Wade

      Comment


        #4
        Click image for larger version

Name:	CAEEC2C2-40A6-4AD4-8055-76B2587F3C11.jpeg
Views:	53
Size:	117.0 KB
ID:	1418180

        Click image for larger version

Name:	4D68BE83-B353-4B1B-9516-626DCFA906A8.jpeg
Views:	55
Size:	114.2 KB
ID:	1418181
        Michael

        Comment


          #5
          Originally posted by mulu View Post
          I am doing something pretty similar but if I recall correctly I am resetting the timer. In your case you are just starting it which I think makes it continue rather than restart from 0.
          That was what my forum browsing brought up as well about the reset, but its not an option in my event drop down. I only have Start, stop, resume, or set time. Is it not available in HS4 maybe? EDIT** I assume i can set to time and have it set back to zero.Click image for larger version  Name:	set to time.JPG Views:	0 Size:	16.2 KB ID:	1418183

          Comment


            #6
            I think your 1 minute time to test is too short. Try 5 minutes at the least.
            Michael

            Comment


              #7
              Does your motion sensor actually go back to "no motion" immediately?

              Mine don't turn off for a configurable time after they stop sensing movement, i.e. all the functionality you're doing is actually in the sensor.

              All I need is events for motion = lights on and no motion = lights off.

              This would explain the symptoms - lights come on for a minute, then go off because no sensor trigger received. After X minutes of no motion the sensor sends No Motion and is re-armed, but before that movement makes no difference except to extend the period of the sensor being "on".

              ps realised after I posted this that cc4005 said effectively the same thing.

              Comment


                #8
                Got it sorted. It was that the motion timeout interval in the device was too high. Still set for default of 10min. I also changed the timer to set to zero everytime it senses motion. So either one/combo of both those made it work. Thanks a lot folks!

                Comment


                  #9
                  For most motion sensors, they send a "motion" signal to HS and then after there has been no motion for a programmable parameter (call it "Timeout") seconds, the motion sensor will send a "no motion" signal to HS. Those two signals are all you need for your situation to turn the light on then off(after the "Timeout" programmed into the motion sensor). NO Timer needed!
                  It might be constructive to tell us what type of sensor you are using.

                  Comment


                    #10
                    Here's an alternative that doesn't require a "motion off" signal (post #4)

                    https://forums.homeseer.com/forum/ho...ed-event-logic

                    Comment

                    Working...
                    X