Announcement

Collapse
No announcement yet.

Error, Unable to connect speaker client interface: Not Authorized

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #46
    zwolfpack ,
    Your findings very good and it's mirrors Rupp 's post # 43 but your additional notes not on the ball.

    YouElz is trying to deal with different clients. We were trying to fix all of them.
    HomeSeer uses Desktop, Android, iOS and I don't know about the Kindles as Speaker Clients. That's why he was providing all sorts of logs and images.
    • If you don't define any HomeSeer Speaks to all them.
    • The connection causing problems is coming from from an external IP and thus user default should not be allowed. That's what's got to be fixed

    Eman
    TinkerLand : Life's Choices,"No One Size Fits All"

    Comment


      #47
      Thanks the workaround and this last post stopped
      me tearing my hair out!

      Cheers,

      Jon.

      Comment


        #48
        , Rupp and Eman thank you all for trying to help... providing tons of information I did not know before...

        So just for PoC I followed zwolfpack instruction by entering the speakeruser "YouElz" and userpassword parameters in the settings.ini " of course the password is not encrypted" > It actually worked perfectly when connected from an external IP address and my iPhone acted as the speaker.

        Of course I can't keep my password like that written in plain English; so I remove it as soon as I am done testing..

        Click image for larger version  Name:	Capture2.JPG Views:	0 Size:	32.2 KB ID:	1428491
        Click image for larger version  Name:	Capture1.JPG Views:	0 Size:	26.3 KB ID:	1428492


        So my humble opening leaning toward a bug now, as why the settings.ini does not get updated with speakeruser and spearkpassword once updated at the application layer (HS4)..


        Rupp and Eman what do you guys think?

        Comment


          #49
          Yes the fact that it's not getting added to the ini file appears to be a bug.
          -Rupp
          sigpic

          Comment


            #50
            Well, well,

            Because I have the old code (I have always updated to a new version)

            For now Just change your user name to something else because your current one has been around the world and back. ???? Don't know about this one

            But until HST fixes what zwolfpack said was a no-no everyone will just have live with that. But I think if the device connects via the email user then it would be a safe connection

            Only the High Priests (HST) and / or zwolfpack can explain better.

            Q : I wonder if leaving the main settings (HStouch) blank may affect it? Else, there is a setting to let the Local users without logging in first..............???

            Eman.
            TinkerLand : Life's Choices,"No One Size Fits All"

            Comment


              #51

              Eman
              For now Just change your user name to something else because your current one has been around the world and back. ???? Don't know about this one
              🤣 anyone is welcome to turn on and off my house lights...


              How can we report a bug then? I have a ticket opened with support already...

              Comment


                #52
                The bug was uncovered by you guys.
                It is not by design a bug and hence the reason the email user account. And not to login remotely using your Admin user name.

                If it gets worked on is another issue.

                Maybe not to use HStouch remotely or if someone explains the transactions how the system connects to MyHS.....??

                I checked that's what everyone has.


                Eman
                TinkerLand : Life's Choices,"No One Size Fits All"

                Comment


                  #53
                  Thanks for this thread! It was driving me crazy!

                  I can confirm that updating the "Speaker Username" and "Speaker Password" in the HS4 setup updates the HSPI_HSTouch.ini, but it is not being used when a HSTouch client connects. You'll have to manually add speakeruser and speakerpass in Settings.ini for that... (in plain text)

                  Time for a bugfix!
                  stefxx

                  Comment


                    #54
                    stefxx
                    The ticket is still in Pending Status since Nov 30th, 2020


                    Click image for larger version

Name:	Capture.JPG
Views:	29
Size:	86.0 KB
ID:	1466075
                    ​​​​​​​

                    Comment


                      #55
                      Thank you for this thread. I spent most of a day trying to figure out why I was so stupid - not being able to figure out which passwords went where on my HSTouch device. I've been connecting through MyHS fine since I started working with HS and HSTouch, but wanted to connect locally so I don't have to rely on external networking. Well, nothing worked until I found this thread, and made the change to the settings.ini file. With that in place, everything works. I only feel a little violated by having my unencrypted password hanging out there.

                      Thanks,
                      Mark

                      Comment

                      Working...
                      X