Announcement

Collapse
No announcement yet.

Pi/ZeeS2 - Broke MyHS/Find.homeseer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Pi/ZeeS2 - Broke MyHS/Find.homeseer

    The Problem:
    I can no longer connect to MyHS, I get HomeSeer is not running. Find.homeseer.com shows no systems.
    Profile report shows WAN IP Address is blank.

    Troubleshooting:
    I ran traceroute from terminal on my Mac and from the ZeeS2 using SSH. I get
    www.google.com 142.250.68.110
    Mac Runs Runs
    Pi Fails Runs
    Fail return is: "google.com: Name or service not known
    Cannot handle "host" cmdline arg `google.com' on position 1 (argc 1).

    Also,
    homeseer@HomeTrollerZeeS2V3:~ $ route -n
    Kernel IP routing table
    Destination Gateway Genmask Flags Metric Ref Use Iface
    0.0.0.0 192.168.11.1 0.0.0.0 UG 202 0 0 eth0
    192.168.11.0 0.0.0.0 255.255.255.0 U 202 0 0 eth0

    Conclusion:
    I'm a damn good sparky, but I suck at software and networks. In addition, it appears to be a DNS resolving issue? Clearly the Pi is not able to get my WAN IP for some reason.

    I'm waiting for tech support, but it appears they are backed up and I was hoping I could get some help from somebody more network/Pi conversant than me.

    Background:
    Things had been running fine on the ZeeS2 with the as-supplied older rev of HS3.
    Contrary to all good practices, I changed at least a dozen (big) variables in a short time frame, so I don't know exactly what caused the issue. The main suspect: I replaced my entire network with Ubiquiti gear about 3 weeks ago. Part of the process is installing VLANs for all the IOT stuff and gateway flow control for the LAN. Then, to prepare for HS4, I upgraded to 3.0.0.551. I then bought a 32gb SD card and transferred everything to the new card. I got it done, but it was still in an 8gb partition. I installed and booted sucessfully, but it was at at this point that I discovered I couldn't reach MyHS/Find.homeseer. I don't know how long it has been broken. While the usual suspects would be my network configuration, in my defense I must point out:
    1. Moving the ZS2 from my IOT VLAN to the main admin LAN did not help.
    2. Changing back to the original SD card did not help.
    3. I have at least a dozen other IoT devices on my IoT VLAN that have no problem talking to the web.
    4. I have cross pinged every combination of lan subnets and they all are behaving exactly as they should.
    5. I've tried changing DHCP to fixed, changing gateway... everything else I could think of in HS3 Settings/network.

    One other potential piece of evidence is my DDNS. When I had my Asus, I used their native DDNS service to get my WAN IP. I also was running a DDNS service on my Synology NAS, but a whatismyip.com showed that my WAN IP was the ASUS number. With the ASUS out of the picture, my WAN IP is now the value set by my NAS.

    Any help would be greatly appreciated!

    #2
    DNS config is at /etc/resolv.conf. Should look something like
    Code:
    nameserver 192.168.1.1
    Depending on your network configuration (DHCP/static) this might be automatically generated.

    Comment


      #3
      Thanks zwolfpack, I had done a lot of plowing on both HomeSeer and Pi forums and had run across several of your posts that were very helpful. One of the things I had tried was:
      homeseer@HomeTrollerZeeS2V3:~ $ cat /etc/resolv.conf
      # Generated by resolvconf

      Which I interpreted to mean that no nameserver was found, but I wasn't sure if /etc/resolv.conf was used on the ZeeS2 w/Homeseer installed. OK, so it looks like you're saying it should exist and point to my router, which would be 192.168.11.1 and not to my WAN IP, right? And how do I get it in there?

      Another of the things I have tried is following the HS4 Clean Install process on my new 32gb card to see if that would get around this issue. Here is a shot of the end of the install process:

      At first I thought this was a flag that showed the issue may actually be with the ZWave interface, but after the other tests I had settled on DNS as the root cause. I raise this issue here only because I read your exchange on "Can't update anything in Z-Net interface" and wonder if the ZWave interface might be involved? It is worth noting that this is a different card, new version of HS (4 vs 3), updated OS, and I'm still not getting any WAN IP love.
      NOTE: I've switched back to HS3 on the original 8gb SD card until I get this resolved.

      One of the things I have tried is changing from DHCP to fixed (and back, multiple times and combinations) in Homeseer/Settings/Network. Normally I don't like setting fixed IP at the device level, I prefer DNS reservations at the router level. I've attached below one of the configs I tried. I also tried with DNS (nameserver) pointed at my router. No config I've tried so far seems to result in an entry in /etc/resolv.conf.

      Am I at least on course that this is a Pi/Homeseer issue and not a network issue?

      Thanks again for your help.
      Attached Files

      Comment


        #4
        Generally when configured for DHCP, DNS server info is provided in the DHCP packet and that gets written to /etc/resolv.conf (by resolvconf).

        What OS version are you running?
        Code:
        more /etc/os-release
        Look for VERSION

        Next, the network configuration.
        Code:
        more /etc/network/interfaces
        This will likely change when you modify things on HomeSeer Settings->Network, so both DHCP and static configurations would be helpful.

        Comment


          #5
          OS
          NAME="Raspbian GNU/Linux"
          VERSION_ID="8"
          VERSION="8 (jessie)"


          NETWORK INTERFACES
          Using STATIC IP (both enet & WiFi), Gateway = 192.168.11.1, DNS IP address = 192.168.11.1
          Note that the header includes comment:
          homeseer@HomeTrollerZeeS2V3
          :~ $ more /etc/network/interfaces

          # Please note that this file is written to be used with dhcpcd
          # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'

          # Include files from /etc/network/interfaces.d:
          source-directory /etc/network/interfaces.d


          Results:
          auto lo
          iface lo inet loopback

          iface eth0 inet dhcp

          allow-hotplug wlan0
          iface wlan0 inet manual
          wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf

          allow-hotplug wlan1
          iface wlan1 inet manual
          wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf


          Using DHCP on both interfaces:
          Exact same results!

          I'm really confused why the first run returned eth0 = dhcp. Looks like something wrong to an ignorant sparky; or per the header comment, should I be using a different command?

          I did reboot between runs, of course.
          Thanks again for the help!

          Comment


            #6
            Just to be sure, check if there's anything in /etc/network/interfaces.d/ (I expect not).

            Another file to check is
            Code:
            more /etc/dhcpcd.conf
            This is where static IP's are "supposed" to be set.

            I posted this in another thread earlier today:

            https://raspberrypi.stackexchange.co...aspberry-pi-os

            Under section "Notes on obsolete Operating Systems", the recommend contents of /etc/network/interfaces is listed for the "jessie" OS

            Code:
            # interfaces(5) file used by ifup(8) and ifdown(8)
            
            # Please note that this file is written to be used with dhcpcd
            # For static IP, consult /etc/dhcpcd.conf and 'man dhcpcd.conf'
            
            # Include files from /etc/network/interfaces.d:
            source-directory /etc/network/interfaces.d
            
            auto lo
            iface lo inet loopback
            
            iface eth0 inet manual
            
            allow-hotplug wlan0
            iface wlan0 inet manual
                wpa-conf /etc/wpa_supplicant/wpa_supplicant.conf
            Note that this matches what you have, with exception of where highlighted. You might try changing that.

            Also maybe try using your router IP address (192.168.11.1) for DNS server address, rather than 1.1.1.1.

            Comment


              #7
              Don't really know what I'm doing here, but ssh to pi, cd to /etc/network, nano -w interfaces, changed "dhcp" to "manual", exit, verified edit took. Changed Network settings in ZS2 to dhcp on both interfaces, rebooted ZS2.

              Nothing in /etc/network/interfaces.d/ (before or after interfaces modification).

              In dhcpcd.conf, I didn't find any static IP's, but I noticed that after I edited the interfaces file and rebooted, there was 1 difference in this file. Before the edit, the file ended with:
              Code:
              # a hook script is provided to lookup the hostname if not set by the dhcp
              # server, but it should not be run by default.
              nohook lookup-hostname
              nohook resolv.conf
              After the edit, the "nohook resolv.conf" was gone.

              In my prior post, I listed under Network Interfaces that my DNS server was currently pointing to router address 192.168.11.1. Of course, that dissapears when you check dhcp in Settings/Network...

              After the edit and reboot, I'm still where I started: no WAN IP and no MyHS.

              EDIT: Whoops,
              Code:
              iface eth0 inet dhcp
              is back. Don't know if it got changed or I screwed up. I'll try again.

              EDIT:
              It was a write permissions problem. Now the "interfaces" file does have eth0 set to "manual". Also, the "dhcpcd.conf" file got "nohook resolv.conf" back. Not sure what happened before.

              Still no WAN/MyHS, etc.

              Comment


                #8
                For your jessie OS version, the prescribed method to assign an IP address is:

                /etc/network/interfaces as in post #6

                Then in /etc/dhcpcd.conf, add static IP info:
                Code:
                interface eth0
                static ip_address=192.168.11.108/24
                static routers=192.168.11.1
                static domain_name_servers=192.168.11.1
                the last two lines specify the default gateway and DNS server(s), respectively. DNS server IP's are space separated if more than one.

                https://www.raspberrypi.org/document...uration/tcpip/

                Comment


                  #9
                  OK, zwolfpack, thanks a ton for your help and patience, but that one didn't go so well. Here is what I did:
                  1. In HS3, Settings/Network, changed both interfaces backed to static as shown in post #3 except that DNS IP in both locations was same as router: 192.168.11.1.
                  2. Edit /etc/network/interfaces to set eth0 to "manual" as in post #6.
                  3. Added code from #8 to end of /etc/dhcpcd.conf
                  4. Rebooted.

                  Now I can' t connect. My Unifi UDM shows its connected and communicating, but I can't ssh in, and the browser times out trying to connect. Whoops.

                  Luckily, I have the 32gb SD with HS4 which I will try to boot now, but since I couldn't register HS4 last time because it couldn't connect to the internet, I may be DOA. And that started me thinking about the HS4 fresh install: since the HS4 fresh install process loads a whole new OS and uses default networking config, if it doesn't work, doesn't that mean the problem must be a compatibility issue between the Pi and the UDM?

                  If there is anything you can think of to revive my HS3 SD card, I'm all ears. Meanwhile, I think I'll try booting the new card and see how far I get.

                  Comment


                    #10
                    Easiest way to get back in is to connect a keyboard and monitor. Then remove the additions to /etc/dhcpcd.conf

                    Starting fresh may be you best plan. The jessie OS you're currently running is two revisions behind the latest one (10 buster). And this one's networking is being a b***h!!

                    Comment


                      #11
                      Here's another tutorial on setting a static IP on jessie.

                      https://thepihut.com/blogs/raspberry...address-update

                      It basically says the same thing at the one from post #8.

                      This is a 'clean' copy of jessie's /etc/dhcpcd.conf, in case you want to compare it to what you have. The 'clean' /etc/network/interfaces is as in post #6.
                      Code:
                      # A sample configuration for dhcpcd.
                      # See dhcpcd.conf(5) for details.
                      
                      # Allow users of this group to interact with dhcpcd via the control socket.
                      #controlgroup wheel
                      
                      # Inform the DHCP server of our hostname for DDNS.
                      hostname
                      
                      # Use the hardware address of the interface for the Client ID.
                      clientid
                      # or
                      # Use the same DUID + IAID as set in DHCPv6 for DHCPv4 ClientID as per RFC4361.
                      #duid
                      
                      # Persist interface configuration when dhcpcd exits.
                      persistent
                      
                      # Rapid commit support.
                      # Safe to enable by default because it requires the equivalent option set
                      # on the server to actually work.
                      option rapid_commit
                      
                      # A list of options to request from the DHCP server.
                      option domain_name_servers, domain_name, domain_search, host_name
                      option classless_static_routes
                      # Most distributions have NTP support.
                      option ntp_servers
                      # Respect the network MTU.
                      # Some interface drivers reset when changing the MTU so disabled by default.
                      #option interface_mtu
                      
                      # A ServerID is required by RFC2131.
                      require dhcp_server_identifier
                      
                      # Generate Stable Private IPv6 Addresses instead of hardware based ones
                      slaac private
                      
                      # A hook script is provided to lookup the hostname if not set by the DHCP
                      # server, but it should not be run by default.
                      nohook lookup-hostname

                      Comment


                        #12
                        zwolfpack Thanks! At last I was 1 step ahead: post 10 is exactly what I did, but to no avail. I decided to swap out my HS3 SD for the fresh install of HS4 that didn’t complete when I first tried it. This time I had a little better luck, since I figured out that my “head” setup was using an enet port on my Guest VLAN, so of course it couldn’t get out (not the problem with the HS3 headless setup). Now FINALLY find.Homeseer.com finds something!

                        Unfortunately, it finds “HTPiHubG1 Maintenance”, which doesn’t exactly follow the install script:
                        1. Once the install is done restart the system and locate HS4 using find.homeseer.com from a web browser.
                        2. You will be brought to the registration screen. Enter your HS4 license and follow the prompts to complete.
                        The 1st time it loads, the whole phrase is one link. The second time the Hub and the Maintenance link are separate, but the hub link won’t load (site can’t be reached) and the Maintenance page doesn’t give me any place to register, and the only thing that seems to be applicable is
                        Update System
                        This updates your system if HS4 does not run correctly. This may take up to 45 minutes or not work if your system is too old. Your system will reboot upon completion
                        Which didn’t work.

                        I’m really close to chucking this. I don’t know if I should buy a pre-config HS Pi (which is a 3), buy a naked 4 and start from scratch (sounds scary with my skill level), or just try moving to Apple Home. Pretty disappointing.

                        Comment


                          #13
                          I'm up! Sheesh, what an ordeal. It took 3 installs, and some guessing, but after hammering at it for hours I'm up and flying on HS4.

                          Comment

                          Working...
                          X