Announcement

Collapse
No announcement yet.

Someone has gotta have a theory why this is possible...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Someone has gotta have a theory why this is possible...

    I first posted this in the DirecTV forum because the weirdness came from an element linked to a device from that plug-in, but spud thought someone in the HSTouch forum might have an idea what's happening. Crickets in both forums, so I thought I'd try a wider audience.

    I have a text field that has its StatusTracking set to the plug-in's Title of the current DirecTV program being viewed. It looks like this, as it should, on all the other clients:

    Click image for larger version  Name:	HSTouch DirecTV Correct.jpg Views:	21 Size:	104.4 KB ID:	1437122​​

    I have one old Samsung Note 12.2" tablet from 2014 that the text box occasionally shows an image with a play button. I didn't pay too much attention to it, until one time I hit the button. Check out what it did (lower left of the screen):



    Yep, that was the video feed from DirecTV, but I don't think that should even be possible! I ran to one of the other tablets and took the above pic while the mini video was playing on the Samsung tablet.

    It would obviously be useful if there is a way to capture live TV on HSTouch via the DirecTV plug-in, but I can't recreate this intentionally. It doesn't happen very often, and there doesn't seem to be anything consistent in the system when it does.

    Here's all the info in case someone wants to hazard a theory:
    • There's nothing unusual about the text element in HSTouch Designer - it's a button that opens a media control screen on the tablet, and its StatusTracking is set to the DirecTV current title device (see below for screen grab).
    • The other clients are Fire HD tablets of different flavors, and LG & Samsung smartphones. It only happens on the old Samsung tablet.
    • The old Samsung tablet does have some issues, specifically with the Sonos plug-in (HSTouch crashes sometimes when selecting music on it), but other than that it functions as expected.
    • There was nothing unusual/helpful in the HS log or Windows Event Viewer.
    • I don't think this is an HS3 vs. HS4 or hardware issue. This first happened in HS3 on a high-end Frankencomputer I built. The above video & pic was taken after migrating to HS4 that is now running on a Beelink NUC. Not sure it matters, but here is the current setup in case that helps:

    Date/time=12/6/2020 8:46:52 AM Eastern Standard Time
    Version=HS4 Pro Edition 4.1.9.0 (Windows)
    License=Registered
    Confguration File=C:\Program Files (x86)\HomeSeer HS4\Data\HomeSeerData.json
    In Virtual Machine=No MFG: azw
    Antivirus=Windows Defender
    OS=Microsoft Windows 10 Pro - Work Station
    OS Version=10.0.18363
    Uptime=11 Days 14 Hours 11 Minutes 43 Seconds
    Lan IP=192.168.1.213 (HomeSeerServer)
    Device Count=701
    Event Count=224
    Processor:=Intel64 Family 6 Model 61 Stepping 4 at 2.51 GHz
    Modules/Threads=153 Modules, 185 Threads
    Available Threads=1023
    System Load=198 Processes, 8% Load
    Free/Total Memory=4.16 GBytes / 7.90 GBytes (53% free)
    Free/Total Virtual Memory=3.99 GBytes / 9.15 GBytes (44% free)
    HomeSeer Memory Used=125 Mbytes
    Plugin Memory Used=15 EXE Plug-Ins using 420 Mbytes
    Plugins Installed=AK Bond 3.0.0.49,Alexa 3.0.0.1,BLDenon 2.0.57.0,BLLock 3.0.35.0,BLOccupied 2.0.28.0,BLRoombaWifi 2.0.37.0,BLShutdown 1.0.5.0,Blue-Iris 3.1.3.33206,BLUPS 2.0.26.0,DirecTV 3.0.0.20,DirecTV 3.0.0.20,EasyTrigger 3.0.0.71,MediaController 3.0.0.66,MyQ 1.2020.705.1301,Pushover 3P 0.0.0.52,SmartThings 4.0.15.0,Sonos 3.1.0.53,weatherXML 3.0.1.19,Z-Wave 3.0.2.0

    Here is the text element from Designer:

    Click image for larger version

Name:	DirecTV Element.PNG
Views:	174
Size:	392.3 KB
ID:	1438715

    I could just chalk this up to a really old tablet acting weird, but I don't think this is even possible: neither the HSTouch element nor the device it's linked to is a video feed.

    It's a total mystery to me. Any thoughts?
    Attached Files

    #2
    I have no HSTouch experience, but the fact it easily shows up on the Samsung tablet I'm going to guess DLNA. You can easily prove this out by going into the Samsung's settings and disabling DLNA to see if that stops it. I'm pretty sure the DirecTV boxes also support DLNA and you can try turning it off there.

    Just a WAG (wild *** guess).

    Comment


      #3
      Thanks TC1, I can turn it off. I think Samsung calls it AllShare.

      But really I want to see how to recreate it. Really the weird thing is that, as far as I know, the DirecTV plug-in doesn't offer a video feed, and that particular text element in Designer is just text.

      I'm just trying to figure out how it could even happen, and I'll take any other WAGs that anyone has to offer.

      Comment


        #4
        The PI doesn't have to do anything... somehow enough information is the HSTouch interface being displayed on the tablet for it to grab the DLNA stream that already exists on the network. Just a WAG

        Comment


          #5
          Wow, I was trying to check out what HBO Max offers via DirecTV, but I never got the chance. As soon as the music started playing on the big screen, ALL of my tablets in the house started playing the same music from the HBO Max video stream:



          It came from that same HSTouch element with StatusTracking set to the DirecTV plug-in's Title device. I know this because it can be paused by tapping the play button - but there shouldn't be a play button at all - this is just a frakking text element!

          At first, I thought the only way to stop it was turn off the DirecTV box then quit HSTouch and restart. Tried again, but this time I left half the tablets on one of 2 screens with that text element, and the others on screens without it. Only the tablets on one of those 2 screens with the DirecTV text element played the video stream.

          I had chalked it up to the old 2014 Samsung Galaxy Not 12.2 tablet not playing well with newer software. That's not it, some of the Fire HD tablets are from the Black Friday sale a couple of weeks ago.

          I'm thinking it must be plug-in related somehow, so I did reach out to spud in the media sub-forum again.

          HBO Max is a streaming channel so maybe it is DLNA related, but I'm not going to shut it off on all the tablets just because I want to try HBO Max (especially with Wonder Woman 1984 coming out on 12/25, and I am NOT going to a theater any time soon!!!).

          Comment


            #6
            Got it fixed, so if anyone else's DirecTV plug-in hijacks their HSTouch apps, here's the workaround:

            Set the DirecTV log to Debug and saw this when I switched the channel to HBO Max:
            Dec-11 9:06:31 PM DirecTV DEBUG { "callsign": "", "duration": 12, "expiration": "0", "expiryDate": "0", "expiryTime": 0, "isPartial": false, "isPclocked": 3, "isPpv": false, "isRecording": false, "isViewed": false, "isVod": false, "keepUntilFull": false, "major": 0, "minor": 0, "offset": 0, "programId": "", "rating": "No Rating", "startTime": 1607565930, "stationId": 0, "status": { "code": 200, "commandResult": 0, "msg": "OK.", "query": "/tv/getTuned?clientAddr=0" }, "title": "http://content.zonetv.cloud/files/media/1596847549591/videos/transcodes/mp4/TopLevelScreens_2400.mp4", "uniqueId": "-1" }
            Because the element was not wide enough to accommodate a long string, the HStouch screens didn't show that the DirecTV element had changed to http://content.zonetv.cloud/files/media/1596847549591/videos/transcodes/mp4/TopLevelScreens_2400.mp4.

            Because I can't control the plug-in's device string, I created a virtual one to use in Designer instead. Then created a simple event that copied the plugin's program Title to the new virtual device's status except when the title contains the problematic ".mp4" in it.

            Click image for larger version  Name:	HBO Max Event.PNG Views:	0 Size:	67.4 KB ID:	1440149

            The WAF takes a serious hit when all the tablets in the house are seemingly possessed and start playing the music that you can here in the video from the previous post!

            Comment

            Working...
            X