Announcement

Collapse
No announcement yet.

Disabling Windows 10 Auto Restart

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Disabling Windows 10 Auto Restart

    So, I've since moved my HS4 installation to a Windows 10 VM, and predictably, it wants to restart automatically when updates are applied.

    While I do have HS4 set to automatically start (through Task Scheduler), I'd preferably never have Windows unpredictably restart regardless. I THOUGHT I had this properly set by using group policy editor to turn off automatic restarts, but today it did so anyway.

    I found an additional article suggesting to rename the "Reboot" task to something like "Reboot.old" - so that's now done, as well. But I wanted to ask the forum members if they've found a reliable way to keep Windows Update from auto restarting. Again, I have HS4 set to start on reboot, but even 5 minutes of unpredictable downtime is unacceptable when it should be easily avoidable.

    I know the Linux fans will simply say, "Don't use Windows!" - but spare me that answer for the moment!

    #2
    I’m using a windows 7 Hometroller so it’s not an issue for me….yet…but I’ve seen a HS4 setting in the Setup>Labs tab and see if you have a check next to “Disable Windows Updates”. Not sure of that will actually work but it’s a start.


    Sent from my iPhone using Tapatalk
    HS4 4.2.6.0 &HSTouch Designer 3.0.80
    Plugin's:
    BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee, Nest, AK Bond
    EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
    weatherXML, Jon00 Alexa Helper, Network Monitor, MyQ, Z-Wave

    Comment


      #3
      Originally posted by The Profit View Post
      I’m using a windows 7 Hometroller so it’s not an issue for me….yet…but I’ve seen a HS4 setting in the Setup>Labs tab and see if you have a check next to “Disable Windows Updates”. Not sure of that will actually work but it’s a start.


      Sent from my iPhone using Tapatalk
      Thanks - I located that under Settings --> Labs and now turned that on, as well.

      Comment


        #4
        Post again if you find that this has been working for you. I’d like to know when I update to a mini pc with win10!


        Sent from my iPhone using Tapatalk
        HS4 4.2.6.0 &HSTouch Designer 3.0.80
        Plugin's:
        BLBackup, BLOccupied, BLShutdown, EasyTrigger, Ecobee, Nest, AK Bond
        EnvisaLink DSC, PHLocation, Pushover, SONOS, Blue Iris, UltraRachio3,
        weatherXML, Jon00 Alexa Helper, Network Monitor, MyQ, Z-Wave

        Comment


          #5
          I don't use HS on a windows PC, but even do this bug me a lot on my own desktop PC.
          I did few things to disactivate that, but lately it did reboot by itself and I lost my work running all the time on my PC
          Never had an issue with windows 7, but why making it like this on Win10!

          Comment


            #6
            Originally posted by 838Joel View Post
            I don't use HS on a windows PC, but even do this bug me a lot on my own desktop PC.
            I did few things to disactivate that, but lately it did reboot by itself and I lost my work running all the time on my PC
            Never had an issue with windows 7, but why making it like this on Win10!
            Depends on what version of Win10 you have but with Pro up you can use the policy editor to stop reboots.
            Jon

            Comment


              #7
              Originally posted by jon00 View Post

              Depends on what version of Win10 you have but with Pro up you can use the policy editor to stop reboots.
              I do, and I did... seems it is not working!

              Comment


                #8
                I think this is closely enough related to include in this discussion...OP, I'll move it to a separate thread if you prefer...

                I wouldn't necessarily mind Win 10 automatically restarting by HS server if it would do so cleanly, but it doesn't wait long enough for HS4 to fully shut down. My HS4 installation takes just over 30 seconds to close. Does anyone know if setting HungAppTimeout to > 30 seconds would fix the issue--without creating other undesirable consequences?
                -Wade

                Comment


                  #9
                  Originally posted by Wade View Post
                  I think this is closely enough related to include in this discussion...OP, I'll move it to a separate thread if you prefer...

                  I wouldn't necessarily mind Win 10 automatically restarting by HS server if it would do so cleanly, but it doesn't wait long enough for HS4 to fully shut down. My HS4 installation takes just over 30 seconds to close. Does anyone know if setting HungAppTimeout to > 30 seconds would fix the issue--without creating other undesirable consequences?
                  Why don't you just use my Windows Update Monitor (which I know you have used before). It has a device that flags if a reboot is required. It also has a built-in restart PC capability which shuts down Homeseer and plugins gracefully before restarting the PC. You just create a simple event to trigger on your criteria / parameters plus the reboot device and set an action to reboot the PC.

                  https://forums.homeseer.com/forum/3r...r-3-homeseer-4
                  Jon

                  Comment


                    #10
                    Originally posted by jon00 View Post

                    Why don't you just use my Windows Update Monitor (which I know you have used before). It has a device that flags if a reboot is required. It also has a built-in restart PC capability which shuts down Homeseer and plugins gracefully before restarting the PC. You just create a simple event to trigger on your criteria / parameters plus the reboot device and set an action to reboot the PC.

                    https://forums.homeseer.com/forum/3r...r-3-homeseer-4
                    Thanks Jon. Yes, I do use it to monitor several Windows PCs on my network although haven't configured it to handle the restarts. I've just watched for notifications and handled them manually. I've had a couple of unexpected overnight restarts in the past few weeks on 2 HS4 servers, so like the OP, I need to once again stop the auto restarts and then maybe configure the PI to handle them.
                    -Wade

                    Comment


                      #11
                      Like some of you, I'm running Win 10 Pro, so I've tried using group policy editor to turn off the restarts, but clearly that didn't work the last time around. I'm hoping that renaming the Reboot task will physically stop Windows from being able to execute the reboot. Awfully silly that it needs to be taken to this extreme. I get the Microsoft wants to ensure updates get applied in a timely fashion, but taking the control away from the user isn't the best approach.

                      As for the shutdown, yes, I've also noted that HS4 doesn't get shut down gracefully. It complains on start-up (in the log) about this.

                      Comment


                        #12
                        I use these 2 tools to disable the reboots.
                        Till now they seem to do the fix.

                        https://winaero.com/windows-10-updat...dates-reliably

                        https://www.sordum.org/9470/windows-...-blocker-v1-6/
                        - Bram

                        Send from my Commodore VIC-20

                        Ashai_Rey____________________________________________________________ ________________
                        HS3 Pro 3.0.0.534
                        PIugins: ZMC audio | ZMC VR | ZMC IR | ZMC NDS | RFXcom | AZ scripts | Jon00 Scripts | BLBackup | FritzBox | Z-Wave | mcsMQTT | AK Ikea

                        Comment


                          #13
                          I use the Win10 Pro Update, Advanced Options, Pause Updates to extend the updating to the maximum time (35 days). Then on my schedule (and some time before the 35 days are up), I bring Homeseer down in a orderly way, do a full system backup, and restart the updating. After updating is all done, I reset the pause for another 35 days.

                          Since its done on my schedule, I can plan when having Homeseer down for a time when it is less inconvenient to the household.

                          Comment

                          Working...
                          X