Quick history, I was running HS3-pi, all good albeit a it slow. Migrated to HS4 standard on a an ubuntu server VM running in VirtualBox on a Apple Mac mini. Now running on Ubuntu Server on Apple Mac mini hardware.

When running under VM ubuntu all was working well but I had regular wave usb stick errors, a reboot of the VM was the only reliable way to fix them. This happened at least once per day and was very annoying. I ended up concluding it was something to do with the usb passthrough with VirtualBox . Don't know, gave up and moved to Non VM ubuntu.

So here I am with ubuntu booting on a Mac Mini 2011 hardware. This is super quick, I have not had any wave issues. The Issue I am having is my event that called a .sh script no longer work. That worked fine on the pi and the VM but on this install they do not.

My event is set to "run another program or process". Application path is /bin/sh and the parameters are /usr/local/HomeSeer/enable_fw_rules_kahlia.sh

When the event is triggered I get the entry in the log to show the event was triggered and nothing seems to fail there.

10/15/2021 22:57:56
Event Trigger "Master Control Allow Kahlia internet"

If I run the same script from the ubuntu cli they work fine. My linux skills are not great so this is probably letting me down.

Anyway thanks for reading and hopefully someone has some advice.


**** FIXED NOW ****. The cause. Because the script I am running connects to another dive via SSH I had to manually connecting using root user at lease once to install the public ssh key. I had only done it from user homeseer. I did not realise the keys were saved per user,. Rookie mistake.