No announcement yet.

Instant Status Issue - Leviton DZ15S Switches

  • Filter
  • Time
  • Show
Clear All
new posts

    Instant Status Issue - Leviton DZ15S Switches

    Hi there... I'm running a trial of HomeSeer and added a few different devices to the system before making the jump. These devices work perfectly on other HA platforms, but I'm having a strange issue with HomeSeer and figure it's just human error somewhere

    The devices are added and I can control them from HomeSeer no problem. However, status updates from these switches are not showing up in the HomeSeer interface when I manually toggle the switch on/off. I'm confident they support "instant status" because if I move a switch back to Hubitat, HA or ST for example then status is instantly updated.

    Looking for ideas on how to troubleshoot this... they are running firmware 1.2.0 if that helps


    Greetings pstewart

    Navigate to the Z-Wave manage tab for the device and open the drop down menu for [Information About Node ...]

    What is listed for the Neighboring Nodes?
    Click image for larger version  Name:	Screenshot_2021-10-25_21-09-44.png Views:	0 Size:	86.0 KB ID:	1504357

    After that, open the drop down menu for [Associations]

    What is listed there?

    Click image for larger version  Name:	Screenshot_2021-10-25_21-19-35.png Views:	0 Size:	39.1 KB ID:	1504358

    Following that, click on [Optimize]

    Wait til it's finished.
    Then, click on [Optimize] again,

    Wait til it finished again,
    and finally, click on [Full Optimize]

    Click image for larger version  Name:	Screenshot_2021-10-25_21-24-27.png Views:	0 Size:	42.8 KB ID:	1504359

    Please perform the above steps in the order listed and let me know your results.


    Roger D


      Roger D Thank you so much for pointing me in the right direction. I couldn't find the Z-Wave tab that you show in the screenshot at first, so after some searching around the forums I found that it's hidden by default. Solved that and was able to pull up the information about the node ... I had a pretty serious Z-Wave RF issue going on and didn't realize it but when I tried to pull up settings or associations the system kept throwing an error... very much like interference.

      I found I had some other Z-Wave hubs running that I had unplugged .. somehow they got plugged back in ... 5 of them lol ...

      Instant status is working just fine now .. and thank you for pointing me towards the right info.



        pstewart Can you enlighten me on what you had to do to make Neighboring Node show up? I have the same exact issues for both the switch (DZ15S) and the with HomeSeer.


          My issue was ZWave RF related ... after I cleared that up things worked as expected.


            I couldn't find the Z-Wave tab that you show in the screenshot at first, so after some searching around the forums I found that it's hidden by default.
            I was not asking how you fixed the switch issue. What did you have to do in HomeSeer to get Neighboring Node to show up under View/Device Management/Z-Wave [Tab]/Information About Node X? There is no Neighboring Node field currently for me.


              @Roger D I'm trying fix a problem which appears to be identical to the OP's with a Leviton DZ15S switch and wanted follow your example above, but don't see the "Neighboring Nodes" field under View/Device Management/Z-Wave [Tab]/Information About Node X. I've searched for an answer but found nothing. How can I make it visible?



                ​​​​​​​Please post a screenshot of the page you are viewing.



                  I'm having the same issue with my Leviton switches in HS4

                  The attached shows the relevent configuration information

                  This is a new HomeTroller HS4/Win 10 Pro build with the Nortec Z-wave interface; prior to this everything was running on a HomeTroller HS2 system and instant status worked fine.

                  As part of the build all the optimizations/associations were done. Nonetheless, I went through the steps outlined above for this particular switch including deleting and re-adding the association to Homeseer. Unfortunately the instant status reporting is still not functioning. Interestingly, there are 2 ancient Intermatic dimmers which do function correctly, if they are turned on/off/dimmed locally HS4 correctly reports their status.

                  I would appreciate any guidance as to next steps. TIA

                  Best Regards

                  edit: this was a scratch build, no type of migration was done.
                  Attached Files


                    It shows good neighbors so that wouldn't be an issue. Take a look at the node itself ZWave->Node Information. Look at the last route.

                    If it doesn't show Direct, try setting it to 1, which is the stick itself. You can set it from the box directly to the right of it.

                    I had to do that with my Z-Wave locks that require Beacon waking to point them to a repeater that support Beaconing.


                      Thanks for your prompt response.

                      It shows Direct already, but I set to 1 anyway. Unfortunately there is no improvement.

                      I've got a Nortek interface, which Z-Wave interface are you using? I wonder if that could be a factor.

                      Best Regards
                      Attached Files


                        I'm using the original SmartStick +, but going to go the new G3 as soon as I finish my HAI security system upgrade.

                        Another thought, what version of the ZWave plugin are you running? The latest is There were a lot of improvements made in that version.


                          I went to check the version (it is and I think to myself, I've poked and prodded this thing every which way (including restarting the Z-Wave interface), but I haven't actually stopped/started the Z-Wave Plugin. Et voilà, we have instant status.

                          I suspect, there was more to it than the plugin restart. The instant status has not worked since I started the build 10-15 days ago, and I restarted HS4 (and hence the plugins) 5 days ago. I did rescan all the Leviton switches today, prior to the plugin restart.

                          I guess, add (1) rescan the devices and (2) restart the Z-Wave plug-in to the list of possible fixes😀

                          Thanks for the ideas

                          Best Regards