Announcement

Collapse
No announcement yet.

HSTouch connection to the HomeSeer Server in case of folder access HS3 vs HS4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    HSTouch connection to the HomeSeer Server in case of folder access HS3 vs HS4?

    What happens to HSTouch connection to the HomeSeer Server in case of folder access HS3 vs HS4?


    That question is intended for Windows users who claim their projects to break after upgrading to HS4... Or even try to run HS3 and HS4 side by side?



    Eman.
    TinkerLand : Life's Choices,"No One Size Fits All"

    #2
    In my case, there was no warning of any connection failure from HS4. When my attempt at HS4 failed, I was still able to make and send a new project to a client (and that project wouldn't work, either). I did have icons disappear from the client under HS4 but they (e.g. the locks they control became nonresponsive via clicking them) and their ability to control would reappear after reinstalling HS3. I can see how this sort of situation could happen with a copy and paste installation, but I used the .msi installation.

    For me and the way we use HSx this is a big deal because this is our primary method of communicating with the software. No tailored GUI, no way to control the HA. Alexa can only do so much.

    This has the appearance, from where I stand, that HST knows the problem but doesn't want to either deal with it or deal with it right now as it probably is a large fix in proportion to the numbers that seem to be affected.
    HomeSeer Version: HS3 Pro Edition 4.2.6.0
    Operating System: Microsoft Windows 10 Pro - Desktop

    Enabled Plug-Ins
    AK Google Calendar 3.0.0.45,AK Smart Device 3.0.0.6,AK Weather 4.0.1.77,AmbientWeather 3.0.1.9,Big5 1.38.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.38.0,BLPlex 2.0.22.0,BLUPS 2.0.26.0,Device History 3.2.0.2,EasyTrigger 3.0.0.74,HSBuddy 3.25.614.1,mcsMQTT 5.21.4.1,MeiHarmonyHub 3.1.0.22,NetCAM 3.0.0.14,PHLocation 3.0.1.109,Restart 1.0.0.7,SDJ-Health 3.1.0.3,SDJ-VStat 3.1.0.7,TPLinkSmartHome 19.10.7.1,UltraCID3 3.0.6681.34300,UltraSighthoundVideo3 3.0.5960.36744,,Z-Wave 3.0.2.0

    Comment


      #3
      I've been following the threads about this and it's really strange because one would think that the upgrade path, if followed the same way by all users, would lead to consistent results.

      I used the preferred upgrade path and everything worked - except initially - HS Designer.

      Like @ewkearns, my primary HS3/4 interface is HSTouch, so initial panic set in.

      The fix was easy enough though - all I had to do was go into the setup screen and make sure the login information was correct as well as point Designer to the proper graphics folders.

      The only difference from my setup compared to typical ones is that I keep all the HSTouch info (projects & graphics folders) in the HS3/4 folder. For me, it makes for easier backups of the entire system.

      I think this one is an important issue to solve - some of us moved to HomeSeer specifically because of HSTouch and the interface that is limited only by one's imagination.

      Obviously the problem is real, but it would be such a shame for potential new users to be scared away because of bad experiences like this.

      Comment


        #4
        Originally posted by jgreenberg01 View Post
        <Snips>
        The fix was easy enough though - all I had to do was go into the setup screen and make sure the login information was correct as well as point Designer to the proper graphics folders.
        <Snips>
        Since I had HS3 working fine,
        1. updated all of my PIs to the latest version
        2. assured that designer and touch were the latest versions
        3. and ran the system for a few days to ensure that nothing was problematic and everything ran fine. (No problems noted.)
        I updated HS4,
        1. downloaded the latest version and ran the installer as instructed
        2. printed the instruction sheet and followed it implicitly, checking off each step, as completed

        Here are my questions:
        1. As there is no HS4 Designer or Touch and they worked fine with HS3, why would the installation of HS4 alter any of those settings?
        2. Since I ran the updater, why would it not have adopted the already working settings under HS3 (actually, it appeared to have done so, successfully)?
        3. Generally, if a touch client cannot connect to the server, it gives that warning in the upper left of the screen. If a connection was a problem, why did it not indicate so?
        4. How could I send another project to the client if not connected?
        5. Why were icons missing on the client under HS4, but not HS3.
        These questions are, obviously, rhetorical.
        HomeSeer Version: HS3 Pro Edition 4.2.6.0
        Operating System: Microsoft Windows 10 Pro - Desktop

        Enabled Plug-Ins
        AK Google Calendar 3.0.0.45,AK Smart Device 3.0.0.6,AK Weather 4.0.1.77,AmbientWeather 3.0.1.9,Big5 1.38.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.38.0,BLPlex 2.0.22.0,BLUPS 2.0.26.0,Device History 3.2.0.2,EasyTrigger 3.0.0.74,HSBuddy 3.25.614.1,mcsMQTT 5.21.4.1,MeiHarmonyHub 3.1.0.22,NetCAM 3.0.0.14,PHLocation 3.0.1.109,Restart 1.0.0.7,SDJ-Health 3.1.0.3,SDJ-VStat 3.1.0.7,TPLinkSmartHome 19.10.7.1,UltraCID3 3.0.6681.34300,UltraSighthoundVideo3 3.0.5960.36744,,Z-Wave 3.0.2.0

        Comment


          #5
          Originally posted by ewkearns View Post
          5. Why were icons missing on the client under HS4, but not HS3.

          These questions are, obviously, rhetorical.
          Please don't think that I was being critical in any way or was suggesting that you did something wrong, I was not! Your experience should not have happened and it's a good example of why users do not embrace updates. Too many issues like this will shake people's confidence and potentially start them going down the road of looking at other platforms.

          Your #5 reminded me that, while I can't compare HS3 icon access vs. HS4, I too had some missing icons after updating. The missing ones were all png files that I had added to the html/mages/HomeSeer/status folder.

          Only some of my custom graphics files disappeared - it makes no sense at all...

          Comment


            #6
            More on that here : https://forums.homeseer.com/forum/ho...lp-or-thoughts







            Eman.
            TinkerLand : Life's Choices,"No One Size Fits All"

            Comment

            Working...
            X