Announcement

Collapse
No announcement yet.

Linux CPU usage > 100%

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Eman
    replied
    Originally posted by avpman View Post

    Won't work on Linux. Back to looking for a script from a kind soul.
    Try here : https://www.cyberciti.biz/tips/how-d...ilization.html


    Eman.

    Leave a comment:


  • avpman
    replied
    Originally posted by Pete View Post
    There is the Blade BLCpuAdvisor PI you could try maybe.
    Won't work on Linux. Back to looking for a script from a kind soul.

    Leave a comment:


  • Pete
    replied
    There is the Blade BLCpuAdvisor PI you could try maybe.

    Leave a comment:


  • avpman
    replied
    Originally posted by rmasonjr View Post
    It might be a runaway event that is triggering over and over. Have you added any new ones lately?
    Nope, and the fact that it's sporadic makes it even more confusing.

    Leave a comment:


  • rmasonjr
    replied
    It might be a runaway event that is triggering over and over. Have you added any new ones lately?

    Leave a comment:


  • avpman
    replied
    Might anyone have a script I can run at some regular interval to check the CPU usage and email me when CPU goes above a certain percentage?

    Leave a comment:


  • Eman
    replied
    Originally posted by avpman View Post

    No MQTT (yet). "...update the system?" Not sure what you mean. I updated to .6 and coincidently the issue resurfaced so I downgraded it back to .5. As of now, the CPU usage is normal. Chasing this down is like trying to nail Jello-O to the wall.
    I meant the OS but assumed you'd already done that... as pending updates may affect a system with MQTT and Node-RED which you have mentioned that you don't have.

    A remote sensor which need battery replacement...?? But this would affect Z-wave and would should show in the logs

    Or even some plug-in logging heavily to disk...??


    Eman.

    Leave a comment:


  • avpman
    replied
    Originally posted by Eman View Post

    Do you have MQTT anywhere in your setup?

    Plus can you update the system or you already done that...?



    Eman.
    No MQTT (yet). "...update the system?" Not sure what you mean. I updated to .6 and coincidently the issue resurfaced so I downgraded it back to .5. As of now, the CPU usage is normal. Chasing this down is like trying to nail Jello-O to the wall.

    Leave a comment:


  • Eman
    replied
    Originally posted by avpman View Post
    Linux CPU usage > 100% - it' back. Grrrrrrrr. I even regressed from .6 to .5 and disabled more plugins. How best to find the culprit? I'm stumped.
    Do you have MQTT anywhere in your setup?

    Plus can you update the system or you already done that...?



    Eman.

    Leave a comment:


  • avpman
    replied
    Linux CPU usage > 100% - it' back. Grrrrrrrr. I even regressed from .6 to .5 and disabled more plugins. How best to find the culprit? I'm stumped.

    Leave a comment:


  • avpman
    replied
    Originally posted by rmasonjr View Post

    FYI, I get the same thing with the Device History plugin. I ended up disabling it until I figure out exactly what I want to track...
    Good to know I (we) pinned it down. Thanks, Rob!

    Leave a comment:


  • rmasonjr
    replied
    Originally posted by avpman View Post
    Knock on wood, I think this is fixed. I disabled and then re-enabled the Device History plugin and CPU load is back to normal. I picked that Plugin because I figured it might be constantly checking device statuses. If the CPU pegs again I'll leave the plugin disabled and key an eye on the CPU load.
    FYI, I get the same thing with the Device History plugin. I ended up disabling it until I figure out exactly what I want to track...

    Leave a comment:


  • avpman
    replied
    Originally posted by pistacheL0 View Post
    I have seen something similar with the z-wave ui plugin.
    Thanks, but I don't use the Zwave UI plugin. I disabled it the first time I used it. Linux is still stable overnight - so far.

    Leave a comment:


  • pistacheL0
    replied
    I have seen something similar with the z-wave ui plugin.

    Leave a comment:


  • avpman
    replied
    Knock on wood, I think this is fixed. I disabled and then re-enabled the Device History plugin and CPU load is back to normal. I picked that Plugin because I figured it might be constantly checking device statuses. If the CPU pegs again I'll leave the plugin disabled and key an eye on the CPU load.

    Leave a comment:

Working...
X