Announcement

Collapse
No announcement yet.

Find Device In Old Backup?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Find Device In Old Backup?

    I have some events that control a ton of things in a recording studio. Today, several of the events are missing "device number 1046."

    Eventually, I'm sure I'll notice what's not happening.

    When I run older full folder backups, I see the same thing...so I'm assuming the interface no longer has it in its config?

    Is there a way to see find this device number in a file in the backup folder somewhere...find out what it was? IE - Without launching HS4?

    #2
    In the ConfigBackup folder, you can check one of the backups and open devices.json in a text editor. There is a lot of serialized data in there that will be unreadable, but if you search for the device name, you might be able to pick out the device reference number.
    HS4Pro Running on a Raspberry Pi4
    79 Z-Wave Nodes, 131 Events, 383 Devices
    Z-Wave, UPB, WiFi
    Plugins: EasyTrigger, weatherXML, OMNI, Z-Wave, Tuya, Device History
    HSTouch Clients: 3 Android, 1 Joggler

    Comment


      #3
      THANKS!! Will give that a try.

      Comment


        #4
        Thanks again...found it in backups of the eventlisting.txt file.

        I am a bit confused though. The reference was to the older harmony hub plugin before HS supported it natively...that changed a long time ago This had not shown up in Jon000's broken event checker...or whenever it was HS started showing the red heading for things that are broken.

        Comment


          #5
          Just a heads up:
          Jon00 device viewer and Jon00 event viewer both have a report feature;
          I run it daily so I keep an historical record of devices/events ;
          makes it really easy to track deleted devices for the usual "missing device xxxx" in events.

          Since it overwrites previous reports, you can add a simple script to rename/copy files per date/time:

          Code:
          Sub Main(ByVal Parm As Object)
          My.Computer.FileSystem.CopyFile(hs.GetAppPath & "\html\devicelisting.csv", hs.GetAppPath & "\Data\Eventdevicebackup\devicelisting" & DateTime.Now.ToString("yyyyMMdd") & ".csv")
          My.Computer.FileSystem.CopyFile(hs.GetAppPath & "\html\eventlisting.csv", hs.GetAppPath & "\Data\Eventdevicebackup\eventlisting" & DateTime.Now.ToString("yyyyMMdd") & ".csv")
          End sub
          HS3, HSTouch Designer, ESP8266 based devices and sensors, Tasmota, OpenMQTTGateway, RTL433, DIY ground plane antenna, BlueIris + LAN cams, USB-UIRT, ATON DLA amp, Winamp, Multiple Android tablets for control.
          Plug-Ins Enabled: Restart:,mcsMonitor:,EnvCan:,EasyTrigger:,CM15A:,BLUSBUIRT:, BLLAN:,BLBackup:,Pushover 3P:,mcsMQTT:

          Comment


            #6
            Right...I run it often and that's why I'm confused. I haven't used the non-HS4 Harmony plugin in ages and its devices from that ...that show to be missing. I find it hard to believe there isn't something corrupted somewhere.

            Comment

            Working...
            X