Announcement

Collapse
No announcement yet.

Virtual Device with No Controls Change Value

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Virtual Device with No Controls Change Value


    I am new to HS4 and trying to figure something out:

    I am trying to create a virtual device to duplicate the status lights on a HS-WX300. I have created the virtual device without any controls but I cannot figure out how to change the value of the devices in my events to duplicate the lights on the switches. Since the virtual devices don't have controls they cannot be updated within an event that I can find.

    Is there something I am missing here?

    Any help would be appreciated.

    #2
    Go to the Status/Graphics page for the virtual device and add whatever controls are needed for you application.

    Comment


      #3
      Thanks Roger D. I was trying not to have any controls visible since they are just status lights.

      I did finally figure it out by writing a script that runs hs.setdevicevaluebyref(device,variable,True) when I want to change them.

      I'm new to all this scripting. Very powerful yet still complicated to me.

      Comment


        #4
        Originally posted by Ironbar View Post
        Thanks Roger D. I was trying not to have any controls visible since they are just status lights.

        I did finally figure it out by writing a script that runs hs.setdevicevaluebyref(device,variable,True) when I want to change them.

        I'm new to all this scripting. Very powerful yet still complicated to me.
        That is the way to control a device without specific controls.

        HS4 Pro, 4.2.19.0 Windows 10 pro, Supermicro LP Xeon

        Comment


          #5
          Another way to do this is with the EasyTrigger Plug-in action. EasyTrigger:Set Device to another Device

          It sets the value of one device to the value of another device.

          Roger D

          Comment


            #6
            Ironbar,

            BTW, I had started working a script for what sounds like this very thing a while back but had run short of time. I'll dig up when I get the chance.


            Click image for larger version

Name:	New Bitmap Image (2).png
Views:	204
Size:	62.3 KB
ID:	1517051

            Roger D

            Comment


              #7

              I tried EasyTrigger at first but for some reason the devices did not show up in the easy trigger device list. After reading your post I went back and tried it again and now they do appear on the lists. I changed all of my scripts to the Set Device to Variable and they work perfect. Thanks Roger D. That eliminated a line in my log every time it called the scripts (which is many times throughout the day).

              For some reason some of my devices still show up incorrectly in the EasyTrigger device lists. I changed my alarm system from Global (floor) and Global (room) to Global (floor) and Alarm (room) but they still appear in EasyTrigger's device list as Global-Global. Not sure what is going on there but I'm thinking it is related to the devices not showing up the first time in the device lists. That is a problem for another day....

              Comment

              Working...
              X