Announcement

Collapse
No announcement yet.

Stop Win 10 updates and rebooting?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Stop Win 10 updates and rebooting?

    I have a Win 10 pro box running HS3 and it works great, except I can not stop the updates and auto rebooting. I mind the auto reboot so much except this box gets stuck on the UEFI boot and needs to be turned off and back on to get past the HD check for some reason (haven't looked into that yet.).

    Anyway has anyone been able to turn this crap off? I have tried every reg edit, system setting I can find, even the MS pages say it can't be done! That can't right.

    Thanks
    -Skybolt

    #2
    Several ways to do this. The method I use is to delay the updates for 35 days,, then make a note to myself to "unfreeze" the updates before the time is up (to keep the system current, but on my schedule). I then extend the freeze for another 35 days.

    On a windows 10 pro system settings, go to Update and Security, then the Advanced Options, then the Pause Updates (and select the maximum date).

    Comment


      #3
      I set the Ethernet network to Metered to keep updates from being downloaded. No download, no install and reboot.

      Some say this doesn't always work but I've never had a problem.

      Then, once a week or so, I connect, shutdown HS4, force a check for updates, select download anyway (over metered connection), and allow the install and reboot.
      "if I have seen further [than others], it is by standing on the shoulders of giants." --Sir Isaac Newton (1675)

      Comment


        #4
        You can also launch gpedit.msc to manually set windows update settings with win 10 pro

        Comment


          #5
          If your day-to-day operations do not need internet access, create a firewall rule to block Internet connectivity for the source IP address of your device. Then when you need to do maintenance and updates, disable the rule until your maintenance tasks are completed. If you need a continuous connection to the Internet, just block the destination IP address for the updates. Your OS will still show it checked for updates even though it never connected.

          Comment


            #6
            Thanks guys.

            Not sure what reg setting actually works if any, but I have tried numerous ones.

            Tried the settings and putting off for days, but then forget and there we are nothing working until I reboot pc.

            I didn't think of blocking ips/domains, might try that. Thanks.

            It shouldn't be that hard to do this. Why does MS always have to control everything! Ha - I guess because we do as well. ...
            -Skybolt

            Comment


              #7
              When my HS3 system was still on Win10 (I’ve since switched to Linux) I was using Windows Update Blocker (https://www.sordum.org/9470/windows-...-blocker-v1-6/). It worked perfectly and I never had any updates installed or restarts. Once every month I would enable updates through WUB, install everything, then re-block updates through WUB.

              Comment


                #8
                Originally posted by marthoc View Post
                When my HS3 system was still on Win10 (I’ve since switched to Linux) I was using Windows Update Blocker (https://www.sordum.org/9470/windows-...-blocker-v1-6/). It worked perfectly and I never had any updates installed or restarts. Once every month I would enable updates through WUB, install everything, then re-block updates through WUB.
                I will give this a shot. Thank you!
                -Skybolt

                Comment


                  #9
                  Maybe upgrade to HS4 and use the disable windows update checkbox?

                  Comment


                    #10
                    Originally posted by dmiller View Post
                    Maybe upgrade to HS4 and use the disable windows update checkbox?
                    That would be too easy ... Actually I have the upgrade license but am not ready to switch just yet. Not all PI's are 4 ready ...
                    -Skybolt

                    Comment

                    Working...
                    X