Announcement

Collapse
No announcement yet.

Aeon Labs Aeotec Door/Window Sensor Issue

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Aeon Labs Aeotec Door/Window Sensor Issue

    Hi All,

    I'm struggling to use my sensor in HS4 in an event. The sensor is on a door. I want to set my Ecobee thermostat to Away when the door is open, and Home when it is closed. The problem is it's not working and I'm not sure why. I swear it used to work back in the HS3 days.. It seems like the device itself has 4 devices and the first one updates when i open/close the door, but not the fourth one which is what my event triggers off of. It used to as you can see in the first screenshot.

    First, lets look at my door sensor device..

    Click image for larger version

Name:	2Avxu1ILfT.png
Views:	212
Size:	37.4 KB
ID:	1519576

    Notice the bottom device "French Doors" hasn't triggered since 2019.. Weird. This seems to be the crux of the problem since that's the device my event uses. Otherwise it clearly has a healthy battery and the first device is firing as it fired today which you can see above. In fact I also see this in the logs which looks like this when it happens:

    Click image for larger version

Name:	luGCtnalZH.png
Views:	195
Size:	25.2 KB
ID:	1519577

    I don't know why the 4th device isn't firing. Anyone know what might be going on here?

    My actual event which doesn't fire looks like this. Note it's based off the bottom-most device in the first screenshot above because it's the only device which has values such as open/closed that I'm interested in and it used to work:

    Click image for larger version

Name:	EWPJfN6owj.png
Views:	133
Size:	84.6 KB
ID:	1519578

    If I try to change the device to the first one since that's what is being reported in the logs as triggering, I do not see an option to trigger off of it being on/open or off/closed. I can only plug in a value from 0 to 255:

    Click image for larger version

Name:	xjvcl5Xgi6.png
Views:	132
Size:	41.9 KB
ID:	1519579

    Click image for larger version

Name:	lU3qbRZICe.png
Views:	124
Size:	25.0 KB
ID:	1519580

    So it seems incorrect to use the first device. And yet, that's what the HS4 log is reporting.

    I suppose as I type this I can go try removing the device and re-adding it. But before I do that I thought i'd fish here for any ideas.

    My install details:

    Code:
    Date/time=09/01/2022 14:51:44 PST
    Version=HS4 Standard Edition 4.2.7.0 (Linux)
    MONO Version=Mono JIT compiler version 5.18.0.240 (Debian 5.18.0.240+dfsg-3 Sat Apr 20 05:16:08 UTC 2019)
    
    License=Registered
    Confguration File=/usr/local/HomeSeer/Data/HomeSeerData.json
    Uptime=0 Days 1 Hour 34 Minutes 12 Seconds
    Lan IP=192.168.1.210 (homeseer)
    Device Count=188
    Event Count=48
    Plugins Enabled=Ecobee:,Z-Wave:,PHLocation2:
    Modules/Threads=68 Modules, 47 Threads
    Available Threads=399
    HomeSeer Memory Used=101 Mbytes
    Plugins Installed=Ecobee 4.0.15.0,PHLocation2 3.0.0.64,Z-Wave 3.0.9.0

    #2
    Not knowing exactly what it sends for on, have you tried triggering on device value > 0?

    I have some wonky Leviton switches and for some reason events don't work reliably for on and off on them. I've checked their final status by going into the Advanced tab of the Z-Wave properties but hitting the exact number for those, and only those devices is hit and miss.

    So I worked around it by just triggering on value > 99 for ON And value < 100 for OFF.
    It wasn't worth my time for just two ZWave devices out of 65 to muck with it much longer and I was getting tired.

    Comment


      #3
      Interesting suggestion. Poking around I saw this under Status/Graphics

      Click image for larger version

Name:	xKjCHuDrPG.png
Views:	132
Size:	93.5 KB
ID:	1519598

      So I tried changing my event to fire on the first device being 255

      Click image for larger version

Name:	hyCOrdR5zE.png
Views:	128
Size:	59.0 KB
ID:	1519599

      And it worked!!

      Click image for larger version

Name:	OKopXyuR7x.png
Views:	189
Size:	21.1 KB
ID:	1519600

      I set the close event the same way only using 0 and that also works.

      Nice! Thanks for the suggestion!

      Comment


        #4
        You're looking at your setup and not the actual device values.

        Your status graphics shows 255 as being ON, but that's just telling HS what ON means. That doesn't mean that's what the actual value is.
        You need to look at the advanced tab to see it.

        Also, the best way is to have the HS Log up and updating when you trigger the sensor. That will tell you exactly what the sensor actually sent to the ZWave plugin.

        So look at the log, a nickel says that the ON or triggered status is not 255.

        Comment


          #5
          BTW, I believe some Aeotec Features have to be enabled using Device Parameters in order for them to update values.

          Roger D

          Comment


            #6
            Originally posted by George View Post
            You're looking at your setup and not the actual device values.

            Your status graphics shows 255 as being ON, but that's just telling HS what ON means. That doesn't mean that's what the actual value is.
            You need to look at the advanced tab to see it.

            Also, the best way is to have the HS Log up and updating when you trigger the sensor. That will tell you exactly what the sensor actually sent to the ZWave plugin.

            So look at the log, a nickel says that the ON or triggered status is not 255.
            Funny, it does work perfectly doing what I just did.

            I don't see an advanced tab anywhere. Where do I find an advanced tab? Under the device, even if I click Zwave and then the manage button, I still do not see advanced.

            Comment


              #7
              Originally posted by gwichman View Post

              Funny, it does work perfectly doing what I just did.

              I don't see an advanced tab anywhere. Where do I find an advanced tab? Under the device, even if I click Zwave and then the manage button, I still do not see advanced.
              Just click on the device name in the UI. You'll see 4 tabs.

              Configuration / Advanced / Status/Graphics / ZWave

              You sort of have to look up

              Click image for larger version

Name:	x.jpg
Views:	100
Size:	24.8 KB
ID:	1519829

              Comment


                #8
                Is that an old UI thing?

                Click image for larger version

Name:	O6mShU8Odf.png
Views:	94
Size:	21.9 KB
ID:	1519831

                Comment


                  #9
                  Or something that was missed in the new UI.

                  Invaluable to find out exactly what the current "real' state of the device you are trying to troubleshoot.

                  I'd find out where it went, it's invaluable in troubleshooting and setting custom values.

                  Just another reason why I stayed on HS3.

                  Click image for larger version

Name:	y.jpg
Views:	95
Size:	132.1 KB
ID:	1519835

                  Comment


                    #10
                    Take a look at jon00 's device list and viewer utility. It lists everything you want to know about a device and it's state.

                    It works on both HS3 and HS4 as HS4 is just HS3 with some lipstick.

                    Comment

                    Working...
                    X