Announcement

Collapse
No announcement yet.

Motion sensor script help needed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Motion sensor script help needed


    #2
    It looks to me as if your palmpad RF is received by a unit that converts RF to powerline signal vs a MR26A or W800. The L1 serves a dual role of being the address of the light as well as the device that is used by HS to set the occupancy virtual device. The L1 now makes it to the powerline and up to the light, by the signal does not propogate to the HS/CM11A(or whatever X10 interface you have). This means the light is direclty controlled with the palmpad and HS is not involved. Any electrical appliance plugged-in or unplugged changes the powerline characteristics. I suspect your light and HS are on different circuits. Problem resolution is 1) confirm HS does not see the palmpad L1 by looking at the devicelastchange property of L1. 2) unplug equipment, especially on the ciruits where HS/CM11A is located.

    Comment


      #3
      Yes, my palmpad RF is received by a w800. And yes, L1 turns the light on and sets the occupancy. Since the light is turning on and off with the palmpad I just assumed (I know...) that everything was getting through but it makes sense that perhaps the RF is via the w800 but the powerline isn't via the cm11a.
      I have plugged an appliance in since the problem started so when I get home I will unplug it and test it again. If it turns out to be the troublemaker I guess I'll try a filter on it.
      Thanks for your input.
      HH

      Comment


        #4
        Thanks Michael,

        Well, I got home and unplugged the Roomba Discovery SE and it is indeed the troublemaker. I'll have to order a filter for it.
        I just wanted to thank you for your expert assistance and let everyone who is thinking of getting a roomba that they are great to have but apparently can cause trouble on the powerline.
        HH
        Last edited by ; January 28, 2005, 07:50 PM.

        Comment


          #5
          Spoke too soon...

          I spoke too soon. It still doesn't work with the roomba unplugged.
          I get this in the log when I hit L1 On on the palmpad:

          1/28/2005 7:51:33 PM~!~X10 Received~!~L1 (Living Room Floor Lamp) L On
          1/28/2005 7:51:33 PM~!~Event Trigger~!~X10 Trigger (LR Occupied) L1 On (Living Room Floor Lamp)z3 On (Living Room LR Occupancy)

          Device Last change is showing Living Room Occupied at 7:51:33 also.

          And I have tried unplugging everything that has come into the house in the last 6 months (problem has been going on for maybe 2 weeks).

          Any clues on what to try next?
          Do the scripts look ok?

          Comment

          Working...
          X