Announcement

Collapse
No announcement yet.

email not working - Posted POP server error. See below.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    email not working - Posted POP server error. See below.

    Current Date/Time: 6/21/2022 10:55:39 AM
    HomeSeer Version: HS3 ZEE S2 Edition 3.0.0.548

    Error posted in log: "Unable to connect to POP server(1) Error: Object reference not set to an instance of an object"

    Email been working for "years". No updates. Just started failing. What I've tried: 1. Swap to backup SSD. Same failure. 2. Moved SSD to new PI. Same failure. 3. Created new email account. Same failure. Found multiple hits on this issue and tried many but still same failure. Spent 3 days on this and don't know where to go next. Need some guidance on what next to try to solve this problem.

    #2
    do you use Gmail?

    https://support.google.com/mail/answer/185833?hl=en-GB

    Comment


      #3
      Yes. The homeseer email is on Gmail. I have seen the text before but did not try to make that change as it appeared you had to create a change in the operation of logging on? I have even thought about bailing clear out of gmail and using another vendor just for the homeseer account??
      Thoughts.....

      Comment


        #4
        I don't use Gmail for Homeseer but I have two third party plug-ins with HS3 that needed to be updated. It was a simple process and you would need to do the same for Gmail if you decide to keep it.

        The instructions are easy to follow to turn on two-step authentication and then create an app password for your Gmail for Homeseer. Then in Homeseer email settings keep your username the same but change the password to the app password you created in your Google security settings. After that you will be good to go.

        Comment


          #5
          Hi retiredtech,
          I just did this. I waited til the last minute, because I didn't want to change Google acct. It doesn't do anything to your login. You create an app password and enter that into homeseer under the smtp location under email setup in the homeseer webpage. You have to restart homeseer to have the change take effect.
          works fine now
          Bruce
          Well you do have to change to 2 factor login though.

          Comment


            #6
            I started the routine as described above......Signed into my regular gmail account. 2-step verification is ON. App password is NONE. Selected APP PW is NONE. Changed my regular email account over to the HOMESEER email account. Set following but error says "what you are looking for is not available". Went back and tried to just use my main email account and all the info was there to create an APP PW. Just not work for the HomeSeer email account.

            Appreciate your help but so far not making much progress. Google email is a monster! I was trying to think just where this problem might be located. Not in the operating system or hardware and the email for HomeSeer works fine using Thunderbird. Just the combination of a change in google and homeseer I guess!

            Comment


              #7
              you need to generate an app password. Select and choose custom and name it Homeseer where I circled on the attached screenshot. It will auto generate an encrypted password for you to use in Homeseer's email settings

              Click image for larger version

Name:	Capture.jpg
Views:	61
Size:	49.8 KB
ID:	1553406

              Comment


                #8
                This post is what I used to get it working.

                https://forums.homeseer.com/forum/ho...95#post1437795

                Bruce

                Comment


                  #9
                  Thanks to everyone for your help on this.....unfortunately I've been pulled away for a higher priority issue in the family! Will keep this up to date when I get back to working on the solution.

                  Comment


                    #10
                    Had some time this morning to get my 86 year old brain in gear and do the changes you have given me. And it all worked! Thanks again for your help and hanging with me. I'm still on HS3 what is your recommend on moving over to HS4, the easiest way possible?

                    Comment

                    Working...
                    X