Announcement

Collapse
No announcement yet.

Missing events when improperly shutdown

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Missing events when improperly shutdown

    A storm rolled through my area this afternoon causing a power failure at my house. Later tonight, I noticed several things weren't "automating" (like pool turning on, notifications, etc.) and checked out my HS4 server. All my events were lost during the power failure...again.

    Not trying to debate the value of a UPS (yes, I have them but not on this server) or backups (I do that), but thought this issue had been resolved. Anyone else experience lost events when a machine is shutdown? Any suggestions beyond adding a UPS and running backups? This is the one server I have that can NEVER survive a bad shutdown, even if I shutdown the OS before HS4. While I have the ability to address it (backups and such) the annoyance factor is high and more concerning if this happens when I'm not home. I can only imagine the frustration level of someone that does not have backups or understand how to mitigate (like most consumers might). HS4's database should be more robust and able to survive bad shutdowns.

    For reference: My HS4 is running as an Ubuntu VM on a 24 core DL380 running Window Datacenter Server 2021. ZWave is done through RPi's connected through SER2NET located around my house and property (have devices that are outside the reach of the in-house network).

    #2
    This has been a problem for me (and others) since the release of HS4. Not events specifically, but rather corrupted z-wave device files (for lack of a better term). I now have two UPS boxes but as far as I'm concerned they're just Band-Aids. .

    Comment


      #3
      Originally posted by jwbryan View Post
      A storm rolled through my area this afternoon causing a power failure at my house. Later tonight, I noticed several things weren't "automating" (like pool turning on, notifications, etc.) and checked out my HS4 server. All my events were lost during the power failure...again.

      Not trying to debate the value of a UPS (yes, I have them but not on this server) or backups (I do that), but thought this issue had been resolved. Anyone else experience lost events when a machine is shutdown? Any suggestions beyond adding a UPS and running backups? This is the one server I have that can NEVER survive a bad shutdown, even if I shutdown the OS before HS4. While I have the ability to address it (backups and such) the annoyance factor is high and more concerning if this happens when I'm not home. I can only imagine the frustration level of someone that does not have backups or understand how to mitigate (like most consumers might). HS4's database should be more robust and able to survive bad shutdowns.

      For reference: My HS4 is running as an Ubuntu VM on a 24 core DL380 running Window Datacenter Server 2021. ZWave is done through RPi's connected through SER2NET located around my house and property (have devices that are outside the reach of the in-house network).
      Look in /usr/local/HomeSeer/Data/HomeSeerData.json directory. There should be a backup of your events in there.

      Comment

      Working...
      X