Announcement

Collapse
No announcement yet.

Honeywell Zwave Thermostat TH6320ZW2003 T6

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #31
    Originally posted by jgreenberg01 View Post

    HS4 can use any sensor to control the TStat via an event. Here's a simple example:

    Click image for larger version

Name:	Tstat Control.png
Views:	68
Size:	29.0 KB
ID:	1562401
    Wow, that is an awesome answer! Not only does what I'm looking for but probably allows for a WHOLE lot more flexibility! Thank you very much!

    I just finished online chatting with Honeywell and, for everyone else's reference, the T6 does not support any form of remote wireless sensor - only a single wired sensor.

    And also for reference the guide to the setup codes can be found at:

    https://customer.resideo.com/resourc...3-00294EFS.pdf

    Love this forum, people who really know how to do home automation (and am loving Homeseer and Zwave a whole lot more than I loved my Insteon for so many years, too..)

    Comment


      #32
      Random question, but do I have to have an event to set the thermostat mode to "off" that follows this so if the remote sensor drops below 72 they system shuts off, or will it default to that if this condition is no longer true?

      Comment


        #33
        Originally posted by tmaddison View Post
        Random question, but do I have to have an event to set the thermostat mode to "off" that follows this so if the remote sensor drops below 72 they system shuts off, or will it default to that if this condition is no longer true?
        Setting the TStat to Cool turns off Auto Mode, so yes, you will want to be cognizant of that. You will want another event to turn on the heat when the temperature reaches your desired trigger point.

        In my case, control all aspects of the TStats is done through through HS4 - including the schedule for both cool setpoints and heat setpoints. You can go as deep down that rabbit hole as you are willing (and have the time to dedicate).

        Comment


          #34
          "You can go as deep down that rabbit hole as you are willing (and have the time to dedicate)."

          As with any programming... I had some pretty complex things going in Insteon at one time, I was ticked when it went away, but Homeseer is so much better I'm now glad.

          For the thermostat fortunately I'm now retired. I once had a fairly complex program involving different setbacks depending on day of week (or weekend) and time of day, but life around the house is a lot simpler these days!

          Comment


            #35
            Originally posted by tmaddison View Post
            "You can go as deep down that rabbit hole as you are willing (and have the time to dedicate)."

            As with any programming... I had some pretty complex things going in Insteon at one time, I was ticked when it went away, but Homeseer is so much better I'm now glad.

            For the thermostat fortunately I'm now retired. I once had a fairly complex program involving different setbacks depending on day of week (or weekend) and time of day, but life around the house is a lot simpler these days!
            Well if you have time and enjoy those rabbit holes... HSTouch can add a whole new dimension to automation/control.

            My wife HATES trying to set a schedule using the TStat's interface and that's the reason I use HSTouch for this. Here's the screen that allows changing heat/cool setpoints as well as being able to modify the times that they take place:

            Click image for larger version  Name:	TStat Schedule.png Views:	0 Size:	345.5 KB ID:	1562423

            If you ever want to de-simplify (if that's even a word?), HSTouch can keep you very busy!

            Comment


              #36
              tmaddison,

              "I bought the Honeywell with the intention of having it somehow be aware of an HS-FS100 sensor I have in our bedroom. In theory, the idea would be to have it control the HVAC system based on the readings from that sensor, not from the readings on the thermostat itself."

              Like others have already stated about going down the rabbit hole, it is still possible to control your T6 from your HS-FS100.

              All you've got to do is... (That phrase scares me sometimes)

              Using the Arduino Plug-in from Greig Dempster (Enigmatheatre.)

              Setup a small Arduino compatible board.

              Send the temperature from your HS-FS100 to the Arduino.

              Have the Arduino convert the temperature to a resistance that would match the value of the thermistor using one of several available means.

              Connect this resistance output to the hardwire temperature sensor input of the T6 and your done.

              This is a simplified explanation of just one way to do it but completely doable.

              Roger D

              Comment


                #37
                Thanks for the suggestions, all!

                I'll take a look at the HSTouch. I haven't really broached the WAF (Wife Acceptance Factor) in this yet. She never really touched the old "stand in front of it and push buttons for an hour" programmable we had before so I don't know that she's going to care to do it now. As long as she can quickly override it manually from the panel...

                As for the arduino approach, that looks cool. My HomeSeer actually runs on an RPI so I'm a bit familiar with arduino, but likely the hurdle would still be needing to run a wire. Might be able to punch through the wall behind the thermostat and put the arduino in a closet, though...

                Great solutions!

                Comment


                  #38
                  HONEYWELL T6 Pro - TH6320ZW2003 - Humidity Reporting Issue -- UPDATE:

                  I've been working with Honeywell on the Humidity Reporting issue:
                  - where Humidity changes are being reported within within seconds because the humidity value is changing every few seconds.

                  In my previous post, I noted that the thermostat is not near a register -- it's just a very very sensitive hygrometer and will report very small changes as they occur.
                  This presents a problem where the Zwave network will be inundated with humidity change reports and with 3 thermostats in my house, this can become an issue.

                  I've been working with Honeywell on this issue and they sent me a test thermostat with a different firmware version. Here are the results:

                  MINE is my existing unit, and TEST is the unit HONEYWELL sent me.

                  Date Code:
                  > Mine: 2119
                  > Test: 2234

                  Firmware versions:
                  > Mine: 01.04.05.00
                  > Test: 01.04.09.00

                  Zwave Firmware Versions:
                  > Mine: 01-03-00-00
                  > Test: 01-03-00-00

                  Library:
                  > Mine: 04-61
                  > Test: 04.61

                  The only difference is the Firmware version which made the following difference in functionality.
                  Parameter 1426 (Humidity report scaling -- where you should be able to tell Honeywell not to report changes unless at least a specific value change has occurred) is still not available as an option either in or out of the zwave network.

                  My unit:
                  Was sending humidity readings whenever humidity changed -- back and forth within seconds if the humidity was fluctuating (and I suspect this fluctuation was within decimals and rounding -- i.e. 70.4% change to 70.6% would trigger a change of 1% and be reported). I turned off humidity logging which at least keeps the logs clean, but the issue is that it's still doing the reporting). Reporting interval parameters within my Zwave config had no effect on this self-imposed change based reporting. As I recall, Zwave standards say that reporting back to the hub should occur automatically when a parameter changes regardless of polling. (Version 5 - to 7?)

                  The test unit:
                  Something most interesting when I first included within the Z-wave network was that all reporting parameters were set to about 20 minutes. Did not see that on the previous units where they were all set to 0 -- meaning no polling reporting until something changed (and with humidity, it changed frequently). This is normal Zwave reporting as with all other devices and Zwave standards.

                  So, I experimented with the test unit:
                  First -- I breathed on the thermostat to see if it would report a change. - It did not.
                  So I set the humidity polling parameter to 1 minute and tried it again.
                  After 1 minute, it reported the change. After another minute -- it reported a further change.
                  The important thing here is that it would not simply report a change in humidity on it's own as it should. It was only using the Zwave Polling parameter.

                  Second - I set the polling parameter to 0 - no polling. I breathed on the thermostat and it would not report the change at all (yes the thermostat display showed the humidity change from 61% to 83%).

                  Great right? No --

                  Conclusion:
                  While the test thermostat stopped self reporting humidity as it fluctuated within decimals, it also stopped self reporting temperature changes unless I set the polling parameter to something other than 0.
                  Not good.
                  It looks like all humidity and temperature change reporting has been deactivated in order to avoid the erratic humidity reporting. Hence requiring polling as defaulted to 20 minutes when installed. Maybe polling every 5 minutes would be ok? But from what I've learned -- polling is very resource intensive.

                  I'd suggest that it's not the way a thermostat should work. When the thermostat detects a temperature change to beyond the set-point -- it should activate the necessary actions -- not have to wait 20 minutes or whatever polling set point is defined. Seems like Honeywell fixed an erratic hygrometer by breaking the Temperature reporting functionality too.

                  I've uninstalled the test unit and replaced with my own unit again.

                  I've reported the findings to Honeywell and have requested a firmware update to turn-off Humidity change reporting, but not to affect Temperature change reporting. - ie. the ability to disable humidity reporting it or at least have it work the same way as temperature.

                  More to come.

                  Comment


                    #39
                    POST SCRIPT UPDATE:

                    In further testing, it appears that polling only impacts reporting - not thermostat actions based on temperature changes. Temperature / humidity change reporting back to the Zwave controller effected and if there are events etc that are triggered by such change, they will be impacted with delayed reporting.

                    Comment


                      #40
                      Good to see finding some success with this.

                      I initially had the "Do not Log" box under the humidity feature checked. This cleared up my log spamming issue. Unfortunately, I'm running Homebridge with the Homeseer plugin and logs continued to inundate through that service.

                      Living in the SE Texas, I have no need to monitor and/or manipulate the humidity in my home. I have a very rudimentary knowledge of Homeseer and zwave, so I had to settle for a simple overkill solution. I ended up just deleting the humidity zwave feature from my Honeywell thermostat. It fixed my problems, but I really hate solving issues like this with a sledge hammer.

                      Comment

                      Working...
                      X