Announcement

Collapse
No announcement yet.

Has the "scripts" directory really been removed in 4.2.x.x of HS4?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Has the "scripts" directory really been removed in 4.2.x.x of HS4?

    So this post: https://forums.homeseer.com/forum/3r...15#post1559515

    Can anyone explain the reasoning for this if it is the case?

    #2
    Originally posted by kenm View Post
    So this post: https://forums.homeseer.com/forum/3r...15#post1559515

    Can anyone explain the reasoning for this if it is the case?
    Running 4.2.14.0 and the scripts directory is still there.

    ---
    John

    Comment


      #3
      Yes, It's there if you update from 4.1.x.x but if you install 4.2.x.x supposedly it doesn't create the directory. Why is that is the question?

      Comment


        #4
        See for yourself:
        Code:
        wget -N https://homeseer.com/updates4/linux_4_1_13_0.tar.gz
        wget -N https://homeseer.com/updates4/linux_4_2_14_0.tar.gz
        Then
        Code:
        tar taf linux_4_1_13_0.tar.gz | grep /scripts/
        tar taf linux_4_2_14_0.tar.gz | grep /scripts/
        First one returns
        Code:
        HomeSeer/scripts/
        HomeSeer/scripts/csharp.cs
        HomeSeer/scripts/ShutDown.txt
        HomeSeer/scripts/Startup.vb
        Second one returns nothing.

        Comment


          #5
          Interesting.

          Comment


            #6
            I see a reference that it was intentional but what information is that based on?

            Comment


              #7
              Folks,

              This seems to be an error in the Linux tar/install. I just spun up a fresh Windows 11 virtual machine, downloaded HS4.2.13.0 from the Homeseer website, installed, and the scripts directory is there.

              Click image for larger version

Name:	temp2.jpg
Views:	98
Size:	29.2 KB
ID:	1559630

              Which is disappointing, because I wanted to post this meme....
              Click image for larger version

Name:	temp.jpg
Views:	90
Size:	45.7 KB
ID:	1559631

              Comment


                #8
                TC1Look closer. zwolfpack shows that it's in 4.2.13.0 but not in 4.2.14.0. Can you try a fresh 4.2.14.0?

                Edit: You might get to use that meme after all.

                Comment


                  #9
                  how about this one?

                  Click image for larger version

Name:	6o8v5z.jpg
Views:	97
Size:	60.8 KB
ID:	1559634

                  Comment


                    #10
                    Originally posted by kenm View Post
                    TC1Look closer. zwolfpack shows that it's in 4.2.13.0 but not in 4.2.14.0. Can you try a fresh 4.2.14.0?

                    Edit: You might get to use that meme after all.
                    Ok, I'm on it, creating another new VM and just downloaded .14.0 beta....
                    I also did a google search on this site and see no reference to the Scripts directory being deprecated.

                    Comment


                      #11
                      Originally posted by kenm View Post
                      TC1Look closer. zwolfpack shows that it's in 4.2.13.0 but not in 4.2.14.0. Can you try a fresh 4.2.14.0?

                      Edit: You might get to use that meme after all.
                      My post shows that 4.1.13.0 had it ...

                      4.1.13.0 appeared to be the end of the 4.1.x.x series. 4.2.14.0 is the current release.

                      I also sampled a few more 4.2.x.x and none had it.

                      Comment


                        #12
                        Originally posted by Dweber85rc View Post
                        I see a reference that it was intentional but what information is that based on?
                        It may have come from reading too much into this exchange: https://forums.homeseer.com/forum/ho...73#post1559373

                        Comment


                          #13
                          Originally posted by zwolfpack View Post

                          My post shows that 4.1.13.0 had it ...

                          4.1.13.0 appeared to be the end of the 4.1.x.x series. 4.2.14.0 is the current release.

                          I also sampled a few more 4.2.x.x and none had it.
                          But as shown above, I installed a fresh copy of HS4.2.13.0 (for Windows/on Win11) and it was there.

                          Comment


                            #14
                            So once again... spun up a fresh Win11 VM... installed HS4.2.14.0... a scripts directory with both the startup and shutdown files was created.

                            Based on this, and the info provided by zwolfpack, one should conclude that this is a bug/issue with the Linux HS4 version, not an overall change to the program.

                            Comment


                              #15
                              Originally posted by TC1 View Post
                              So once again... spun up a fresh Win11 VM... installed HS4.2.14.0... a scripts directory with both the startup and shutdown files was created.

                              Based on this, and the info provided by zwolfpack, one should conclude that this is a bug/issue with the Linux HS4 version, not an overall change to the program.
                              My apologies TC1I asked you to look closer and I was not. Somehow I was seeing 4.2.13.0 instead of 4.1.13.0 in zwolfpack's post. So, it appears that a bug report is in order against the HS4 4.2.xx. Linux releases.

                              Comment

                              Working...
                              X