No announcement yet.

Z-Wave not all Child Devices get created during inclusion

  • Filter
  • Time
  • Show
Clear All
new posts

    Z-Wave not all Child Devices get created during inclusion

    General issue is when adding new z-wave devices it reports it knows there are 5 child devices, two are notification types (home security and power mgmt). However, it fails to create all of the child devices ("4 of the 5 Child devices for node XX were created successfully").

    I've gone through the standard exclusion process, re-inclusion without security and still get the same thing. I've seen this on an occasional z-wave device over the years, but today its the HS floodlight sensor (HS-FLS100-G2). I've had one of these for a year and it has all of the child devices, just not the new one I'm adding today.

    Any suggestions in how to address this? Am I just overlooking the obvious?

    Correct one:

    Click image for larger version  Name:	Screenshot 2022-09-10 135311.png Views:	0 Size:	15.9 KB ID:	1565589

    Incorrect one:
    Click image for larger version  Name:	Screenshot 2022-09-10 135459.png Views:	0 Size:	13.5 KB ID:	1565590

    Have you tried auditing the node? I've had some limited success where HS would pick up additional child devices after an audit.
    Device->Zwave tab->Manage->Audit this node

    Let us know if this works for you.


      I generally re-scan even though it's not recommended. It has found additional child devices and properly included them. Good luck.


        I don’t know why a rescan wouldn’t be recommended. If you have a device missing any child nodes a rescan will usually create them. Certainly a rescan on a properly working device is unnecessary, but it won’t hurt anything.
        HS4 Pro, Windows 10 pro, Supermicro LP Xeon


          Agreed, I just added a few Aeotec and UltraPro devices and 3 of them had the same initial problem.

          Rescans fixed all but one. The 3rd needed to be replaced (thank you Amazon!).


            I've tried audit, optimize, test connectivity and rescan so many times I've proved the definition of insanity today (doing the same thing over and over again and expect different outcome).

            To add to the madness one of the features of the device, power mgmt, logs an error with it can't find the device Id. No Shxx! I've got another device with the same issue, different type of device.

            I dread contacting HS support. I can hear them now, upgrade to our beta z-wave plug - no thank you!