Announcement

Collapse
No announcement yet.

Zwave Node reporting command classes every 3 seconds

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Zwave Node reporting command classes every 3 seconds

    I had a couple of unresponsive devices, so I chekced my log. Nothing related to the unresponsive device (although this could be a cause possibly), but I seen node 27 reporting command classes every 3 seconds. I have not initiated this, also not tried to remove the node. Its a mains powered motion sensor, which seems to be working normally. How can I stop this ? Excluding and including would be very fiddly as its hard to get to.

    This is a extract of the log

    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_SWITCH_ALL
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_SWITCH_BINARY
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_SENSOR_MULTILEVEL_V8
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_ASSOCIATION_GRP_INFO_V2
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_MULTI_INSTANCE_ASSOCIATION
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_ASSOCIATION
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_NOTIFICATION_V6
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_NODE_NAMING
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_POWERLEVEL
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_CONFIGURATION
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_DEVICE_RESET_LOCALLY
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_MULTI_CHANNEL_V3
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_MANUFACTURER_SPECIFIC_V2
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_VERSION
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_FIRMWARE_UPDATE_MD
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_ZWAVEPLUS_INFO
    Oct-30 23:33:37 Z-Wave Z-Net 2: Node 27 is reporting 15 command classes in the node information.
    Oct-30 23:33:37 Z-Wave Warning Device Reset Locally Notification received for device Security Sensors Garage Garage Motion Sensor Root - DEVICE IS BEING REMOVED FROM THE SYSTEM.
    Oct-30 23:33:37 Z-Wave DEVICE RESET LOCALLY: Node removal process completed. (Node 27)
    Oct-30 23:33:37 Z-Wave Node 27 was not removed from any interface in the system, it may still be communicating or function aborted.
    Oct-30 23:33:37 Z-Wave Warning Z-Net 2: Node 27 was not removed because the interface Z-Net 2 does not have that node in its memory. (It may already be removed.)
    Oct-30 23:33:37 Z-Wave Removing node 27 from interface Z-Net 2
    Oct-30 23:33:35 Script multi energy
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_SWITCH_ALL
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_SWITCH_BINARY
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_SENSOR_MULTILEVEL_V8
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_ASSOCIATION_GRP_INFO_V2
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_MULTI_INSTANCE_ASSOCIATION
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_ASSOCIATION
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_NOTIFICATION_V6
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_NODE_NAMING
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_POWERLEVEL
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_CONFIGURATION
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_DEVICE_RESET_LOCALLY
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_MULTI_CHANNEL_V3
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_MANUFACTURER_SPECIFIC_V2
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_VERSION
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_FIRMWARE_UPDATE_MD
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 supports class: COMMAND_CLASS_ZWAVEPLUS_INFO
    Oct-30 23:33:34 Z-Wave Z-Net 2: Node 27 is reporting 15 command classes in the node information.
    Oct-30 23:33:34 Z-Wave Warning Device Reset Locally Notification received for device Security Sensors Garage Garage Motion Sensor Root - DEVICE IS BEING REMOVED FROM THE SYSTEM.
    Oct-30 23:33:34 Z-Wave DEVICE RESET LOCALLY: Node removal process completed. (Node 27)​

    #2
    Try a rescan on the root device. I'd be curious if that worked.
    HS4Pro on a Raspberry Pi4
    54 Z-Wave Nodes / 21 Zigbee Devices / 108 Events / 767 Devices
    Plugins: Z-Wave / Zigbee Plus / EasyTrigger / AK Weather / OMNI

    HSTouch Clients: 1 Android

    Comment


      #3
      I tried a rescan. I also tried a reboot of my HS4. Then I edited the node file, and edited out node 27, and restored that to the controller. Nothing is working, I still get the command classes for node 27 every 3 seconds.
      When restoring the edited node list to the controller, it did not restore node 27. As expected. But when I open my node list, its still there !!!

      Checking file...
      Starting restore operation.
      Restoring node information from the file C:\Program Files (x86)\HomeSeer HS3\Data\Z-Wave\Zwave Network 2_F***_2022-08-18_10.59.41 edited out node 27.zwave. Please wait...
      Erasing the interface...
      Z-Wave Interface Z-Net 2 (1) has been reset to its defaults.
      Erase complete - sending network ID to the controller...
      Restoring node information for node 1...
      Restoring node information for node 2...
      Restoring node information for node 3...
      Restoring node information for node 4...
      Restoring node information for node 9...
      Restoring node information for node 10...
      Restoring node information for node 11...
      Restoring node information for node 12...
      Restoring node information for node 13...
      Restoring node information for node 14...
      Restoring node information for node 15...
      Restoring node information for node 17...
      Restoring node information for node 18...
      Restoring node information for node 19...
      Restoring node information for node 20...
      Restoring node information for node 21...
      Restoring node information for node 22...
      Restoring node information for node 23...
      Restoring node information for node 25...
      Restoring node information for node 26...
      Restoring node information for node 28...
      Restoring node information for node 29...
      Restoring node information for node 30...
      Restoring node information for node 31...
      Restoring node information for node 32...
      Restoring node information for node 33...
      Restoring node information for node 35...
      Restoring node information for node 36...
      Restoring node information for node 37...
      Node information has been successfully loaded - restarting the controller...
      Restore of node information COMPLETE.
      Done!​

      Comment


        #4
        After restoring the edited node list, then the backup node list (the one including node 27) a few times, its now not showing the node classes any more, just this

        DEVICE RESET LOCALLY: Node removal process completed. (Node 27)

        again, every 3 seconds...

        and node 27 has now gone from the node list, but the message keeps coming

        Comment


          #5
          So glad I do regular backups of the whole HS4 folder. I tried excluding and including the motion sensor, nothing worked. In the end I deleted the HS4 folder, and copied the last backup which was only 2 days old. Everything back to working normally, no weird messages in the log any more either.
          Still never seen anything like this before, and hope I'll never see that again...
          And I will keep backing up frequently.

          Comment


            #6
            crazy stuff - glad you got it sorted...
            HS4Pro on a Raspberry Pi4
            54 Z-Wave Nodes / 21 Zigbee Devices / 108 Events / 767 Devices
            Plugins: Z-Wave / Zigbee Plus / EasyTrigger / AK Weather / OMNI

            HSTouch Clients: 1 Android

            Comment

            Working...
            X