Announcement

Collapse
No announcement yet.

hs.speak TTS repeats itself twice?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    hs.speak TTS repeats itself twice?

    I just noticed this a week or so ago. I have some events that speak HS4 devicestatus to my default desktop speaker client. Has been working normally for a year.

    Recently it has been repeating itself twice. I check the speaker client log and sure enough the TTS is logged twice at the same time.

    I do a test and run an immediate script and again twice...

    Click image for larger version

Name:	image.png
Views:	162
Size:	11.0 KB
ID:	1576659
    I reboot HS4 and all is back to normal when I run a typical script command above.

    Once any of my speak events run its back to twice again, even the manual immediate scripts command as well...

    Click image for larger version

Name:	image.png
Views:	91
Size:	9.9 KB
ID:	1576660

    Anyone know what could be causing this?

    Thanks​

    #2
    Guessing you have "wait for speaking to finish" flag on?

    Code:
    Speak
    I’m planning to write a book someday.
    
    To:
    ICS-HSPRO3-W7DEFAULT
    
    And
    Wait for Speaking To Finish
    ​
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
    HS4 Lite - Ubuntu 22.04 / Lenovo Tiny M900 / 32Gb Ram

    HS4 Pro - V4.1.18.1 - Ubuntu 22.04 / Lenova Tiny M900 / 32Gb Ram
    HSTouch on Intel tabletop tablets (Jogglers) - Asus AIO - Windows 11

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Alexa, Cheaper RFID, W800 and Home Assistant

    Comment


      #3
      Thanks Pete but it is not checked in any of the speak events I have. And the HS device variables I use in the events only have one phrase. This is a strange one

      Click image for larger version

Name:	image.png
Views:	101
Size:	21.0 KB
ID:	1576667

      Comment


        #4
        Is there a possibility you are running another plug-in with a speech proxy?
        HS4 Pro, 4.2.19.0 Windows 10 pro, Supermicro LP Xeon

        Comment


          #5
          Thank you Randy. You are spot on. I started disabling and enabling plugins related to speech and I found when disabling SONOS plug-in the repeated TTS stopped.

          I just checked SONOS config and see my speaker proxy flag was checked. Its unchecked and all is well again. Thanks again, I would have never thought to check there.

          Comment

          Working...
          X