Announcement

Collapse
No announcement yet.

Blue Iris Gurus... Help!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Blue Iris Gurus... Help!

    I've run up against something that is making me nutz. I am trying to give a command to move a PTZ camera to a preset. To that end, from a browser:

    This works: /cam/camera-short-name/preset=1 it says "Ok" and moves the camera.

    HOWEVER:

    NOTHING that uses "admin" works. such as: http://192.168.1.xx:yy/admin?camera=...&password=pass

    It merely returns a message that Authorization (is) required.

    I have visited the web server tab checked and unchecked the box "use secure session keys and login page" double checked user and pass, but nothing has helped.

    I've even given open access to logins. This is on a network behind the firewall and it doesn't need to see the Internet (at least not yet).

    Thus far, other people have complained of the same thing, but I haven't found a fix. Any ideas?
    HomeSeer Version: HS4 Pro Edition 4.2.18.1
    Operating System: Microsoft Windows 10 Pro - Desktop
    Z-Wave Devices via two Z-Net G3s
    Zigbee Devices via RaspBee on RPi 3b+
    WiFi Devices via Internal Router.

    Enabled Plug-Ins
    AK Weather 4.0.5.37,AmbientWeather 3.0.1.9,Big6 3.34.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.39.0,BLUPS 2.0.26.0,Device History 3.3.1.0,EasyTrigger 3.0.0.76,Harmony Hub 4.0.14.0,HSBuddy 3.30.1003.1,JowiHue 4.0.8.7,LG ThinQ 4.0.24.0,rnbWeather 4.4.0.0,SDJ-Health 3.1.1.4,TPLinkSmartHome4 2022.12.30.0,UltraCID3 3.0.6681.34300,Z-Wave 3.0.11.0 2

    #2
    I am using this link format to enable and disable cameras. Maybe try it with your info instead of the ???? to see if it works, then try to change the preset?

    IP:PORT/admin?user=????&pw=????&camera=Cam4&enable=0

    Comment


      #3
      Originally posted by jmedemar View Post
      I am using this link format to enable and disable cameras. Maybe try it with your info instead of the ???? to see if it works, then try to change the preset?

      IP:PORT/admin?user=????&pw=????&camera=Cam4&enable=0
      That, too, returns, "Authorization Required." I can log in to BI remotely and into the camera remotely. I just can't get *through* BI to the camera....
      HomeSeer Version: HS4 Pro Edition 4.2.18.1
      Operating System: Microsoft Windows 10 Pro - Desktop
      Z-Wave Devices via two Z-Net G3s
      Zigbee Devices via RaspBee on RPi 3b+
      WiFi Devices via Internal Router.

      Enabled Plug-Ins
      AK Weather 4.0.5.37,AmbientWeather 3.0.1.9,Big6 3.34.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.39.0,BLUPS 2.0.26.0,Device History 3.3.1.0,EasyTrigger 3.0.0.76,Harmony Hub 4.0.14.0,HSBuddy 3.30.1003.1,JowiHue 4.0.8.7,LG ThinQ 4.0.24.0,rnbWeather 4.4.0.0,SDJ-Health 3.1.1.4,TPLinkSmartHome4 2022.12.30.0,UltraCID3 3.0.6681.34300,Z-Wave 3.0.11.0 2

      Comment


        #4
        this works for me to move to a preset as an immediate command in an event

        &hs.URLAction("http://192.168.1.3:82/admin?camera=Cam1&preset=1&user=usernamehere&pw=passwordhere ", "GET", "", "")

        Comment


          #5
          Just confirming my BI settings that work with my URL above. I also read that passwords with special characters can give issues in a URL. Maybe try with a basic password for now to troubleshoot?

          Click image for larger version

Name:	image.png
Views:	114
Size:	224.1 KB
ID:	1593275

          Comment


            #6
            This has been working for me. ("Use secure session keys..." must be unchecked)
            &hs.geturl("http://127.0.0.1","/admin?camera=BackPan&preset=2&user=HS&pw=[redacted]",FALSE,181)

            Comment


              #7
              Originally posted by jmedemar View Post
              Just confirming my BI settings that work with my URL above. I also read that passwords with special characters can give issues in a URL. Maybe try with a basic password for now to troubleshoot?

              Click image for larger version

Name:	image.png
Views:	114
Size:	224.1 KB
ID:	1593275
              That's the ticket! I had "+" and not "^". Thanks a million!
              HomeSeer Version: HS4 Pro Edition 4.2.18.1
              Operating System: Microsoft Windows 10 Pro - Desktop
              Z-Wave Devices via two Z-Net G3s
              Zigbee Devices via RaspBee on RPi 3b+
              WiFi Devices via Internal Router.

              Enabled Plug-Ins
              AK Weather 4.0.5.37,AmbientWeather 3.0.1.9,Big6 3.34.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.39.0,BLUPS 2.0.26.0,Device History 3.3.1.0,EasyTrigger 3.0.0.76,Harmony Hub 4.0.14.0,HSBuddy 3.30.1003.1,JowiHue 4.0.8.7,LG ThinQ 4.0.24.0,rnbWeather 4.4.0.0,SDJ-Health 3.1.1.4,TPLinkSmartHome4 2022.12.30.0,UltraCID3 3.0.6681.34300,Z-Wave 3.0.11.0 2

              Comment


                #8
                You might want to look at controlling the camera with MQTT. That is what I ended up doing...
                HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                Plug-Ins Enabled:
                Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                Comment


                  #9
                  Originally posted by wpiman View Post
                  You might want to look at controlling the camera with MQTT. That is what I ended up doing...
                  Thanks! I will probably look at that, in time, but there are ample Homeseer http commands to control the cameras and, thus far, they seem to do everything I have needed. Tackling MQTT is going to be covering new ground for me and I have bitten off a lot tackling BI and some network issues...
                  Last edited by ewkearns; February 20, 2023, 09:45 AM. Reason: Poor Spelling.
                  HomeSeer Version: HS4 Pro Edition 4.2.18.1
                  Operating System: Microsoft Windows 10 Pro - Desktop
                  Z-Wave Devices via two Z-Net G3s
                  Zigbee Devices via RaspBee on RPi 3b+
                  WiFi Devices via Internal Router.

                  Enabled Plug-Ins
                  AK Weather 4.0.5.37,AmbientWeather 3.0.1.9,Big6 3.34.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.39.0,BLUPS 2.0.26.0,Device History 3.3.1.0,EasyTrigger 3.0.0.76,Harmony Hub 4.0.14.0,HSBuddy 3.30.1003.1,JowiHue 4.0.8.7,LG ThinQ 4.0.24.0,rnbWeather 4.4.0.0,SDJ-Health 3.1.1.4,TPLinkSmartHome4 2022.12.30.0,UltraCID3 3.0.6681.34300,Z-Wave 3.0.11.0 2

                  Comment


                    #10
                    Originally posted by ewkearns View Post

                    Thanks! I will probably look at that, in time, but there are ample Homeseer http commands to control the cameras and, thus far, they seem to do everything I have needed. Tackling MQTT is going to be covering new ground for me and I have bitten off a lot tacking BI and some network issues...
                    Oh, no doubt. Good to go slow. I just rejiggered my setup and forgot how complicated my setup has grown.

                    Is the Blue Iris Plugin still available? I have it and apparently I am still using it for some stuff. I know it isn't supported much anymore. Looks like I don't use it for HS triggers but I just tests the PTZ ability and that is working great.
                    HS3 Pro Edition 3.0.0.435 (Windows Server 8.1 on ESXi box)

                    Plug-Ins Enabled:
                    Z-Wave:,RaspberryIO:,AirplaySpeak:,Ecobee:,
                    weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:

                    Comment


                      #11
                      I believe that you can do all the same commands over http that you can with mqtt in blue iris, or at least that is how the manual reads. I was using http and switched to mqtt and found mqtt to be just a hair faster, but http was never slow either.

                      Comment


                        #12
                        Originally posted by wpiman View Post

                        Oh, no doubt. Good to go slow. I just rejiggered my setup and forgot how complicated my setup has grown.
                        Yeah, it doesn't take long for things to balloon into a monster!

                        Originally posted by wpiman View Post
                        Is the Blue Iris Plugin still available? I have it and apparently I am still using it for some stuff. I know it isn't supported much anymore. Looks like I don't use it for HS triggers but I just tests the PTZ ability and that is working great.
                        I think the consensus is that it is no longer supported. I couldn't find it in the list of available plugins, but I haven't seen a definitive statement that it is toast. BI keeps moving along with updates at a breakneck pace. The old PI was for HS3 and BI4 or earlier. So, I suspect there are a lot of current features that aren't supported. There seems to be a LOT of user interest in a current PI for HS4 and BI5, if any developers out there are interested.... (hint, hint, nudge, nudge).

                        HomeSeer Version: HS4 Pro Edition 4.2.18.1
                        Operating System: Microsoft Windows 10 Pro - Desktop
                        Z-Wave Devices via two Z-Net G3s
                        Zigbee Devices via RaspBee on RPi 3b+
                        WiFi Devices via Internal Router.

                        Enabled Plug-Ins
                        AK Weather 4.0.5.37,AmbientWeather 3.0.1.9,Big6 3.34.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.39.0,BLUPS 2.0.26.0,Device History 3.3.1.0,EasyTrigger 3.0.0.76,Harmony Hub 4.0.14.0,HSBuddy 3.30.1003.1,JowiHue 4.0.8.7,LG ThinQ 4.0.24.0,rnbWeather 4.4.0.0,SDJ-Health 3.1.1.4,TPLinkSmartHome4 2022.12.30.0,UltraCID3 3.0.6681.34300,Z-Wave 3.0.11.0 2

                        Comment


                          #13
                          Originally posted by ewkearns View Post

                          That's the ticket! I had "+" and not "^". Thanks a million!
                          I have the same problem, what I'm trying to do is enable or disable a camera, what is the command for it? I'm a little confuse about your statement, was the + in the password that was causing issues?

                          Sent from my SM-S906U using Tapatalk

                          Comment


                            #14
                            Alpha - this is what I use to enable or disable camera(s)

                            enable: &hs.URLAction("http://192.168.1.3:82/admin?camera=Cam1&enable=1&user=usernamehere&pw=passwordhere ", "GET", "", "")

                            disable: &hs.URLAction("http://192.168.1.3:82/admin?camera=Cam1&enable=0&user=usernamehere&pw=passwordhere ", "GET", "", "")

                            Comment


                              #15
                              Originally posted by alphatech View Post
                              I have the same problem, what I'm trying to do is enable or disable a camera, what is the command for it? I'm a little confuse about your statement,

                              Originally posted by alphatech View Post
                              was the + in the password that was causing issues?
                              It was, for me, because I kept getting a request to log in, when using the example provided above by will40. The example was correct, but the computer was demanding an unnecessary login. If you read this post, it shows where the "^" goes and the long and short of that is it tells the computer to not bother with asking for the login, so everything just fluidly happens. BI has an awesome 250 page manual that gives a rundown on all of the goodies, including the above, which I missed on the first read through.
                              HomeSeer Version: HS4 Pro Edition 4.2.18.1
                              Operating System: Microsoft Windows 10 Pro - Desktop
                              Z-Wave Devices via two Z-Net G3s
                              Zigbee Devices via RaspBee on RPi 3b+
                              WiFi Devices via Internal Router.

                              Enabled Plug-Ins
                              AK Weather 4.0.5.37,AmbientWeather 3.0.1.9,Big6 3.34.0.0,BLBackup 2.0.63.0,BLGData 3.0.55.0,BLLock 3.0.39.0,BLUPS 2.0.26.0,Device History 3.3.1.0,EasyTrigger 3.0.0.76,Harmony Hub 4.0.14.0,HSBuddy 3.30.1003.1,JowiHue 4.0.8.7,LG ThinQ 4.0.24.0,rnbWeather 4.4.0.0,SDJ-Health 3.1.1.4,TPLinkSmartHome4 2022.12.30.0,UltraCID3 3.0.6681.34300,Z-Wave 3.0.11.0 2

                              Comment

                              Working...
                              X