No announcement yet.

Homeseer Webserver won't open using localhost

  • Filter
  • Time
  • Show
Clear All
new posts

    Homeseer Webserver won't open using localhost

    I hope somebody can help shed some light on the issue I have. So I run HS4 on a local windows PC network on port 8888 for years. Any other network PC or mobiles via wifi can access HS4 with my same logon credentials no issues.

    Today I noticed that I am not able to access HS4 using localhost or loopback address on the PC where HS4 resides with any of my web browsers. I can access both loopback and localhost on port 80 and get Windows IIS to come up and also another port that I run codeproject on with no issues.

    I have toggled off my firewall and tried with no difference. Not using a proxy. Any idea what I am doing wrong or could be the cause?


    I, too, would like to understand this, if it is the same thing I am witnessing. Most of my issues [broken websites] have "fixed" themselves, but I can no longer view my PWS at I'm pretty sure this is a war waged between "HTTP" and "HTTPS," but this all started [for me] when I tried to check the weather yesterday morning. It seems browser independent.
    HomeSeer Version: HS4 Pro Edition
    Operating System: Microsoft Windows 10 Pro - Desktop
    Z-Wave Devices via two Z-Net G3s
    Zigbee Devices via RaspBee on RPi 3b+
    WiFi Devices via Internal Router.

    Enabled Plug-Ins
    AK Weather,AmbientWeather,Big6,BLBackup,BLGData,BLLock,BLUPS,Device History,EasyTrigger,Harmony Hub,HSBuddy 3.30.1003.1,JowiHue,LG ThinQ,rnbWeather,SDJ-Health,TPLinkSmartHome4 2022.12.30.0,UltraCID3 3.0.6681.34300,Z-Wave 2


      You could check if something else is blocking the port by running this on an elevated command prompt:

      netstat -abn
      or a bit nicer to grab only the listening processes:

      netstat -abn | powershell "$Input | Select-String -Pattern \"LISTENING\" -Context 0,1"
      Which will also show if it's listening on a specific IP or all of them (


        Thanks pseudocode I’ll try those. I did discover this morning however when I change Setup>Labs binding my Homeseer server to an IP both localhost and loopback IP work. I found years ago on my dual NIC HS PC that I needed to bind HS server to the same as my wifi so that it will support plugins such as Sonos, Lifx, and GEM power monitors.

        so I removed my wifi IP bind and left default. Restarted Homeseer and the webserver defaulted to my hard Ethernet interface IP. I lost the plug in support but I was able to connect to HS4 via localhost and loopback IP.

        As soon as I change back and re-bind my IP to wifi address plugs all restore but I lose localhost.

        arghhh. I am sinking here.


          No idea about the internals of HS, but if you specify a connection IP to bind then it's correct if it doesn't bind to anything else.

          Any particular reason you need localhost? Using the "real" IP address isn't any different, the stack is sensible enough to not send anything out onto the network.


            Yeah I am seeing that today. Right now I disabled my ethernet interface and started HS with no bind in Setup>Labs and all is fine. I then enabled my ethernet adaptor to support other various HS peripherals. All will be fine until I have to restart HS but gives me sometime to wrap around this with a solution.

            The reason I need HS to run on loopback/localhost is that HSBuddy plug in uses it to enumerate cameras. Without access I get countless errors that fill my HS log. I am hoping the author avargaskun can suppress these non-critical log errors or somehow use my bound HS IP address instead of the loopback address. The log error below is clear. I thought I could fix the issue but sounds like I have exhausted a fix for my end with little to no networking experience.

            Failed to enumerate HomeSeer cameras.|System.Net.Http.HttpRequestException: An error occurred while sending the request. ---> System.Net.WebException: Unable to connect to the remote server ---> System.Net.Sockets.SocketException: No connection could be made because the target machine actively refused it

            Thank you for your help.


              an update. It is determined that I cannot access the HS webserver using localhost nor loopback address if the IP address in bound using HS Setup/Labs.

              avargaskun made a very quick fix in the plugin to request from the webserver address and now the plug in errors are gone. Thanks to all who tried to help. I learned something new with Homeseer today.