Announcement

Collapse
No announcement yet.

Linking devices with reversed control uses

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Linking devices with reversed control uses

    Weird one here. I have lights from SmartThings that import with a 0 as on, 1 as off. I'm trying to link it with a Zigbee light that has 0 as off and 1 as on (makes more sense that way but whatever).
    Wreaks havoc to say the least!
    Tried changing the ST lights controls to the same as the Zigbee light, didn't help.
    Tried changing just the ST light "control use" section to ON for the 1 and left the 1 as off, didn't work. (ie the Start was 0, Label was ON, and Control Use was OFF.)
    Is there a way to reverse controls when linking devices?

    Edit: Yeah, I know I could do events, looking for a simpler and less "work" way. On should be ON even when linking.

    #2
    Unfortunately, HS only deals with values. Changing the Status or “Control Use” (primarily for voice control) will have no effect on what the values represent. When you link devices, it is value for value only. The problem is that the Smart Things Devices are using different values than the norm. Unless the ST developer can change the way devices are created, you will have to use events.
    HS4 Pro, 4.2.19.0 Windows 10 pro, Supermicro LP Xeon

    Comment


      #3
      Kinda figured that. Hoped I was wrong. Oh well. At least the conditional events will come in handy here.

      Comment

      Working...
      X