Announcement

Collapse
No announcement yet.

CPU spikes to 100% for 10 seconds every 60 seconds.

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    CPU spikes to 100% for 10 seconds every 60 seconds.

    Issue: CPU spikes to 100% for 10 seconds every 60 seconds. Normal utilization is 5% between these spikes.

    Things I have checked:
    This behavior only happens when HomeSeer is running. Task Manager shows HomeSeer.exe is the CPU hog when the CPU spikes to 100%.
    HomeSeer Log does not show any events being triggered when the CPU spikes to 100%
    Configuration does not have any recurring events enabled.

    Environment:
    Windows XP SP2
    CPU Pentium III 930 MHz
    RAM 512 MB
    HomeSeer 1.7.3
    HSPhone 2.0.17

    Does anyone have any ideas as to how I can enable more verbose logging to see what HomeSeer is running? Any advice or tips would be appreciated.

    #2
    Additional Test

    I have disabled VR and TTS, and I am still having the same CPU spikes.

    Comment


      #3
      hs.debug will generate a log of activity. It has parameters that define level of information. It should be in the help. I think hs.debug 15 is verbose.

      Comment


        #4
        HomeSeer checks conditional events every minute, so it's possible this is happening and bogging things down if you have LOTS of conditional events or conditional events that are running a script that could be the cause.

        Michael McSharry's advice to enable debugging is a good one and will hopefully generate some clues to what's happening.

        Paul

        Click to visit: www.sbsmarthomes.com
        Santa Barbara Smarthomes

        Authorized Russound Dealer & Installer

        Personal HA Website

        HomeSeer User Profile

        Comment


          #5
          How do I enable debugging.

          I searched for hs.debug and couldn't find anything on my drive. How do I enable debugging?
          James

          Running HS 3 on Win10 .

          Comment


            #6
            Are you checking mail every minute?

            If you are delete all messages on server and it will go away.
            If this is your problem, use Outlook or Outlook Express as you mail client and then hook HS to that program for mail send and receive.


            ~Bill

            Comment


              #7
              Originally posted by jasv
              I searched for hs.debug and couldn't find anything on my drive. How do I enable debugging?
              They at least used to be remmed out in your start up script.

              Unrem the level of debug your want and restart HS.


              ~Bill

              Comment


                #8
                Define a manual event and in the Script action line type
                &hs.debug 15

                You will also want a second event to turn it off
                &hs.debug 0

                Comment


                  #9
                  Conditional Events

                  I have disable all of my conditional events (about 15 total), saved the config, and restarted homeseer. I am still seeing the CPU spike every minute for 10 seconds. I will try the debug option next.

                  Comment


                    #10
                    You don't happen to have a z-wave thermostat, do you? I have noticed the same thing on my machine and I wonder if it is when it polls the z-wave thermostat...

                    Comment


                      #11
                      Resolution

                      I ran the command to set the trace &hs.debugmode = 31. This bitmap level records everything according to the help files. This trace is written to hstrace.log when 16 or greater is used.

                      hstrace.log showed the following:

                      6/14/2005 5:47:00 PM:64020.36: Exit SaveSetting->last_event_time
                      6/14/2005 5:47:00 PM:64020.36: Enter CheckMail
                      6/14/2005 5:47:18 PM:64038.74: Exit CheckMail
                      6/14/2005 5:47:18 PM:64038.74: Enter CommitDeviceStatus->Device:
                      6/14/2005 5:47:18 PM:64038.75: Exit CommitDeviceStatus


                      My config was set to check for mail every 2 minutes. I disabled it and the CPU spikes went away. Not sure why. I could be because my mail file is huge, or latency with my mail server. At least I know what the problem is now.

                      Thanks so much to all who replied. It is phenominal how active the homeseer user community is. This model of support is much more effective than any other software company I have seen. I love it.

                      Comment


                        #12
                        I was just going to write and tell you ANYTHING in HomeSeer that access' the Internet can cause that effect. You probably want to decrease that polling. I get this with pings, and GETURL's and mail, so you gotta be careful.

                        Comment

                        Working...
                        X