Announcement

Collapse
No announcement yet.

A little help please!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    A little help please!

    ok , I had a major hard drive crash. I reinstalled HS and put all my scripts and stuff back in place.

    Now, NONE of the scripts that worked before to get information from the web are working. For instance weather scripts. Also .asp pages are no longer displaying with "called information"> Meaning the pages show up but all the information being retreived is left blank.

    EA:
    Current temperature:
    Wind direction:

    I have downloaded the web wrapper, all the new Includes ect..ect... Anyone else know where to start looking for a sollution? This is the latest version available of HS as of 4/4/4 (Yes, that is today's date, not some garden fertilizer

    On another note, ALL of these scripts worked prior to this reinstall. I even grabbed a few from the script library to try them out and have the same results.

    Added Note:
    I just found this in my log file:
    4/4/2004 11:30:00 PM~!~Error~!~In GetURL: Can't find DLL entry point UrlToFile in ahutil.dll

    Any idea's?
    Visit My Home Seer Site at:
    www.JohnWPB.com
    Created with LCARS

    #2
    John

    Have you updated your script engine to 5.6. That little gotcha drove me crazy a few months ago.

    john

    Comment


      #3
      John,

      Well I just grabbed that from MS's site, to no avail

      I also on a LOT of my pages have reference to a reg key (for a registry entry that is not there) of:
      Script error: Invalid root in registry key "HKCU\Software\VB and VBA Program Settings\AutoHome\Settings\gNavigationLoc"

      I did a search on the board and really came up with nothing pertaining to it, other than changing all of the scripts. I went into my calendar.asp page and deleted all refrences to "Include" and still am getting this error.

      Does anyone have this reg key they would be willing to export and post it up here? I am at wit's end here and it is getting really frustrating!

      Thanks!
      Visit My Home Seer Site at:
      www.JohnWPB.com
      Created with LCARS

      Comment


        #4
        John,
        That's HS's main DLL. I would try a repair on your HS installation. Start > programs > add/remove programs. Select HS and then select the repair option.
        -Rupp
        sigpic

        Comment


          #5
          Yes, it sounds like you have the incorrect ahutil.dll. There may be an old one on your system. Search your drive for the file ahutil.dll and make sure you only have one. It should be in your HS folder. I suspect you have an old one in your system folder.

          -Rich
          website | buy now | support | youtube

          Comment


            #6
            Thanks Rupp, that repair did the trick!

            Rich, I just did a search for the dll and found version 1.0.0.1 in the HS directory. I couldnt figgure out why. THen it dawned on me, I did a fresh install of the latest HS, and then copied all but the executable into that directory to keep all my settings, style sheets ect ect. Duh!


            That took care of the .asp problem, but many of the scripts are still trying to get info from the reg key I mentioned above. I have so many scripts and do not want to edit all of them, is there a way to "insert" that reg key back into the registry? What was it that originally placed it there?

            Script error: linkshow = WshShell.RegRead("HKCU\Software\VB and VBA Program Settings\AutoHome\Settings\gNavigationLoc")voiceshow = WshShell.RegRead("HKCU\Software\VB and VBA Program Settings\AutoHome\Settings\webvenabled")

            This should also be entered into the registry with current releases of HS so it is "backwards compatible". The .ini is a far better way of doing things, but the reg key is obviousally needed by a lot of current scripts as well.
            Visit My Home Seer Site at:
            www.JohnWPB.com
            Created with LCARS

            Comment


              #7
              Wow John it has been a while since you have rebuilt. This registry key had been in existence foe well over a year. I think you will find it "cleaner" and easier in the long run to edit your scripts and get rid of the old includes (which look for that registry key). It should be as simple as updating to the newest includes. But nothing is ever that simple.
              -Rupp
              sigpic

              Comment


                #8
                Rupp, Well it's DEFINATELY not that easy. I replaced the includes with the latest ones and that was no help. Just about EVERY script on my system is calling for that reg key. Including a LOT of recent ones, the latest 5 day forecast, the isholiday script and calendar, all of my weather pages, calculator page, webcam pages a lot of the cuztomized pages for the touchpad interface, well over 20 scripts.

                This is what lead me to to beleive, although those reg keys are no longer active, unless a complete OS re-install was done, you would never know what scripts are STILL using them.

                It will have to wait I guess, I am FAR too burnt out on HA right now to go back and fix all that was already working after spending countless hours on each of them to get them working in the very first place, and now to make it all work again.
                Visit My Home Seer Site at:
                www.JohnWPB.com
                Created with LCARS

                Comment


                  #9
                  John,
                  Take the easy way out and add the value from that registry key to your includes file and it will get picked up by editing one file.
                  Like
                  linkshow = "value here"
                  voiceshow = "value here"
                  -Rupp
                  sigpic

                  Comment


                    #10
                    I have no idea what value's are being asked for really.

                    I JUST installed the isholiday/calendar package. ALL of the .asp pages in the package come up with this error. This package is fairly new as you know. Try removing that key from your registry and I think you will see the scope of how it effects just about EVERYTHING.
                    Visit My Home Seer Site at:
                    www.JohnWPB.com
                    Created with LCARS

                    Comment


                      #11
                      John,

                      There is still something basically not right with your HS install. I do not have "HKCU\Software\VB and VBA Program Settings\AutoHome" in my registry and everything works fine. I did a search of all my scripts and I found only one reference to this registry entry in an old script I don't use any more. No new scripts or script updates within the last year or more should be using any registry entry as they are not maintained by HomeSeer. I tend to agree with Rupp that it is an old include somewhere that is picking it up. Have you checked the specific scripts and asp's? Do they directly reference this key or is it through an include? Since I don't have the registry entries, I can't provide them, otherwise I would.

                      Your best bet would be to open a help desk ticket.

                      Bill

                      Comment


                        #12
                        The only thing that all of those scirpts should have in common is header.asp and style.asp.
                        I just did a new install in December on a brand new hard drive. I did not see the errors you are seeing which makes me think that when you copied back your files back, you copied in an old header.asp.

                        I would delete the header.asp file that you have in the includes directory and then use the updater to install the Include Scripts. I just checked and the header.asp that is in the updater does not have a reference to the registry keys.
                        --
                        Jeff Farmer
                        HS 3, HSPhone
                        My HS3 Plugins: CFHSExtras, Random, Restart, Tracker, WeatherXML, PanaBluRay
                        Other Plugins In Use: APCUPSD, BLOnkyo, Device History, EasyTrigger, HSTouch Server, PHLocation2, Pushover, RFXCom, UltraGCIR3, UltraMon3, UltraPioneerAVR3, X10, Z-Wave

                        Hardware: GoControl Irrigation Controler, Schlage Lever Lock, Schlage Deadbolt, Way2Call Hi-Phone, RFXCom RFXrec433 Receiver, WGL 800, TI-103, Z-Net, Pioneer 1120, Pioneer 1021, Pioneer LX302, Panasonic BDT-110, Panasonic BDT-210 x2

                        Comment

                        Working...
                        X