Announcement

Collapse

Contacting HomeSeer This Week

HomeSeer is open and operational this week. All orders are being processed and shipped as usual. However, some staff are working from home. If you need to contact HomeSeer for support or customer service, please use our Email or Chat options. https://homeseer.com/contact-us/
See more
See less

Error in Enable Voice~!~Method '~' of object '~' failed

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Error in Enable Voice~!~Method '~' of object '~' failed

    Anyone see this error.

    I had to rebuild my machine, and since I couldn't figure out a good way to restore a backup (I switched drive letter allocations in the rebuild), I just rebuilt from scratch all events and devices. However, since installing HS again, I am getting this in the logs.

    4/26/2004 1:50:56 PM~!~Error in Enable Voice~!~Method '~' of object '~' failed

    It happens pretty often. I also get an error about a path not being found but I searched all apps for a mention of the old drive (G and fixed them all.

    Anyone see this or have any idea what is causing it?

    Jay Fro

  • #2
    Hi Jay Fro,
    Sad to say but since I've updated to ver 1.7 I've had this error occur 13 times... but had none prior to this.

    4/26/2004 2:24:24 PM~!~Audio Debug~!~Warning, speak error, resetting speech: Method '~' of object '~' failed

    Stuart

    Comment


    • #3
      Jay Fro,
      Have you tried the repair option on your HS installation to see if that fixes it? Start > settings > control panel > add/remove programs. Select HS and during the uninstall it will ask you if you want to do a repair.
      -Rupp
      sigpic

      Comment


      • #4
        After all of the pain I went through to get this back and running for the most part (minus HSP issues with announcing...) I really don't want to do this. It seems others are having some issues with this latest HSP and HS builds. Just a bummer than I lost my HD, then I couldn't figure out any reasonable way to restore from backups other than guessing and choosing which files to copy over to the new directory. Of course HS has to go and upgrade their software in the middle of all of this so now I have no idea if it is software, driver, hardware or whoknowswhat related.

        For now, I will ignore the log entries. I can't beleive there isn't a "Detailed Log" function to see what is going on in HS when the error occurs).

        Oh wait, just got new emails. HS says it is announcing them... but NOOOOO, no sound. Worked a few minutes ago! Here is the log:

        4/26/2004 8:09:22 PM~!~Info~!~Exec command: Living Room Speakers on dim: 0 extra: 0
        4/26/2004 8:09:24 PM~!~Error in Enable Voice~!~Method '~' of object '~' failed
        4/26/2004 8:09:24 PM~!~Speak~!~Jay's has received, 2 new email messages from,
        4/26/2004 8:09:28 PM~!~Error in Enable Voice~!~Method '~' of object '~' failed
        4/26/2004 8:09:28 PM~!~Speak~!~"Dan Gordon" , with the subject of, RE: RE: It's on!
        4/26/2004 8:09:37 PM~!~Error in Enable Voice~!~Method '~' of object '~' failed
        4/26/2004 8:09:37 PM~!~Speak~!~and from
        4/26/2004 8:09:38 PM~!~Error in Enable Voice~!~Method '~' of object '~' failed
        4/26/2004 8:09:38 PM~!~Speak~!~"Julie C. Taylor" , with the subject of, roof
        4/26/2004 8:09:39 PM~!~Info~!~Sending email To: 1111111111@messaging.sprintpcs.com From: "Dan Gordon"
        4/26/2004 8:10:39 PM~!~Error~!~Timeout while connecting to SMTP server, message not sent, will retry later
        4/26/2004 8:10:39 PM~!~Error in Enable Voice~!~Method '~' of object '~' failed
        4/26/2004 8:10:39 PM~!~Speak~!~Angie's has received, 4 new email messages from,
        4/26/2004 8:10:40 PM~!~Info~!~Sending email To: 1111111111@messaging.sprintpcs.com From: "Dan Gordon"

        Oh.. the SMTP timeout.. who knows what that is about. SMTP server is on local machine and working flawlessly. Tried 127.0.0.1 and the server name, which works for every other app.

        Jay Fro

        Comment


        • #5
          few things are fixed. After installing W2C, forgot that it sets the USB device as default audio. screws things up, although not always.

          so far, after changing the default audio to my sound card, I also don't see the error, so it must have been related.

          SMTP error, who knows. I pointed it to my ISP and it works. Guess HS doesn't work with MS SMTP server in Win2K???

          It looks like the only issue left is a Error loading ini settings in the Touchpad interface.

          Things are looking better!

          Oh yah, and the reason no announcement at all for the past hour or so.... the 6 year old decided to unplug my wireless audio sender so he could play with Bill Bass in the Basement

          Jay Fro

          Comment


          • #6
            Jay Fro,
            I do not think this is related to last version of HS.
            I was getting this error from time to time before as well.
            One think for sure – If you use WinXP VNC, the system will log out and you will get this error (not always.. ).
            Also my Homeseer sometimes locks up when speaking and needs to be restarted (processor around 20% so Guardian Angel doesn’t help).
            I tried to repair HS as Rupp suggested, I also reinstall voices but nothing helped so far. I really didn’t have a time to mess with that so I just live with it for right now.
            If you search the board you will find a quite few threads about this problem.

            Marty
            A Person is Smart. People are Dumb, Panicky Dangerous Animals.
            1,500 years ago, everybody knew that the Earth was the center of the universe.
            500 years ago, everybody knew that the Earth was flat.
            15 minutes ago, you knew that humans were alone on this planet.
            Imagine what youll know tomorrow.
            TLJ in MIB

            Comment


            • #7
              No error in enable voice since I changed the default sound device in Win2K back to the Soundblaster card. I don't know if the W2C USB device or ATT made the change (I assume the W2C did), but you need the default sound device set back to the sound card. Cleared it up for me.
              Jay Fro

              Comment


              • #8
                I get this error alot if when I leave a Terminal Services connection to the homeseer PC open, something todo with the sound redirected to the console. I get around it by running the following (taken from another post on this site).

                %windir%\System32\tscon.exe 0 /dest:console

                Phill

                Comment

                Working...
                X