Announcement

Collapse
No announcement yet.

Port Already Open

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • Port Already Open

    Wonder if anyone can help... I've searched the knowledgebase and forums, but can't find anything resembling this situation.

    My Homeseer has been working fine for weeks, but suddenly stopped working yesterday. Homeseer still runs, and I can access the web interface. Commands update the Homeseer interface, but do not effect lights/appliances at all. Looking at the Homeseer log I can see an error with the message 'Port Already Open' on startup (which I assume relates to the COM port on which my CM12U resides - COM1).

    I've not added any serial hardware to my system lately, or any software which uses COM ports to my knowledge. I've checked device manager and there are no reported device problems or IRQ conflicts.

    I've unplugged/replugged the CM12U both from the PC and from the wall outlet - to no avail. I've restarted the PC several times as well - no good.

    One thing that is different - Homeseer used to start automatically at startup and suddenly seems to have stopped. I've manually added it back into the startup but it made not difference.

    Can anyone suggest any reason why Homeseer would have stopped loading at startup on it's own? (I considered the possibility that it's already running and therefore a second instance of Homeseer is using COM1, but checked and homeseer.exe is not in running processes) Secondly, can anyone suggest a way to determine if some other application has latched onto Com1? Failing that, is it possible that my CM12U is malfunctioning??

    Many thanks for your advice.

    Tom

  • #2
    If you have not powered off your machine and cold-booted it, I would try that first. It is possible the hardware on your machine is somehow hosed and a cold boot would reset it. This happens once in a while to software-based modems and USB hardware, too.
    |
    | - Gordon

    "I'm a Man, but I can change, if I have to, I guess." - Man's Prayer, Possum Lodge, The Red Green Show
    http://HiddenGemTech.com - http://MaineMusiciansExchange.org - http://www.WJZF.org

    Comment


    • #3
      Thanks - tried a full shutdown and cold start last night... no luck. Any further thoughts?

      Thanks again,

      Tom

      Comment


      • #4
        twynne,
        Something has that com port locked. Did you load active home or any other software that my require a com port?
        -Rupp
        sigpic

        Comment


        • #5
          Afraid not - have never loaded ActiveHome. And I've not (to my knowledge) installed anything which accesses the COM port. Unfortunately I only have one port or I'd try swapping it to another.

          Is there any way to tell what program(s) are accessing ports?

          Comment


          • #6
            What version of Windows are you running?

            Does your HomeSeer machine use dial-up or have a modem installed?



            Jim

            Comment


            • #7
              Hi Jim,

              Running Win XP Pro SP1. I have a modem installed but it's PCI and uses COM5. I don't have any type of dialup running at all on this machine. Does this help?

              Comment


              • #8
                Did the problem start after an XP crash or incomplete shutdown? XP seems at times to go back to previous settings in its life when it has problems. Since you have evidence that XP changed itself (the change in homeseer start up), I'd look for some type of IR or pda hotsync application that has reinstated it self and grabs the com port when XP boots.
                Why I like my 2005 rio yellow Honda S2000 with the top down, and more!

                Comment


                • #9
                  You can also try and open the port with hyperterm and see if you get the same error.

                  -Rich
                  website | buy now | support | youtube

                  Comment


                  • #10
                    It can be also defective COM port. Did you try to hook up your CM12U to another port (COM2) also if you running COM5, it might share IRQ with COM1. Try to remove your modem and uninstall it's drivers. (Actually first uninstall and then remove ) IRQ's can be tricky. It will not show conflict, but if your IRQ sharing doesn't work properly it can be hell. Sometimes quick play with IRQ settings in your BIOS will do the trick. Did you try to unhook you CM12U and boot up your computer to make sure that is not your X10 "frozen" controller what is messing up your COM1.

                    Try and let us know.


                    Marty
                    A Person is Smart. People are Dumb, Panicky Dangerous Animals.
                    1,500 years ago, everybody knew that the Earth was the center of the universe.
                    500 years ago, everybody knew that the Earth was flat.
                    15 minutes ago, you knew that humans were alone on this planet.
                    Imagine what you’ll know tomorrow.
                    TLJ in MIB

                    Comment


                    • #11
                      And don't forget to look in the BIOS to see if it is disabled or somehow the configuration has changed...
                      |
                      | - Gordon

                      "I'm a Man, but I can change, if I have to, I guess." - Man's Prayer, Possum Lodge, The Red Green Show
                      http://HiddenGemTech.com - http://MaineMusiciansExchange.org - http://www.WJZF.org

                      Comment

                      Working...
                      X