Announcement

Collapse
No announcement yet.

Speaker issue: timing out

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Speaker issue: timing out

    I was updating some scripts today and I started getting the following error message from HomeSeer when I try to address my (previously working) speaker clients:

    Sending command to Speaker Client, Command 10:The response has not been received within the specified period of time.

    I tried everything - restarting speaker clients and homeseer with no luck. Then after a while, it generated a string of errors in Homeseer and started working again. The errors looked like this:

    5/18/2008 3:44:17 PM - Error - Sending command to Speaker Client, command 10:The client application HOST (URL: <none> URI: _gtcp://24c14b5354ef4a13b35dab2ab44d667c LocalNo: 12 RemoteNo: 443) has not reconnected within the specified timeout. The information associated with that remote host will be released.
    5/18/2008 3:44:17 PM - Error - Sending command to Speaker Client, command 10:Can not establish a connection to the remote host "_gtcp://24c14b5354ef4a13b35dab2ab44d667c".
    5/18/2008 3:44:17 PM - Info - Speaker Client speech recognition stopped

    then this error 6 times (presumably one for each speaker.exe I have running around the house?):

    5/18/2008 3:44:17 PM - Error - Sending command to Speaker Client, command 10:Object reference not set to an instance of an object.

    Anyone have any idea what is going on here, or what I may have done to cause this?

    #2
    The line "Can not establish a connection to the remote host" means the speaker clients can not longer connect. Antivirus software, firewall sotware, and Microsoft updates can all cause this. In addition a change in ipaddress can cause this as well.
    -Rupp
    sigpic

    Comment


      #3
      I did check IP connectivity between the machines (but I did not check the specific port that Speaker is using) and this was fine. I only run one firewall on the network and all machines are behind it so it does not restrict connectivity between my private network PCs. Antivirus is set to scan in the middle of the night. All of my machines have static IPs.

      I am dubious about a connectivity issue - I will watch it to see if it happens again. If it does, I will examine the connectivity issues more closely.

      Comment


        #4
        I was able to reproduce the problem. I had to restart Homeseer to update a plugin file. When I restarted it the speakers on one remote machine all show that they reconnected, but nothing was showing up in the log and they were not responding to commands sent to them.

        I checked connectivity between the two machines and it was fine. I had to restart each instance of speaker before they would work again? I am running five instances of speaker on this machine (it is my media server and I am using a copy for each channel on the whole house audio system). It appears that all speaker clients on this machine must be restarted when the Homeseer server is restarted for them to work again?

        P.S. I have a speaker client running on another machine on the network and it reconnects and responds just fine.

        Comment


          #5
          So if you have multiple speaker apps running on one machine you notice this reconnection issue? If so I would put in a help desk request on this issue.
          -Rupp
          sigpic

          Comment

          Working...
          X