Announcement

Collapse
No announcement yet.

Conflicting device codes between plugins

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Conflicting device codes between plugins

    My ElkM1 pluging has been installed for a while. Even though I currently don't have any outputs defined in Elk, it took the "_" device code for the outputs. I will certainly use the Elk outputs in the future, and have a rather large setup of devices and rules associated with my ElkM1 plugin, so I don't want to change any of this.

    I recently installed pjcOutlook and since there were no outputs defined for Elk, pjcOutlook took "_" as it's device code as well. So, when I make changes to the pjcOutlook devices, it shows up as ElkM1 device changes in the log. Don't think it's an issue currently, but I don't want to run into any issues when I define Elk outputs. I'd much rather fix the issue now and recreate pjcOutlook devices etc. now.

    I haven't been able to figure out how to change the pjcOutlook device codes ... thoughts?

    (I'm putting this in the general forum, since I don't think it's an issue of either of the plugins)

    #2
    Nothing like solving your own problems with a very simple doh!

    For anyone else's benefit that might be curious, all I did was:

    - deactive the pcjOutlook plugin
    - shut down HS
    - using ElkRP, I made sure that the first 16 outputs were selected to 'show'
    - restarted HS, which now created devices for all the outputs (on the "_" device code previously used by pjcOutlook)
    - reactivated pjcOutlook, and clicked on the "create devices" button, which now created my task devices, but using a different device code (one that does not conflict with anything)

    vola!

    Comment

    Working...
    X