No announcement yet.

Status goes to 'Unknown' after a few minutes

  • Filter
  • Time
  • Show
Clear All
new posts

    Status goes to 'Unknown' after a few minutes

    I am using about 20 Insteon devices in a weekend house, and I have had very stable operations for about a year. Starting about a week ago, most of my devices show an unknown status . Once the device status goes to unknown, when I try polling the devices Homeseer says "Polling fails" for each device.

    However - if I then turn each of the devices off by sending a signal from Homeseer, and refresh my web page, their status does turn to off. And then here is the confusing part - if I poll the devices every one of them responds to the polling with their correct status.

    If I leave Homeseer alone, after about 10 minutes the status of the devices is again Unknown, and I can repeat the whole cycle.

    I first suspected some sort of noise has been injected into the line, but that would not explain why polling works immediately after I send signals to the devices by turning them off.

    Has anyone observed this sort of behavior before, or have any ideas how I might correct it?


    If you click on HS's "Poll Devices" from the Status page, it actually checks the device and will tell you if it was unable to communicate with the device (Polling Failed), and will set HS's device status to "Unknown".

    However, if you tell HS to turn off a device, it will report that it is off, even if it couldn't communicate with the device. Even refreshing the page 20 minutes later, it is still showing me that it turned it off successfully, and my PLM is unplugged at the moment! If you then poll the device using a script command, it will poll HS for it's status (giving you the False idea that it turned off, even though the "Off" command failed).

    There is a way around this glitch (at least this is what I had to do early last year, maybe things have changed since) - toggle the device (if it's on, turn it off). Poll the device (hs.PollDevice) then wait about 45 seconds before you issue the hs.DeviceStatus command, and it will return the correct status (including "Unknown" if the communications failed) AND HS's status will also update to reflect the polled result.



      Thanks for your response. I probably wasn't clear enough in describing my problem. The simplest way to put it is this: When I click on 'Poll devices' Homeseer is unable to communicate with the device (it gives me the message 'Polling failed'). If I then turn the device on or off (from Homeseer) and click on 'Poll devices', Homeseer is suddenty able to communicate with the device.

      If I wait 5 minutes, Homeseer is no longer able to communicate with the devices via the 'Poll device' button. But if I turn the device on or off again, and the select 'Poll devices', Homeseer is again able to communicate with the device.

      And so on...

      Anyone have any ideas what could be causing this?



        Upon rereading your post, I think I missed the fact that you seem to be experiencing exactly the same problem - e.g. Homeseer lost contact with your devices (polling your devices wasn't working), and then, after toggling the device, Homeseer restablished communications (polling was working).

        Am I reading this right?

        If so, I understand one solution is to toggle frequently - but I didn't need to do that for the past year. Now, HS seems to have lost contact with its devices.

        Any ideas how to give HS back it's contact?


          My experience was polling with script commands, but yes, it sounds like the same issue. It wasn't that HS was suddenly able to communicate just by toggling the switch, but that HS reported a false result if you check it right after toggling the switch. I believe it is caused by polling while HS is waiting for a response from a device, and it doesn't really know if it's on or off, so it reports the last command HS gave the device.

          I tried to do more testing tonight with the "Poll Devices" button, but I'm using the new (Alpha version) ISY plugin, and polling just says that it's status is "Polling".


            Thanks for the clarification. Sounds like our problems are a little different.

            I'm using polling through the button on the screen, not through scripts, and my problem specifically is that Homeseer is unable to see the device at all, and then, after toggling, IS suddenly able to see the device.

            I don't ever have a situation where polling is not reporting the correct status of a device - either HS is unable to find the device through polling, or it can find the device and reports its status correctly.

            Does anyone have any idea why this would be occuring? Thanks.


              Problem resolved

              Well, I should have tried the obvious solution earlier - I downloaded the newest version of the PLM plugin, installed it, and the problem went away.

              CJVann, thanks for your comments.