Announcement

Collapse
No announcement yet.

Strange Entries in Log - System Stability Issues - Fixed!

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Yes I have had very odd behaviour with things plugged into UPS's before, I plugged in a standard 40w light bulb in mine (can't remember why)...my entire X10 network got wiped out. It was a real puzzle, I was restarting the PC, HS the CM11A and then had to go round and unplug everything until I got back in the circle and found the lightbulb, if I moved it to another non UPS socket it was fine...no idea why.

    Comment


      #17
      J Status Reqeust

      I just started having the same issue. Every second I'm getting a log entry that says "J Status Request". I have not made any changes to the system in awhile.

      Comment


        #18
        Originally posted by t-mclane View Post
        I just started having the same issue. Every second I'm getting a log entry that says "J Status Request". I have not made any changes to the system in awhile.
        Do you have a RCS X10 thermostat? If not it's more than likely X10 noise.
        -Rupp
        sigpic

        Comment


          #19
          Noise Update... but now no X-10 signal on PLC

          Well I thought I'd update the board on findings so far.. I actually thought I had solved the problem when my son went back to college after Christmas break.. He always brings home his desktop and the day after he left, things seemed to instantaneously return to "normal".. no noise, no weird X-10 addresses/commands in the logs, etc..

          That happiness lasted a few days, then one leg of my electric service died.. Pretty weird as half of the things in the house quit working (the ones on that phase leg).. It took the power company a few days to fix, though they set up a temporary transformer at my meter to restore service to the faulty leg. Turned out to be one of the power lines (underground) had been partially severed by a rock, or something.. I had asked the repair guys about whether that failure might have been accompanied ahead of time by noise on the line and the answer was "possibly".. no way to know really - when it failed, it was sudden.. no dimming, etc.

          That behind me, I was hopeful that things would return to normal, which was not to be. The HS network seems to be operating properly, based on the log messages, and most days, things "generally" come on and off as programmed. I am NOT seeing the funky phantom X-10 codes in the logs like I had seen earlier though..

          However today, as I am writing this, it appears that there is NO X-10 signal evident on my X-10 Signal Meter, whether from a manual command through the HS status page or from an HR12A remote. The odd thing is that all programming executed properly until about 830 this morning.. after that the system became unresponsive, although the HS software is showing the states that it thinks are correct.. Lights that were to turn on or off after ~830 did not execute, though the software had commanded them properly. The only device that I can reliably cycle is the one plugged into the RR501 Transceiver module, which is plugged into the HD-11A (Home Director version) Serial interface.

          Restarting HS, and even re-booting the Computer has no effect. Un-plugging the serial interface or changing batteries in the transceiver has no effect. It is like there is a total "dampening" of the X-10 signal someplace.. Why it seems to "self-recover" at times is a mystery as I cannot correlate it with any other devices that might be put on or off of the electric circuit.

          I have a phase coupler/amplifier/repeater between phases, but it shows no errors that I have seen.

          I am just at a dead end with this one.. I suspect it is noise or device related, but again, since it seems to cure itself for sometimes days at a time, I cant think of where the problem might be.. or where to start to find it. This system has worked for years reliably (95%), but has just gone to crap in the last couple of months...

          If anyone has any ideas of the process to narrow this puzzle down, I would appreciate it..

          Comment


            #20
            More clues.. Filter Issues...progress?

            Reluctant to give up after posting my last message, I decided to start moving around the house with the X-10 signal meter to try to find the problem source.. to my surprise, I discovered that part (all) of the problem might be coming from my Toshiba laptop (Satellite U400)... not a new machine but the outlet where I normally charge it has always been a noise problem (even from before this laptop, on a Dell model). So I always use a Smarthome FilterLinc Model 1626-10, which has been in service for several years, at this outlet.

            I discovered that when I took the FilterLinc out of the circuit and plugged in the Laptop directly, my Housecode "A" signal strength appeared on the meter barely (had been zero). I also noted that while good enough to cycle a light on the network, it was weaker than the transmissions on the HouseCode "B" network.. not sure why they would be different unless a function of the laptop charger (Toshiba PA-3468U).

            It would appear (at this point) that the FilterLinc was defective (!??!). I then unplugged the laptop altogether and the Housecode "A" signal strength improved from 0.1 volt to 2.5 volts (!!).

            So eliminating this device (and the laptop) seems to be the solution.. (crossing my fingers)... I would not have guessed that the Filter would go bad.. and based on the behavior I have seen, apparently it has been intermittently failing for some time. Since the system sort of worked sometimes and then not, though the laptop was plugged in all the time. (could the laptop charging cycle change the noise level on the circuit? assume so...) Has anyone else seen this kind of issue with a line filter???

            This is the second failure I have seen from a SmartHome device. Late last year, one of their Insteon ApplianceLinc modules controlling a 40 watt aquarium florescent light actually MELTED a dime-size hole through its plastic case next to the wall (not good). Fortunately it didn't start a fire.

            Will continue to monitor the situation and report back if the system behaves (or not).. In the interim, does anyone have a recommendation for a better filter type???

            Thanks for everyone's inputs so far.. it has been a "teachable moment" as they say..

            Comment


              #21
              So far I have been using some X10 Pro filters I got off Ebay and they seem to be working ok...Knock-on-wood.

              Course you never know about electrical devices.

              We had several quick electrical spikes/surges a couple of weeks ago and when we did a load check on the generator last week it wasn't feeding anything into the house. Evidently the quick surges had popped the 70amp breaker at the house from the generator. Reset it and all was fine but you just never know.

              Hope it keeps working fine for you.

              Comment


                #22
                Problem Solved..

                I thought I should update the thread on what I have found, and what I learned. To no surprise for those X-10 "veterans" out there.. in the end, the performance/reliability issues with X-10 devices appeared to be caused by a number of devices in the house... a few new ones, but surprisingly, a lot of devices that were not new or recently installed. This was puzzling as the system had run at a "reasonably" reliable level for long periods over the past few years.

                By using my X-10 signal strength meter, I was able to identify a number of "culprits"... The new devices that were sucking X-10 signals turned out to be my son's Dell laptop (new) and a number of low voltage lights - all the under-cabinet lights in the kitchen (not new), and about four (of 12) fluorescent fixtures in the basement (not new). Each of these devices could drastically reduce or eliminate totally the X-10 signal on the home power network.

                I resolved these issues by putting an X-10 Pro XPPF filter module in front of each device or circuit. That completely resolved the problems I had seen. It is unclear to me why lights that had not seemed to be a problem before were now an issue, but it is what it is. I would have expected the "signal-sucking" behavior of selected devices to be a constant, related to the design of the power supply, but maybe not....?

                The X-10 network has been 100% reliable in the last 4 weeks after making these changes. Nor have I seen the weird X-10 commands for non existent X-10 nodes show up in my logs. Not sure if that was related to the issue described above, but maybe something external like the power transformer phase failure.. but anyway, they are gone too.

                Hopefully this will help others that have seen reliability issues on their control network.

                Comment


                  #23
                  I am sure glad you got it working and thanks for the updateand suggestions for everyone.

                  It is funny how it just kind of degrades for no apparent reason. That is what happened to mine before adding the filters to bring it back up to a good system.

                  Comment


                    #24
                    Something to think about...

                    About 6 years ago or so when I still lived in California and entirely X10, I had a noise problem that would happen the same time every single night and I narrowed it down to my next door neighbor's landscape lights. If any of your neighbors that share the secondary of the power transformer have a really noisy device it can and will carry over to your house. Needless to say I had no problem replacing his low voltage transformer (at my cost) to solve the noise issue. I don't remember if it was leviton or ACT made (makes) a device that goes in your main panel that suppresses noise in the x10 range from coming into your house.

                    Another one that was hard to find was I had a small warm water aquarium with a 20 watt heater, when that heater came on, the x10 died
                    Over The Hill
                    What Hill?
                    Where?
                    When?
                    I Don't Remember Any Hill

                    Virtualized Server 2k3 Ent X86 Guest on VMWare ESXi 4.1 with 3 SunRay thin clients as access points - HSPro 2.4.0.48 - ZTroller - ACRF2 (3 WGL 800's) - iAutomate RFID - Ledam - MLHSPlugin - Ultra1wire - RainRelay8 - TI103 - Ultramon - WAF-AB8SS - jvESS (11 zones) - Bitwise Controls BC4 - with 745 Total Devices - 550 Events - 104 scripts - 78 ZWave devices - 42 X10 devices - 76 DS10a's 3 RFXSenors and 32 Motion Sensors

                    Comment


                      #25
                      Glad you got it working. I wish I had been following this post closer, have been pretty busy lately with things other than home automation.

                      I have a few X-10 devices and have also had trouble with laptops in the past, although I have not had as many mysterious problems as you, possibly because I don't have as much X-10. I bet having the signal strength meter is helpful, my efforts were mostly trial and error.

                      Thanks for sharing your X-10 experiences, it will probably be of a lot of help to others.

                      Comment


                        #26
                        Thanks for everyone's input..

                        Jackpod and BDHall - Thanks for your comments. Yes, the little X-10 signal strength meter was perfect for this investigation. That coupled with my hand held HR12A remote enabled me to go around the house, plug into wall outlets everywhere and send an X-10 signal while I watched for the signal level on the meter. Was actually pretty fast, and when I found a problem, unplugging various devices until I got a good signal was easy. Adding filters on all the problem circuits was easy as well (I found some filters on eBAY for $5 ea, and some larger 20A filters for about $20).

                        I had not thought about checking the aquarium heaters ( I have two in the house), so that's a good tip to check also...

                        I am thinking that some of the spurious "Phantom" X-10 commands in the log were signs of the impending phase failure on the transformer feed to my house - cant be sure though. All the "Noise" problems I found were not actually noise but rather they were X-10 "signal suckers" - they just completely killed the X-10 signal for certain areas and sometimes the whole house, depending on the device.

                        Thanks for all the inputs everyone has had on this - now I need to work on my Z-wave network, which seems to have some communication "issues"....

                        Comment

                        Working...
                        X