No announcement yet.

My Experience with GC WF2CC

  • Filter
  • Time
  • Show
Clear All
new posts

    My Experience with GC WF2CC

    As promised I will discuss my experience in automating the open/close of my garage door. At first I was going to use the ZRF113 device, but Mark from HS said it is being redesigned with no ETA on restock so he recommended the Global Cache WF2CC which is a wifi device to contact closure. I ordered it and it arrived on Tuesday.

    The first step was getting the wf2cc box to talk to my wifi router/ap and boy was that a pain in the arse. I tried 4 different routers/aps and it would not connect. I tried all combinations of security (wep, wpa, no security, etc.) and still no luck. After 4 hours of this nonsense, I called it a day and went home. That night I sent an email to Global Cache and he said that I needed to make sure that my SSID was not hidden. Well of course my SSID is hidden, so the next day I allowed it to be broadcast and voila it connected. Could have saved 4 hours if Global Cache would have just PUT THAT IN THE MANUAL!

    Now that it was on my network, I installed the latest version of the Global Cache plug-in and as soon as it finished installing, I had 3 new devices (Relay 1,1 , Relay 1,2 , Relay 1,3). I clicked on Relay 1,1 to see what configuration was available since that is the relay I was going to use to open/close the garage door and there were four options to select from:

    Digital Input, Analog Input, Digital Output, and Interface Variable

    I had no idea which on to select, but it seemed logical to select Analog Input since I will be dealing with electricy. Saved the setting and set out to wire the wf2cc box to my garage door unit. I read over the garge door instructions and located the correct terminals that open/close the garage via the button on the wall. Wired the wf2cc to the garage door unit in parallel and tested out my handy work. Guess what, nothing. I tried all relay's on the wf2cc box, but nothing worked. I just kept getting the same error over and over again after every change. By this time it was time to go home again.

    Next day, I tried it again with fresh eyes but it did the same thing. So I called HS and spoke to Rich about my error. He said to close HS and open it again as that is when HS "talks" to the wf2cc. Once it restarted, I tried again but still no luck. So right after I got off the phone with Rich, I tried it again and it WORKED! What I found, was that if the Relay state was CLOSED, I had to change the state to OPEN and the change the state to CLOSED again before the door would OPEN or CLOSE. Well that makes sense now that I thought about it so I called Rich back and told him what I found. Also, Rich told me that the four options in the relay device are meaningless for the wf2cc box. I verified this by choosing each one, saving config, and testing the open/close of the garage door and the door opened/closed everytime.

    Hope this helps someone get the wf2cc running in 15 minutes instead of 8-10 hours

    Thanks for posting your experience. I have been thinking of getting some of these to replace some ZRF113's. E.g;

    My whole house fan has a high and low setting triggered by making two different connections. Currently I only have a ZRF hooked to low, and have not seen fit to add a second ZRF for the high setting. With the WF2CC I can use one unit and cover both switches.

    My gate opener is operated by HS using a ZRF, but the distance frequently causes it to be dropped from the z-wave network if the antenna moves or it's A full moon or whatever other vagaries. I know that my WiFi signal historically has been strong there, so perhaps I can have a more robust wireless solution for the gate.

    The one other thing that is convenient about these is you don't have to hardwire to 120V with naked wires. You just plug in the wall wart.

    Let us know how stable the WiFi connection is, as I don't look forward to going into the attic to power cycle the device when it loses connection.

    Thanks again,


      Vector - please wait before you proceed. Seems there might be a problem with the plugin and Rich is working on a fix. The wf2cc works perfectly right after a restart of HS. However, over time (couple hours or so) it stops working and throws errors in the HS log. The fix is slow going b/c Rich doesn't have any on hand so he is sending test fixes to me for testing and so forth. He should have some end of next week so the fix is probably very close.

      As far a wifi connection, my wf2cc is fairly close to my ap so I haven't had any drops. To make sure, I am running a ping to a log file and I have yet to see any drops.


        Rich fixed the plugin issue. It is working everytime I manually trigger no matter the time between triggering.


          Originally posted by nugentgl View Post
          I installed the latest version of the Global Cache plug-in
          Is this the PI-GC100 - Global Cache GC-100 or PI-GCIR - Global Cache IR Reciever Plug-in ? I thought those were for IR communication. Or is there another Global Cache plugin that I am not seeing?

          Ok I did some digging and it would seem that this does use the GC-100 plugin for anyone who didn't know. (Guess if I hadn't been so tired last night I would have found that)
          Last edited by Mikhael; September 19, 2010, 11:36 AM. Reason: Found more info


            This works for IP2CC too!


            Thanks so much for this post. It seems there is absolutely nothing anywhere about getting this working. I have an IP2CC-P which is wired ethernet, so the networking was the easy part for me. I seemed to have an issue getting the plugin to talk to the ip2cc, and the restart did the trick.