Announcement

Collapse
No announcement yet.

Trane Z-Wave Thermostat Control?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    Originally posted by travis010 View Post
    How do you send the "on" and "off" command to the thermostat in an event? The thermostats don't show up as devices when I try a Device Action and there is no "on/off" option when I select ZWave Thermostats Actions. I'm trying to get the thermostats to enter ESM when I put the house into "Away" mode via a virtual device. Any help would be appreciated.

    I accomplish the switch from Run/Hold to ESM by running an immediate script when my virtual device changes to Unoccupied status. The script is "&hs.ExecX10("H99", "Off")" where H99 is the device code for the thermostat. Use "On" if you want to switch it from ESM to Run/Hold.

    To make it easy to switch from the Status Web Page, I added two buttons to switch the device. I manually executed the following script for each of my Thermostats to add the buttons:

    PHP Code:

    Extract of thermostats
    .vb --> see attachment

        
    Public Sub ThermostatSetupDevice(ByVal Parms As Object)
            
    'Private Sub ThermostatSetupDevice(ByVal Parms As Object)
            ' 
    ============================================================================
            
    '
            ' 
    ThermostatSetupDevice
            
    '
            ' 
    Go through devices for specified Home Code and apply special attributes:
            
    '       - Device Buttons on Status Page
            '       
    Device Values
            
    '
            ' 
    Parameter:
            
    '      Device:  HS Device (e.g. s01)
            ' 
    ============================================================================
            
    Dim theDevice As String
            Dim dv 
    As Object
            Dim dvRef 
    As Integer
            Dim ScriptCommand 
    As String

            theDevice 
    Parms.ToString

            
    ' Set Message Buttons 
            '
            '- Special Chars: 
            '       
    CHR(1seperates each button     
            
    '       CHR(2) seperates ref and name values
            '       
    CHR(4in the button name creates a new line after that button
            
    '
            '       
    Samplehs.DeviceButtonAdd("z1""speak_script.txt(""speak"",""hello"")""Speak Now")

            
    ' Remove old values
            hs.DeviceButtonRemove(theDevice, HS_DEV_STATUS_RUN_HOLD)
            hs.DeviceButtonRemove(theDevice, HS_DEV_STATUS_AWAY)

            ' 
    Add in New Values
            ScriptCommand 
    "&hs.ExecX10(""" theDevice """,""On"")"
            
    hs.DeviceButtonAdd(theDeviceScriptCommandHS_DEV_STATUS_RUN_HOLD Chr(4))

            
    ScriptCommand "&hs.ExecX10(""" theDevice """,""Off"")"
            
    hs.DeviceButtonAdd(theDeviceScriptCommandHS_DEV_STATUS_AWAY)

            
    ' Set Device Value to IOTYPE_CONTROL so default buttons don't show
            dvRef 
    hs.GetDeviceRef(theDevice)
            If 
    dvRef 0 Then
                dv 
    hs.GetDeviceByRef(dvRef)
            Else
                
    'LogIt("Error - Could not find the reference for the device specified.")
                Exit Sub
            End If
            dv.iotype = IOTYPE_CONTROL


        End Sub 

    This approach is subpar because the device code is hard-coded in the script. You could also use BLStat.


    Prior to 2.5.0.1 the thermostats appeared in the device drop down of On/Off commands so you didn't have to go through these gyrations. I'm hopeful a) the RUN/Hold <=> ESM operation will be a standard Thermostat function; or b) the Thermostats device will allow ON/OFF commands, or c) the Device Commands will show the thermostat devices so the On/Off can be done via a Device Command. [I'd really like to be able to have the Thermostat plugin be able to download the Schedule for centralized control with Distributed operation.]
    Attached Files
    Last edited by RBergquist; February 27, 2011, 01:04 AM. Reason: added attachment

    Comment


      #17
      Originally posted by Vector View Post

      Note - Trane Z-wave Thermostat = Slightly crippled RCS TZ43.

      Regards,
      Vector
      I just came across this thread as I am investigating getting a new t-stat. What do you mean by the Note above?

      Thank you.

      Comment


        #18
        Originally posted by sonypoolplr View Post
        I just came across this thread as I am investigating getting a new t-stat. What do you mean by the Note above?

        Thank you.
        It's missing a couple of hardly used options like remote temp sensor.
        -Rupp
        sigpic

        Comment


          #19
          I see thank you.

          Comment


            #20
            I have had 2 of these tstats in for a month or so and they have been awesome so far. I have used them with both the built in z-wave stat plugin and blstat and either way is a win.

            Just my 2 cents.

            Comment


              #21
              Why would someone use one of these and not the 2GIG ZStat, which is cheaper (I think?) and seems to have no limitations?

              Comment


                #22
                Originally posted by Otis View Post
                Why would someone use one of these and not the 2GIG ZStat, which is cheaper (I think?) and seems to have no limitations?
                It's just a matter of preference and the Tranes build quality is a bit better. Plus many bought these when they were being cleared out at retail stores for a good price.
                -Rupp
                sigpic

                Comment


                  #23
                  Originally posted by travis010 View Post
                  How do you send the "on" and "off" command to the thermostat in an event? The thermostats don't show up as devices when I try a Device Action and there is no "on/off" option when I select ZWave Thermostats Actions. I'm trying to get the thermostats to enter ESM when I put the house into "Away" mode via a virtual device. Any help would be appreciated.
                  I setup an event "Heating OFF":

                  <TABLE cellSpacing=1 cellPadding=0 width="100%" border=0><TBODY><TR><FORM name=chkOPForm6522 method=post><TD class=tablerowodd noWrap align=middle><INPUT class=formcheckbox type=checkbox value=6522 name=chkOP6522> <INPUT class=graphicbutton type=image alt="Run Heating OFF , Last ran: Unknown" src="http://localhost:81/images/HomeSeer/button_run.gif" value=Run name=""> <INPUT type=hidden value=6522 name=bookmark><INPUT type=hidden value=evls name=ref_page><INPUT type=hidden value="Heating OFF " name=run_event></TD></FORM><TD class=tablerowodd>Heating OFF </TD><TD class=tablerowodd><TABLE cellSpacing=0 cellPadding=0 width="100%" border=0><TBODY><TR><TD class=tablecelltrigger>Manual Only</TD></TR><TR><TD class=tablecelldays>Last ran: Unknown</TD></TR></TBODY></TABLE></TD><TD class=tablerowodd noWrap align=left><TABLE cellSpacing=0 cellPadding=0 width="100%" border=0><TBODY><TR><TD noWrap align=left width=160> </TD></TR></TBODY></TABLE><TABLE cellSpacing=0 cellPadding=0 width="100%" border=0><TBODY><TR><TD class=tablecellzwave_thermostats noWrap align=right width=160> ZWave Thermostats: </TD><TD class=tablecellzwave_thermostats align=left colSpan=8>Z-Wave Thermostat 4:
                  Set Mode: Off</TD></TR></TBODY></TABLE></TD></TR></TBODY></TABLE>
                  Be sure to click the "check settings" box, this is where "OFF" is selected.

                  Steve Q
                  HomeSeer Version: HS3 Pro Edition 3.0.0.368, Operating System: Microsoft Windows 10 - Home, Number of Devices: 373, Number of Events: 666, Enabled Plug-Ins
                  2.0.83.0: BLRF, 2.0.10.0: BLUSBUIRT, 3.0.0.75: HSTouch Server, 3.0.0.58: mcsXap, 3.0.0.11: NetCAM, 3.0.0.36: X10, 3.0.1.25: Z-Wave,Alexa,HomeKit

                  Comment


                    #24
                    I bought mine at Radio Shack a couple of months ago when they were on clearance and got 2 of them for 40 bucks a piece, not much better value than that out there!

                    Comment


                      #25
                      I believe the 2GIG thermostats will not run the program mode when connected to Z-wave. RCS & Trane do so I chose these -- this fits with my philosophy of depending on the thermostat and not a PC to maintain the temperature (PCs fail more often than thermostats in remote environments.)

                      Comment

                      Working...
                      X