No announcement yet.

Z-Stick II and Schlage

  • Filter
  • Time
  • Show
Clear All
new posts

    Z-Stick II and Schlage

    OK, I have searched the forums and read about many issues with the Schlage locks but nothing seems to cover my experience so I am hoping someone has seen this issue and solved it.

    I am using the Aeon Labs Z-Stick II runing Firmware version 3.7 and PC Controller library v 2.78 (ZDK V 5.02 Patch 3)

    I am also using HS

    My problem is that I cannot get the Z-Stick to recognize the Schlage Lever Lock or the Lamp Module. Here is what I do for the lamp module

    1. Remove the Z-Stick II from my system and place it next to the lamp module (plugged in)
    2. Press the button on the Z-Stick II and the blue light will blink slow
    3. Press the enroll button twice on the Lamp module
    At this point I should see the blue light on the Z-Stick II blink quickly for a second and then go back to slow blink. What actually happens is that the Z-Stick II continues to blink slowly and if take it back to the system and try to import the Lamp module is not in the Z-Stick II.

    The same thing happens with the lever lock, the Z-Stick acts like nothing has happened.

    While the Z-Stick II is new, I purchased the Schlage Lock and Lamp controller a year ago and not from HomeSeer based on the very public Z-Wave message that ALL Z-wave devices were compatible. I am now concerned that my older Schlage Lever Lock and Lamp module are not compatible with current Z-Wave technology.

    BTW, I had no problems with enrolling the Schlage Lever Lock and Lamp Module to the Bridge that came with the system and currently I can control the lock and lamp module using Schlage-Link. I want to get away from the monthly charge though.

    Q1: Is there a way to find out the Firmware version of the Schlage Lever Lock and the Lamp module?
    Q2: Is there a known issue with older Locks and lamp modules?
    Q3: Has anyone else had this problem and what did you do to resolve it?

    Any help or suggestions would be greatly appreciated !


    You need to update to the latest release version of HomeSeer to work with any Z-Wave locks. The latest version is available here:


      While it is always a good idea to update to the latest release the version that you are running will work. Have you tried deleting the lamp module from the Z-Stick and then adding again. Two questions for the Lock - Did you try deleting fron the network before adding it ? How far away is the lock from the system? The lock don't stay awake along time I have found - 2 ways to handle this if you can bring your system closer to the lock or bring the lock closer to the system - on the second get it included in the system and then mount it in the door


        Because I am using the Z-Stick II, I can remove the ZStick from my system and take it to the door with the Schlage Lever Lock. When I try to add it, the Z-Stick is only a few inches away. I have not tried to delete it from the existing network run by the Schlage Bridge. I guess that will be my next step. Reset the Lock. I will try this in the next couple of days and see if it helps.


          ZStick II Schlage

          Has anyone been able to get this too work. I recently purchased homeseer, zstick II and the schlage lock. I have followed the directions but I can not get the z-stick II to recognize the locks.

          Do I need to update the firmware for zstick-II first? How can I tell the firmware version?

          Help is appreciated.


            Did you try deleting the lock before adding it? Can you attach the logs from when you tried adding the lock. Did you try rescanning the lock? Logs would definitely help troubleshoot.


              I have a Aeon Zstick II and two Schlage locks and can assure you everything works fine.

              To add the Schlage lamp module-- like someone said you may need to "remove" it first. Sometimes at the factory they test the until and add it to a network. It needs to be told to be removed from a network-- so hold that button down and wait to the fast blinks-- then hit the button on the schlage lamp module. (note it needs to be plugged in). Then you can readd it.

              To add the door lock-- it is more a pain in the a**. You will need to plug in the Aeon smart stick into Homeseer-- and then physically bring the lock next to it. This probably requires removing the lock-- or maybe you can move the computer near the lock-- whatever is easier.

              You then go to the setup/mange zwave window and hit the add devices button and then hit the program button on the lock. The locks are secure devices-- so a lot of data needs to be transfered between Homeseer and the lock. Once you do this-- reinstall the lock and optimize it several times. Be sure the beaming modules are close by.
              HS3 Pro Edition (Windows Server 8.1 on ESXi box)

              Plug-Ins Enabled:
              weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:


                Thanks for the replies I will try again when I get home. Which logs would be useful?

                I have not gone through any of the schlage procedures to setup the locks.

                I am not using the schlage bridge and I was not planning to use the lamp module.

                I tried adding the having the z-stick connected to homeseer, interfaces -> manage -> add device. On the schlage I entered the programming code, then the schlage button, then the 0 key. The schlage button on the lock blinks for a while looking like it is trying to do something, but I have not indication that the z-stick has received anything.


                  If the Z stick is within a short distance of the Zstick-- then the lamp module won't be needed- but a beaming supporting lamp module will need to be nearby otherwise.

                  I believe it does take some time to sync up-- how long did you give it?

                  What version of HS are you running?

                  How far away is the lock from the Zstick when you are attempting to sync it? It needs to be close-- like a foot or so.
                  HS3 Pro Edition (Windows Server 8.1 on ESXi box)

                  Plug-Ins Enabled:
                  weatherXML:,JowiHue:,APCUPSD:,PHLocation:,Chromecast:,EasyTr igger:


                    I will experiment again tonight and get more answers to your questions.

                    It was about a foot away from the lock.

                    I gave it until the led on the schlage button stopped blinking.

                    I will check the version of HS, but I downloaded it in April, so it should be pretty recent.

                    If I use the lamp module are there additional steps I need to go through. Do I need to first add it and then remove it, or can I just remove it as you describe above?
                    Last edited by iporty; June 6, 2011, 07:37 PM. Reason: revise


                      I think the Schlage locks (to Rupp's point) were not fully added until later versions of HS. Maybe or so.

                      So, I'd suggest the same as Rupp. Backup your, update to and see if you can communicate. If not, delete your 2.5 directory and replace with the backup.

                      Tasker, to a person who does like walking up to a Crack Treatment facility with a truck full of 3lb bags of crack. Then for each person that walks in and out smack them in the face with an open bag.


                        Thanks for all of the help.

                        I found the problem. I did not originally install the locks. I was having a remodel done and the contractor installed the locks for me. When he installed the locks he installed the 9v battery, but not the AA batteries. After installing the AA batteries it worked. (Doh!) It's strange that their is no change to the interface when the AA batteries are missing (i.e. programming works, the lights blink at the same time, etc.)
                        Last edited by iporty; June 7, 2011, 04:27 PM.