Announcement

Collapse
No announcement yet.

How do I keep my sound card from going to sleep?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    How do I keep my sound card from going to sleep?

    I upgraded my HomeSeer machine not too long ago. After some fight with various things, I have everything working (except my NetCallerID).

    However, in spite of the fact that I have set Windows to NOT go to sleep or hibernate or spin down the hard disks or anything, the sound card shuts down after some period of time. When I touch the keyboard or move the mouse, the sound comes back immediately, like I'm waking the system up, but it's not supposed to be asleep. The system is not fully asleep, because it will respond to me logging in to the webserver, via remote control software, etc. The sound card is actually on the motherboard (VIA HD Audio on an ASUS M4N68T-M-V2) and I'm using Windows XP SP3. I have looked in device manager for power settings related to the sound card, but can find nothing relevant. Incidentally--or maybe not--the screen also gets blanked after (probably) the same period. Again, I have set Windows to "Never" under all categories related to power and even turned off the screen saver.

    P.S. I'm sure someone has encountered this before, but I could not figure out a way to effectively search for such a topic. Part of the problem seems to be that I can't figure out how to do "and" searches--everything I try ends up searching for all words used rather than an exact match, even when I use quotes around a string.

    Thanks.

    #2
    Just a thought, but have you checked for any Power Management options in the bios?
    Mike

    Comment


      #3
      Originally posted by ToinkyRoo View Post
      P.S. I'm sure someone has encountered this before, but I could not figure out a way to effectively search for such a topic. Part of the problem seems to be that I can't figure out how to do "and" searches--everything I try ends up searching for all words used rather than an exact match, even when I use quotes around a string.

      Thanks.
      Searching on the board is an exercise in futility. You're better off using google to search the board. In the google search box type:

      site:board.homeseer.com my text to search

      Hope this helps...
      HS4Pro Running on a Raspberry Pi4
      68 Z-Wave Nodes, 175 Events, 359 Devices
      UPB modules via OMNI plugin/panel
      Plugins: Z-Wave, OMNI, HSTouch, weatherXML, EasyTrigger
      HSTouch Clients: 3 Android, 1 Joggler

      Comment


        #4
        Sounds like your USB is going to sleep. In Windows, this power down is separate from the "HD/system" sleep. So, disabling one, does not prohibit the other.

        TO disable the USB sleep, you need to go to the USB hub in Device manager. Then turn off power management in there for the USB hub (which then does not put the USB devices to sleep).

        --Dan
        Tasker, to a person who does Homeautomation...is like walking up to a Crack Treatment facility with a truck full of 3lb bags of crack. Then for each person that walks in and out smack them in the face with an open bag.

        Comment


          #5
          If Dan's instructions are a bit terse, see this from the How To's section:
          http://board.homeseer.com/showthread...757#post963757
          Mike____________________________________________________________ __________________
          HS3 Pro Edition 3.0.0.548, NUC i3

          HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

          Comment


            #6
            Thanks UM, I didn't want to go into a LOT of detail until I knew I needed to!



            --Dan
            Tasker, to a person who does Homeautomation...is like walking up to a Crack Treatment facility with a truck full of 3lb bags of crack. Then for each person that walks in and out smack them in the face with an open bag.

            Comment


              #7
              Thank you for the input. I should have provided more information in my original post about what I have tried.

              1. I had already set ALL USBs to not be powered managed. (I learned that "trick" a long time back when I was a different problem.) However, since the sound card is on the motherboard I would think it should really have nothing to do with USB, right?

              2. I had also tried fiddling with the BIOS, but didn't see any setting that seemed like they would be applicable. I did try to turn all power management off via the BIOS. (I've forgotten the exact setting, but something like turning off ACPI.) All that did was hang the machine on windows's attempt to start. Had to change it back. I will look at the specific options in the BIOS and post what I see in case any one can see a setting that could fix the problem.

              Also, I'm still struck by the fact that screen blanks even though I tell windows not to. Something else is messing with the monitor and sound circuitry.

              Oh, and thanks for the tip on searching the board.

              Comment


                #8
                I got it figured out

                As I was making my last post I realized that there had to be some other program shutting my peripherals down. I started looking at resident programs and found the ASUS system utility that controls processor power conservation, etc. It had an option to turn off the monitor. It said nothing about other things, but when I set that to never, viola'.

                Comment


                  #9
                  Originally posted by ToinkyRoo View Post
                  . . . the ASUS system utility that controls processor power conservation . . . had an option to turn off the monitor. It said nothing about other things, but when I set that to never, viola'.
                  Good detective work! Sounds like a bug in the software to me.
                  Which model are you using? I want to be sure to avoid it.
                  I'm running HS on an Eee Box. I turn off the monitor automatically too, but haven't had the sound card follow, thank goodness.
                  Mike____________________________________________________________ __________________
                  HS3 Pro Edition 3.0.0.548, NUC i3

                  HW: Stargate | NX8e | CAV6.6 | Squeezebox | PCS | WGL 800RF | RFXCOM | Vantage Pro | Green-Eye | Edgeport/8 | Way2Call | Ecobee3 | EtherRain | Ubiquiti

                  Comment

                  Working...
                  X