Announcement

Collapse
No announcement yet.

Power lost - the best way to restart HS

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Power lost - the best way to restart HS

    Hi,
    I have an ups connected to HS and we do not lose too many times the electricity but what is the best way to restart HS. In the past I used HS service but I had several issues with the plugins using this method and few people suggested not to use it.

    Thanks,
    Aldo

    #2
    I don't do anything with the UPS's connected. I have the Homeseer server just coming back if it loses power; but most of the time the power loss is only a few minutes and the UPS keeps it running just fine. Any wired HA stuff away from the server rack though gets hit with the power failure and it generates a few log entries and it starts up again once the power is restored. The HS DB has remained intact; with just a log entry stating it was shut down unexpectedly. Most recently I have installed an automotive power supply in the new Homeseer server. The PS has a wide range and it has a separate circuit for charging the 12V battery and will run off a 12V battery.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
    HS4 Pro - V4.1.11.0 - Ubuntu 20.01/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono
    6.10.0.104
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    Comment


      #3
      I may have posted this recently, if not i've got a sense of deja vu but to restart HS all I do is chuck a shortcut in the windows startup directory. I only have one additional program I launch (Cumulus Weather, hopefully i'll finish a plugin for the weather station soon so I don't need any other programs apart from HS) and that can be launched after HS if needed or I just live without it. If you need windows to load completely (or additional programs to run first) then launch HS then i'm not sure if AutoIt or something may be able to help to launch HS with a delay (or a batch file??). But thats all I do and it works.

      Comment


        #4
        Perhaps I'm missing something really basic. When the computer starts from a power failure, it goes to a login screen. I assumed that the windows startup directory runs all the applications in that "folder" only after you login, what am i missing?

        Thanks,
        Aldo

        Comment


          #5
          Originally posted by aldo View Post
          Perhaps I'm missing something really basic. When the computer starts from a power failure, it goes to a login screen. I assumed that the windows startup directory runs all the applications in that "folder" only after you login, what am i missing?

          Thanks,
          Aldo
          ah right, first thing I do when I install windows is disable that screen, what version of windows you on? If your on XP download tweakui.exe and somewhere there is an option to auto logon as a specified user, thats what I do and it boots straight into the desktop.

          Comment


            #6
            I too disable the login screen with W2003 and put HSPro in the start up for all users.

            If you do run cmd
            rundll32 netplwiz.dll,UsersRunDll
            highlight the user name you want auto logging in; uncheck the box at the top; it'll automatically go to that user when you reboot.
            - Pete

            Auto mator
            Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
            Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
            HS4 Pro - V4.1.11.0 - Ubuntu 20.01/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono
            6.10.0.104
            HS4 Lite -

            X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

            Comment


              #7
              I'm running XP. Thank you both for your tips and answers.

              Thanks,
              Aldo

              Comment


                #8
                http://board.homeseer.com/showpost.p...10&postcount=9
                Jon

                Comment

                Working...
                X