Announcement

Collapse
No announcement yet.

URL Control parameters for the new Foscam FI9821W

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • URL Control parameters for the new Foscam FI9821W

    Any of you guys using one of the new Foscam FI9821W cameras? I'm setting one up for a friend and can't get any of the URL parameters that work on the older cameras to work with this one. I tried the most popular:
    http://ipaddressort/snapshot.cgi?user=admin&pwd=pass changing the parts of the url to the correct values and I get nothing.
    -Rupp
    sigpic

  • #2
    I use the streaming URL and its working fine for me.

    /videostream.cgi?user=USERNAME&pwd=PASSWORD&resolution=640X48 0
    I have the Foscam JPG URL somewhere as I use it too...will find it.

    The Foscam also goes to the ZM box where Homeseer grabs a generic JPG utilizing a generic HTML which is totally different than the Foscam JPG HTML.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU - Mono 6.4X
    Homeseer Zee2 (Lite) - 3.0.0.534 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.4X

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation.

    Comment


    • #3
      Yea, that's not working either. I'm guessing that this isn't going to work with this new camera as it a new megapixel camera that supports H.264 video compression and so these older commands seem not to work. I'll post on the Foscam forum but there are others already reporting issues with the older commands.
      -Rupp
      sigpic

      Comment


      • #4
        Hello Rupp. I believe the information you are looking for is here: http://foscam.us/forum/cgi-api-sdk-f...era-t2986.html

        Regards,
        Ultrajones
        Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

        Comment


        • #5
          Originally posted by Ultrajones View Post
          Hello Rupp. I believe the information you are looking for is here: http://foscam.us/forum/cgi-api-sdk-f...era-t2986.html

          Regards,
          Ultrajones
          Thanks for the links Ultra but I can't get any of these to work. I tried a simple:

          192.168.1.144:88/snapshot.cgi?user=admin&pwd=**** and all I receive back is 404 Not found errors. It seems many others are having this issue on the Foscam message board as well.
          Last edited by Rupp; January 6th, 2013, 06:14 PM.
          -Rupp
          sigpic

          Comment


          • #6
            The URL for the FI9821W snapshot should be: /tmpfs/snap.jpg
            Plug-ins: UltraMon, UltraM1G, UltraCID, Ultra1Wire, UltraLog, UltraWeatherBug, UltraPioneerAVR, UltraGCIR

            Comment


            • #7
              Originally posted by Ultrajones View Post
              The URL for the FI9821W snapshot should be: /tmpfs/snap.jpg
              Thanks again but unfortunately it didn't work. 404 not found. Where did you find this information?
              -Rupp
              sigpic

              Comment


              • #8
                They finally released the SDK. The new command for a snapshot is:
                PHP Code:
                http://xx.xx.xx.xx:port/cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=admin&pwd=xxxx 
                These new cams have a nice picture as well.
                Last edited by Rupp; January 10th, 2013, 07:28 PM.
                -Rupp
                sigpic

                Comment


                • #9
                  This worked for me

                  For some reason the full URL in the last post didn't come through - This worked for me: "http://IPort//cgi-bin/CGIProxy.fcgi?cmd=snapPicture&usr=admin&pwd="

                  Comment


                  • #10
                    When I try to use the command:
                    http://xx.xx.xxx.xx:88/cgi-bin/CGIPr...usr=admin&pwd=
                    The camera moves all the way down. Same if I use moveUp it goes all the way up. I wonder how you move the camera in small increments?
                    -Rupp
                    sigpic

                    Comment


                    • #11
                      Originally posted by Rupp View Post
                      When I try to use the command:
                      http://xx.xx.xxx.xx:88/cgi-bin/CGIPr...usr=admin&pwd=
                      The camera moves all the way down. Same if I use moveUp it goes all the way up. I wonder how you move the camera in small increments?
                      Please see this. You can look at the HTML source code to see how it's done:

                      http://foscam.us/forum/free-generic-...41.html#p20338

                      What you need to do is monitor BOTH mouse down and mouse up events. So that when the mouse button is released. You issue a stop PTZ command.

                      Additionally. You should include touch start and touch end event monitoring ("As the above does"). This is because many devices that have touch screens don't fire mouse events when controls are touched.

                      Don

                      Comment


                      • #12
                        Great to see the link here, it works in a browser but can't get it to work in HStouch.

                        Anybody got it working there? Is there a way to scale down the image so it doesn't slow down too much?
                        Just setting &width=xx doesn't see to do the trick anymore.

                        Comment


                        • #13
                          I've also got the same problem, working fine in a web browser, but not in hstouch. My older camera's work fine, but not the hd ones

                          Comment


                          • #14
                            This link works for me in HStouch:

                            http://192.168.1.204:88/cgi-bin/CGIP...dmin&pwd=xxxxx

                            The only place it doesn't yet is HS3 netcam but I have filled a bug report.

                            Bastiaan

                            Comment


                            • #15
                              That works fine for the indoor F19821 but not the F1904W outdoor camera. Can anyone help me with the URL for the 1904?
                              Last edited by Chris Jackson; December 7th, 2013, 08:17 PM.

                              Comment

                              Working...
                              X