Announcement

Collapse
No announcement yet.

New OpenSprinkler Plugin

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Looks like this add on driver is not working for me also just stopped recently. I get the same errors as TotalVoice is showing.
    I also see the add on driver has not been updated in 2 years from todays date.
    If you are looking to buy this device to work with HS, think twice.

    Comment


      thanks, will check version tonight
      Ubuntu on the Intel NUC ( 8i5BEK ), 32 G, 250G SSD, V4 Pro 😎

      Comment


        Hi Everyone,

        I am considering purchasing OpenSprinkler controller hardware but am curious what the current state of compatibility with HomeSeer is looking like. Does it work? Seeing some mixed messages above. Thank you!

        Comment


          Just installed opensprinkler 3.0 which is running firmware 220, debug on plugin shows it's only been tested up to 219. Any chance of a fix or a copy of the current source so I can get it working?
          https://forums.homeseer.com/forum/de...plifier-plugin

          Comment


            The plugin quit working after I upgrade to HS4.

            Comment


              My plugin still works on HS4, I haven't updated it for years as I still have old hardware limited to firmware 219 running reliably.
              I don't have time to keep the plugin up to date, but I'm happy to share source files if you know how to use them. What is the exact error you're etting? I might be related to the install not setting the right files or something, I upgraded from HS3 and it worked, perhaps the issue is only fresh installs on HS4...

              Edit: I'm guessing perhaps you're missing the ini file... Can you please search for HSPI_Opensprinkler.ini under Config folder. The file should contain the following:

              [Settings]
              IPaddress=[yourIP]
              IPPort=80
              Password=[yourpassword]
              Poll=3
              Debug=True
              Stations=8
              Icons=New
              MaxTime=20
              MaxDelay=72​

              Comment


                Thanks for your help Matt. You are right I missing that ini file. After I create one seem everything work fine. I will post if I have more issue.

                Comment


                  Ok cool, thanks for the confirmation. Will try to edit the install file in the next few days and reload a new version. For anyone else reading this, you can fix the issue in the meantime by creating a text file called HSPI_Opensprinkler.ini in your Config folder, pasting in the above text, and setting your IP address, port and password to match your system.

                  Comment


                    Oddly enough it appears to be working now. I haven't paid any attention to it since I installed it as it has rained here almost every day. When I installed the plugin it looks like it created an .ini file in both "config" and "Config" (Linux is case sensitive). The one in "config" has no IP settings in it. That's probably where my original communications error came from. Run a case sensitive "find" on your code for "config" with a lower case "c". I feel like it might have started working after enabling debug.
                    https://forums.homeseer.com/forum/de...plifier-plugin

                    Comment


                      It is working fine Just had some error because I update the latest vwersion Opensprinkler.
                      Legacy-Plugin OS-Debug Error info: js=
                      Legacy-Plugin OS-Debug Error: Failed in attempt to write to Status device - Conversion from string "" to type 'Double' is not valid.
                      Legacy-Plugin OS-Debug Error info: rs=0
                      Legacy-Plugin OS-Debug Error info: jc={"devt":1690386481,"nbrd":1,"en":1,"sn1":0,"sn2":0,"rd":0 ,"rdst":0,"sunrise":409,"sunset":1223,"eip":2890297904,"l wc" :1690375907,"lswc":1690375907,"lupt":1689704120,"lrbtc":4,"l run":[4,1,4500,1690353901],"pq":0,"pt":0,"nq":0,"RSSI":-72,"otc":{},"otcs":0,"mac":"68:C6:3A:F7:F9:4E","loc":"37.86 9 92,-92.25452","jsp":"https://ui.opensprinkler.com/js","wsp":"weather.opensprinkler.com","wto":{"d":24,"pws": "" ,"key":""},"ifkey":"","mqtt":{},"wtdata":{"wp":"Apple","r ain ing":0},"wterr":0,"dname":"My OpenSprinkler","curr":0,"sbits":[0,0],"ps":[[0,0,0,0],[0,0,0,0],[0,0,0,0],[0,0,0,0],[0,0,0,0],[0,0,0,0],[0,0,0,0],[0,0,0,0]],"gpio":[]}
                      Legacy-Plugin OS-Debug Error: Failed in attempt to write to Rain/Soil Sensor device - Input string was not in a correct format.
                      Legacy-Plugin OS-Debug Error info: uwt=0
                      Legacy-Plugin OS-Debug Error info: wl=0
                      Legacy-Plugin OS-Debug Error info: jo=
                      Legacy-Plugin OS-Debug Error: Failed in attempt to write to Water% device - Input string was not in a correct format.
                      Legacy-Plugin OS-Debug Error info: js=
                      Legacy-Plugin OS-Debug Error: Failed in attempt to write to station devices - Input string was not in a correct format.

                      Comment


                        I have been using the OpenSprinkler plugin for years, with 8 zones. I want to add more zones, and the company still offers an expansion module for 2.x hardware. Does adding zones with this expansion module work with the plugin?
                        Mark

                        Comment


                          Off memory yes it does, and I believe others have been using it fine with expansion zones, however I do not have one. Just make sure you update the number of zones setting.

                          Comment


                            I added the zone expander and thought I would share my experience. At the same time I also updated the OpenSprinkler firmware, so not sure what caused some weirdness, but everything seems to work now.

                            I was on firmware 2.1.6 and updated to 2.1.9(11), but I had problems getting it to connect with the plugin. I believe (11) changed EthernetENC library with UIPEthernet - I don't understand what that means, but I can only speculate that it caused the connection problem. So I then tried 2.1.9(9) - then the plugin would at least try to connect, but the password would not be accepted (error was OS-Plugin password mismatch). I could not figure out why because the password was correct, but eventually I checked the "ignore password" setting in the OpenSprinkler app, and after a plugin restart it connected and all was well.

                            The zone expander offers 16 zones, but I only needed 3 more, so I disabled the extra zones in the OpenSprinkler app and set the number of zones to 11 (8+3) on the plugin Config page. I also renamed a few zones on the app. I then hit Rebuild Devices on the Config page, and the plugin seemed to get stuck. There was an error message, but I can't remember exactly what it said but it was something about hanging up. I gave it some time and it imported a few changes. I did that again, and again, After three tries, everything was updated correctly.

                            So my OpenSprinkler 2.3 hardware is up and running with 11 zones on OS firmware 2.1.9(9) and plugin version 2.1.9.3.

                            Mark

                            Comment


                              Is this not compatible with 220?

                              Any one ever get these errors fixed?

                              [11/27/2023 6:15:06 PM] - Device Rebuild Requested
                              [11/27/2023 6:15:06 PM] - Success! INI File read
                              [11/27/2023 6:15:21 PM] - Error: Root device update failed - Input string was no
                              t in a correct format.
                              [11/27/2023 6:15:21 PM] - Error info: jc=
                              [11/27/2023 6:15:21 PM] - Error info: en=0
                              [11/27/2023 6:15:21 PM] - Error: Failed in attempt to write to station devices -
                              Input string was not in a correct format.
                              [11/27/2023 6:15:21 PM] - Error info: js=
                              [11/27/2023 6:15:21 PM] - Error: Failed in attempt to write to program devices -
                              Input string was not in a correct format.
                              [11/27/2023 6:15:21 PM] - Error info: jp=
                              [11/27/2023 6:15:21 PM] - Error: Failed in attempt to write to Rain delay device
                              - Input string was not in a correct format.
                              [11/27/2023 6:15:21 PM] - Error info: jc=
                              [11/27/2023 6:15:21 PM] - Error: Failed in attempt to write to Water% device - I
                              nput string was not in a correct format.
                              [11/27/2023 6:15:21 PM] - Error info: jo=
                              [11/27/2023 6:15:21 PM] - Error info: wl=0
                              [11/27/2023 6:15:21 PM] - Error info: uwt=0
                              [11/27/2023 6:15:21 PM] - Error: Failed in attempt to write to Rain/Soil Sensor
                              device - Input string was not in a correct format.
                              [11/27/2023 6:15:21 PM] - Error info: jc=
                              [11/27/2023 6:15:21 PM] - Error info: rs=0
                              [11/27/2023 6:15:21 PM] - Error: Failed in attempt to write to Status device - C
                              onversion from string "" to type 'Double' is not valid.
                              [11/27/2023 6:15:21 PM] - Error info: js=
                              [11/27/2023 6:15:21 PM] - Error: Failed in attempt to write to history device -
                              Index was outside the bounds of the array.
                              [11/27/2023 6:15:21 PM] - Error info: jc=
                              [11/27/2023 6:15:21 PM] - Error: Failed in attempt to set advanced status - Inpu
                              t string was not in a correct format.​

                              Comment


                                I'm running 2.2.0(1) firmware. I don't have error that you post but not all the function work. I can turn on and off ant zone not manual run function. Try click on LET'GO button than disable the plugin and enable again.

                                Comment

                                Working...
                                X