Announcement

Collapse
No announcement yet.

control Velux skylights with HS3 and RFXCOM?

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • #16
    Eman - I presume that MQTT speaks to the KLF200 via the LAN port?

    Comment


    • #17
      Originally posted by ScottRennie View Post
      Eman - I presume that MQTT speaks to the KLF200 via the LAN port?
      You first find YouTube videos of how Node-RED works and the you will need this node : https://flows.nodered.org/node/node-red-contrib-velux which connects to the mqtt node which connects to HomeSeer . The Velux node also work via LAN.

      You have to learn Node-RED first. Once you know how things work then you will see what you have been missing!

      Eman.
      The Closer.

      Comment


      • #18
        Node-red and MQTT overkill - used a Velux KLF200 and a Fibaro Smart Implant set to 800ms auto-off work perfectly and easily.

        Comment


        • #19
          We have our Velux skylights controlled by HS using the KLF100. The KLF100 is a basic contact closure based controller from Velux.

          Basically you need a simple HS controlled relay to control the Velux. Something like a simple ZWave realy, or Raspberry Pi, or CAI Web Control or whatever. We actually use a spare channel on our Clipsal CBus (digital lighting) system allowing us to use an existing 'ligh switch' to open/close the skylights.

          There are a few caveats though. Firstly check the frequency of the KLFs. There are regional differences due to RF regulations. The UK version is different than the US version and the AU/NZ version etc. Secondly there is no feedback with the KLF100s. You can't confirm the skylight actually closed, or if the inbuilt rain sensor closed the skylight for example. Not sure if this is the case with the KLF200s. I had to install a small sensor on the skylights to get the 'status' of the skylight. And you need one Klf100 for each 'group' of skylights. So if you have more than one skylight you want to control independently you need more than on KLF100.

          I might have a closer look at the KLF200s. If they provide status feedback that might be a tidier option.

          I have two KLF100 UKs if anyone wants them (shipping from New Zealand).

          Marty
          iCore5 Win 10 Pro x64 SSD

          HS3 Pro Edition 3.0.0.435 Windows

          BLOccupied:,Device History:,Yamaha:,UltraMon3:,mcsXap:,Restart:,UltraNetatmo3:, UltraM1G3:,Ultra1Wire3:,BLBackup:,Harmony Hub:,DoorBird:,UltraECM3:,Nanoleaf 3P:,UltraRachio3:,Z-Wave:,SDJ-Health:,BLGarbage:,Blue-Iris:,Chromecast:,Pushover 3P:,EasyTrigger:

          Comment


          • #20
            I also use the KLF100, which works great with simple dry contact to open or close.
            Also curious if feedback is available from the KLF200 like the remote.
            DSteiNeuro

            HS3Pro

            MSI Cubi Intel(R) Core(TM) i5-5200U CPU @ 2.20GHz, 2201 Mhz, 2 Core(s), 4 Logical Processor(s) 16GB DDRl RAM

            Enabled Plug-Ins
            BLRussound, BLSpeech, HSTouch Server, JowiHue, MyQ, Nest, Rain8, Squeezebox, Ultra1Wire3, UltraGCIR3, Vista Alarm, X10,Z-Wave

            Comment


            • #21
              The KLF200 does talk about feedback, but I put in a mag switch in the meantime to give open/closed feedback. I'll look at the KLF status over the winter months. The KLF200 does up to 5 groups I think. I have it running 2 x blinds together & 2 x Windows together. The windows were retrofit Velux motors.

              Comment


              • #22
                Originally posted by ScottRennie View Post
                ...and a Fibaro Smart Implant set to 800ms auto-off work perfectly and easily.
                Have you managed to get both outputs from the Fibaro smart implant to appear in homeseer? I can see Output 1 by the remaining child devices added by the implant don't appear to add correctly for me.

                Comment


                • #23
                  Originally posted by Aljrob View Post
                  Have you managed to get both outputs from the Fibaro smart implant to appear in homeseer? I can see Output 1 by the remaining child devices added by the implant don't appear to add correctly for me.
                  Yes. Suggest you rescan a couple of times. I think one of the units did not create properly & I had to remove and re-add. It did work eventually!

                  Cheers

                  Comment

                  Working...
                  X