Announcement

Collapse
No announcement yet.

Gmail Integration

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Gmail Integration

    I have my Zee w/HS3 working as far as sending email is concerned, but I can't get the receive side to work. I've selected Use Gmail at the top of the email configuration, which I would expect to correctly configure the ports, server name, etc. But, no matter the settings I get an error that I'm connecting to a port that requires SSL or vice versa, no matter what settings I've tried.

    So, what is the correct way to set up Zee/HS3 to receive Gmail?

    David

    #2
    Has NO one tried to use the Gmail setting to receive messages???

    Is there a better discussion area to post this in??

    David

    Comment


      #3
      I posted the solution that worked for me a few days ago. Was related to settings in Gmail to allow other programs to send messages.


      Verzonden vanaf mijn iPhone met Tapatalk

      Comment


        #4
        Thanks, ABL. I checked that setting and already have it set to on. Note that I can send email just fine, I just can't receive it. I think there is something in the settings that is not correct. I can't tell if the "Use Gmail" is overriding the other settings, or if it's trying to do some sort of mix and failing.

        The error I get is:

        Unable to log into Gmail server: Authenticate as SSL client failed. You might be connecting to non SSL port.:Inner Exception: System.IO.IOException: The authentication or decryption has failed. ---> Mono.Security.Protocol.Tls.TlsException: Invalid certificate received from server. at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.LocalValidation (Mono.Security.Protocol.Tls.ClientContext context, AlertDescription description) [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.validateCertificates (Mono.Security.X509.X509CertificateCollection certificates) [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.Client.TlsServerCertifi cate.ProcessAsTls1 () [0x00000] in :0 at Mono.Security.Protocol.Tls.Handshake.HandshakeMessage.Proces s () [0x00000] in :0 at (wrapper remoting-invoke-with-check) Mono.Security.Protocol.Tls.Handshake.HandshakeMessage:Proces s () at Mono.Security.Protocol.Tls.ClientRecordProtocol.ProcessHands hakeMessage (Mono.Security.Protocol.Tls.TlsStream handMsg) [0x00000] in :0 at Mono.Security.Protocol.Tls.RecordProtocol.InternalReceiveRec ordCallback (IAsyncResult asyncResult) [0x00000] in :0 --- End of inner exception stack trace --- at Mono.Security.Protocol.Tls.SslStreamBase.AsyncHandshakeCallb ack (IAsyncResult asyncResult) [0x00000] in :0

        I have the SSL box checked, but I get this message regardless of whether or not it is checked.

        Comment


          #5
          Is your mail domain field blank? If not, try it with it blank.

          Cheers
          Al
          HS 3.0.0.548: 1990 Devices 1172 Events
          Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

          Comment


            #6
            Domain is blank.

            I did find one issue.....I had disabled POP on the Gmail side, rather, when I turned POP on, I didn't save it. I think I have the server side settings correct now.

            I unchecked the Use Gmail box and have put in the settings manually. When I have SSL checked, I get an SSL error saying the port I'm trying to connect to might not be SSL. When I uncheck the SSL box, I get a POP read error saying nothing was read and that my A/V or Firewall settings might be preventing it (unlikely).

            I'm restarting Homeseer, with the settings the way I think they should be, just to make sure something isn't getting set up incorrectly. I've noticed that changing a setting, like checking the SSL or unchecking it, doesn't necessarily do anything, though check or unchecking the read email box appears to reinitialize things.

            Any thoughts at this point?
            David

            Comment


              #7
              Interesting.....

              I'm working with a trial version of HS3 running on a spare computer. I went into the email tab and clicked Use Gmail. I entered my email and password. I clicked the receive email button and......it all works.

              So, it seems that having entries in the email settings messes up Use Gmail, i.e., Use Gmail doesn't completely override what is there.

              Is there a way to clear out the previous settings???

              David

              Comment


                #8
                Glad to hear you are making progress Dave! I think they are all stored in the settings.ini file. Shutdown HS and delete the related entries from the file and then restart.

                Cheers
                Al
                HS 3.0.0.548: 1990 Devices 1172 Events
                Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                Comment


                  #9
                  Thanks, Al, I was wondering if it was possible to edit the file offline.

                  So, how do I do this on a Zee???

                  And where would the settings be to compare on my PC?

                  David

                  Comment


                    #10
                    You'd have to connect in with something like WinSCP and then browse to the folders where the HS files are stored. Hopefully Pete will see this post or someone else that has a Zee. If not, send a PM to Pete and I'm sure he can help. On the PC, it should be under C:\Program Files (x86)\HomeSeer 3\Config. Your root directory may be a bit different depending on where you installed it.

                    Cheers
                    Al
                    HS 3.0.0.548: 1990 Devices 1172 Events
                    Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                    Comment


                      #11
                      Here is an example of using WinSCP and editing a file.

                      Download WinSCP here.

                      WinSCP is only a Wintel program made to connect to a Linux box via SSH.

                      Configure it with your root access and IP.

                      It is said to use sudo only when you ssh to your RPi. That said I never have been able to get WinSCP to work with sudo.

                      Create a root password by typing : passwd root

                      SSH by default shuts off root access

                      Enable it by editing (use nano) /etc/ssh/sshd_config

                      sudo nano /etc/ssh/sshd_config

                      Change or add the following lines:

                      comment PermitRootLogin without-password
                      uncomment PermitRootLogin yes
                      comment # StrictModes yes
                      uncomment PasswordAuthentication yes

                      save and restart SSH service by typing:

                      sudo service ssh reload

                      When you edit a file in WinSCP it will ask for confirmation of you password. Double left click on the file to edit it.

                      You can also change a file/directory permissions right clicking on properties.

                      Also you can Tar/Gzip or UnTar/GZip files / directories.

                      Many times will copy a file from right to left, rename it and copy it back to source directory then edit the original file.

                      As Al mentions above make sure you have Homeseer off while editing the INI files. Using WinSCP you can run Putty and temporarily start HS3 in a console such that you can watch while testing your email. Once out of the terminal session and having vaildated your email to work; reboot the box; WinSCP will automatically disconnect from the box.

                      Note too that the default RPi/RPi2 HomeSeer directory for the Zee and the Zee-2 is /usr/local/HomeSeer.
                      Attached Files
                      Last edited by Pete; August 17, 2015, 03:12 PM.
                      - Pete

                      Auto mator
                      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
                      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
                      HS4 Pro - V4.1.17.0 - Ubuntu 20.01/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono
                      6.12.0.122
                      HS4 Lite -

                      X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                      Comment


                        #12
                        I've been looking at the ini files between the two configurations, and that leads me to this question.....

                        Can I back up the configuration, edit it, then restore the editted version?

                        Comment


                          #13
                          Originally posted by david.delano View Post
                          I've been looking at the ini files between the two configurations, and that leads me to this question.....

                          Can I back up the configuration, edit it, then restore the editted version?
                          Absolutely, as long as HS is shutdown when you restore it.

                          Cheers
                          Al
                          HS 3.0.0.548: 1990 Devices 1172 Events
                          Z-Wave 3.0.1.262: 126 Nodes on one Z-Net

                          Comment


                            #14
                            I've been able to clean up the settings.ini file, and it's easier (I think) than it sounds. I did a back up of the configuration from both the PC setup (which works) and the Zee. This puts a zip of zips on the local machine (wherever you are running the web browser from). I then used Beyond Compare to compare the two zip files, and I cleaned up the email setting in the Zee file that aren't there in the PC file. I then restarted the Zee.

                            Still doesn't work. I backed up the config again and compared the current Zee config with the one I edited. They are essentially the same.

                            Now, there are a bunch of database files that I didn't do anything with, so the data might be getting cached somewhere, but in essence, the settings.ini that I now have should theoretically work.

                            I should note that I have the same version of HS3 on both devices.

                            Is this a bug??

                            David

                            Comment


                              #15
                              I also set up events to test the Gmail interface on the PC side. It is working fine. I detected an email with a predetermined subject and sent out another email saying I'd received the first email.

                              So, what's up on the Zee??? Is it the difference that it's running on Linux and the SSL that Google is expecting isn't supported?

                              Comment

                              Working...
                              X