Announcement

Collapse
No announcement yet.

Apple Homekit(Siri) integration with Homeseer

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

  • RandyInLA
    replied
    nl_user,
    • If you are adding a Homeseer accessory, it needs to be inside another "accessories: []" that is inside the HomeSeer platform. You have yours inside accessories outside of the platform section. I added an accessories section under your HomeSeer platform as well as moved your device inside of it.
    • Formatting your host under platforms can include the username/password you want to use for Homebridge, so you don't need separate entries for username or password. In the host entry, the colon separates username/password and don't forget the "@" between password and the actual URL to your Homeseer server (I just use the IP Address for mine). Note: I know this is true for HomeSeer 3. Not sure if you are using HS4 or if this format for the URL, passing the username/password, also works for HS4 or not.
    • You had a, "Z-Wave Switch Binary": []," out in the middle of nowhere, so I removed it below
    • The accessories: [] outside of platforms needs to exist, but can simply be an empty array
    • I don't have a description in my JSON, so I removed yours below
    • the ASCIIport's default is 11000, so you don't need it in your JSON
    • I added the "poll" attribute as that tells Homebridge how often to poll for changes in seconds over the ASCIIport. I'm not sure if 60 is the default or not, but it's still in mine, so I included it below.
    • I added the events array, even though it's empty. It'll give you a place to insert any Homeseer events you want to trigger from Homebridge
    • You need to lookup the Homeseer Reference ID number for your light. It can be found on the Advanced tab of the device's page.
    • I added onValue/offValue for your switch. The value of "on" is typically set to 100 in Homeseer. You may or may not have changed that. If you did, put the correct value in the onValue for this accessory.
    • Even though it may be a switch on the wall, if it is connected to a light, I'd define it as a lightbulb in config.json
    • If you can dim the light via your Z-Wave switch, then add the line "can_dim": true.
    Try changing your JSON to be like the JSON below, replacing any <> entries I added with actual values from your system (the JSON must be saved in a file named config.json, not sure if you mentioned you have it named correctly and saved to the right place)

    Code:
    {
        "bridge": {
            "name": "Homebridge 9793",
            "username": "0E:D1:72:36:97:93",
            "port": 51994,
            "pin": "477-87-761"
        },
        "accessories": [],
        "platforms": [
            {
                "platform": "HomeSeer",
                "name": "HomeSeer",
                "host": "http://<username>:<password>@<address_of_your_homeseer_server>",
                "poll": 60,
                "events": [],
                "accessories": [
                    {
                        "ref": <reference_id_number_of_your_z_wave_light_in_homeseer>,
                        "type": "Lightbulb",
                        "onValue": 100,
                        "offValue": 0,
                        "can_dim": true, (only add this if your light is actually dimmable using the Z-Wave switch)
                        "name": "Lamp tafel - Switch 1" (I would name this, "Light" or "Table Lamp" etc. something descriptive and lends itself to saying it naturally to Siri)
                ]
            }
        ]
    }
    As for how to set things up so you can invoke Siri, I don't use the "Floors" part of Homeseer, just rooms. When you see your device show up in the iOS Home app on your phone, you can move it into any room that is designated inside of the iOS Home app since Home doesn't know anything about rooms or floors in HomeSeer. ie.You may have the light in a room named, "Guest" in Homeseer, but then have it in a room named, "Main Bedroom" in the iOS Home app. Also, the main connection between HomeBridge/Siri and HomeSeer devices is the device's Reference ID number, so you can name things however you want in the config.json file to speak them to Siri. I would name the light simply, "Light" in the HomeBridge config.json. You can have many different devices named the same thing in config.json and move them into different rooms in the iOS Home app. After you move your lamp device into a room named, "Main Bedroom" in the iOS Home app, you can say, "Hey Siri, turn the Main Bedroom light on". You'll find that you can also say, "Hey Siri, Main Bedroom Light" and Siri will toggle it. If it was on, she'll turn it off and vice versa. Another good one to remember is, "Hey Siri, what's the status of the Main Bedroom Light?", to which she'll just answer if it is on of off. If you want to know the brightness of it (if it's a dimmable device) then ask, "Hey Siri, what's the brightness of the Main Bedroom light?" and she'll say something like, "The Main Bedroom light is at 18%" You can go on to say, "Hey Siri, brighten the Main Bedroom light by 5%" or "Hey Siri, dim the Main Bedroom light by 10%" or "Hey Siri, set the Main Bedroom light to 48%" Note: I don't think any of the brighten/dim/brightness commands to Siri will work unless the device type is set to Lightbulb and possibly also the can_dim is also set in config.json.

    Leave a comment:


  • nl_user
    replied
    Finally succeeded and got it working. I now have one device in Homekit which I can use. Now figure out how to set up things in Homekit. Using Scenes and rooms. First try I thought it did not work, But apparently it did, but because off some delay on the network it took some time to respond. Very Nice
    Sharing some pics here for others starting with this.

    How to deal with different rooms (or places) when using Siri? Would the command include He SIRI: Upstairs bathroom light on? Whats a good approach here?


    Click image for larger version

Name:	homebridge_succeeded.jpeg
Views:	83
Size:	15.0 KB
ID:	1404036Click image for larger version

Name:	E38A6314-AB57-4400-8360-A325DF1B66CA.jpg
Views:	63
Size:	25.7 KB
ID:	1404037

    Leave a comment:


  • mik3
    replied
    Originally posted by nl_user View Post
    Well, I changed things according to your link. No errors in Homebridge but also nothing in the Homekit app. So what Am I missing?

    Code:
    {
    "bridge": {
    "name": "Homebridge 9793",
    "username": "0E:D1:72:36:97:93",
    "port": 51994,
    "pin": "477-87-761"
    },
    "description": "Dit is een test configuration file.",
    "Z-Wave Switch Binary": [],
    "accessories": [
    {
    "accessory": "Z-Wave Switch Binary",
    "name": "Lamp tafel - Switch 1"
    }
    ],
    "platforms": [
    {
    "platform": "HomeSeer",
    "name": "HomeSeer",
    "host": "http://",
    "ASCIIport": 11000,
    "login": "default",
    "password": "default"
    }
    ]
    }
    Where are the open/close brackets?

    youre also missing the Homeseer host.

    did you add this to your homekit app? Scan the code or type it in?

    Leave a comment:


  • nl_user
    replied
    Well, I changed things according to your link. No errors in Homebridge but also nothing in the Homekit app. So what Am I missing?

    Code:
    {
    "bridge": {
    "name": "Homebridge 9793",
    "username": "0E:D1:72:36:97:93",
    "port": 51994,
    "pin": "477-87-761"
    },
    "description": "Dit is een test configuration file.",
    "Z-Wave Switch Binary": [],
    "accessories": [
    {
    "accessory": "Z-Wave Switch Binary",
    "name": "Lamp tafel - Switch 1"
    }
    ],
    "platforms": [
    {
    "platform": "HomeSeer",
    "name": "HomeSeer",
    "host": "http://",
    "ASCIIport": 11000,
    "login": "default",
    "password": "default"
    }
    ]
    }

    Leave a comment:


  • mik3
    replied
    Originally posted by nl_user View Post
    So got a bit further. The plugin is accepted by the Homekit app. But than what?

    This is the "simple config.json" I have now. But its trowing an error in Homekit saying "all accessory blocks must contain the "accessory" attribute". So not realy sure what that involves?

    This is my simple xml right now:

    Code:
    {
    "bridge": {
    "name": "Homebridge 9793",
    "username": "0E:D1:72:36:97:93",
    "port": 51994,
    "pin": "477-87-761"
    },
    "description": "Dit is een test configuration file.",
    
    
    "Z-Wave Switch Binary": [],
    
    "accessories": [
    {
    "type": "Z-Wave Switch Binary",
    "ref": 265
    }
    ],
    
    
    "platforms": [
    {
    "platform": "HomeSeer",
    "name": "HomeSeer",
    "host": "http://my_own_url_here",
    "ASCIIport": 11000,
    "login": "default",
    "password": "default"
    }
    ]
    }
    Would be nice to someone's xml to compare since I'm not getting the complete picture here.

    Is the "type" right "Z-Wave Switch Binary": [],?

    Since my types are all different and have names like: Z-wave On/Off sensor, and so on? Or do I need to use the general naming like in the example.config which seems to be completely different from the ones I have?
    How to get a simple On / Off device in Homekit? Is it there automatic popping up when I have the correct config.json?

    https://github.com/homebridge/homebr...ig-sample.json

    Leave a comment:


  • nl_user
    replied
    So got a bit further. The plugin is accepted by the Homekit app. But than what?

    This is the "simple config.json" I have now. But its trowing an error in Homekit saying "all accessory blocks must contain the "accessory" attribute". So not realy sure what that involves?

    This is my simple xml right now:

    Code:
    {
    "bridge": {
    "name": "Homebridge 9793",
    "username": "0E:D1:72:36:97:93",
    "port": 51994,
    "pin": "477-87-761"
    },
    "description": "Dit is een test configuration file.",
    
    
    "Z-Wave Switch Binary": [],
    
    "accessories": [
    {
    "type": "Z-Wave Switch Binary",
    "ref": 265
    }
    ],
    
    
    "platforms": [
    {
    "platform": "HomeSeer",
    "name": "HomeSeer",
    "host": "http://my_own_url_here",
    "ASCIIport": 11000,
    "login": "default",
    "password": "default"
    }
    ]
    }
    Would be nice to someone's xml to compare since I'm not getting the complete picture here.

    Is the "type" right "Z-Wave Switch Binary": [],?

    Since my types are all different and have names like: Z-wave On/Off sensor, and so on? Or do I need to use the general naming like in the example.config which seems to be completely different from the ones I have?
    How to get a simple On / Off device in Homekit? Is it there automatic popping up when I have the correct config.json?


    Leave a comment:


  • srodgers
    replied
    Originally posted by wpiman View Post
    I have used the Apple Script to run JSON commands on Homeseer. Works well- no plug in necessary, No feedback though.
    Same here. I have a few Apple Shortcuts setup that fires off a HS event. They use the Hey Siri Control voice control. Handy when my hands are dirty and cellphone is near by and I want to start or stop sprinkler events in HS.

    Leave a comment:


  • nl_user
    replied
    Ok, managed to get that working. Delete the auth.json file and restart. Than log in with default settings. Nice

    Leave a comment:


  • nl_user
    replied
    Ok, Clear. I wanted to start with just one device as you mentioned.
    The first problem already came up, after installing Homebridge the default password and user are not accepted? Any idea where to change that on the pi? Or is it a linux user? I think there is already an admin user for Domotics which is on the same Rpi.

    Leave a comment:


  • mik3
    replied
    Originally posted by nl_user View Post
    Thanks, will give that a try. Will the plugin offer an option to add an url towards the Hs3 server? Or how is that working.
    No need to. Just following the plugin instructions. You will setup RefID's to the devices you want to control.

    Focus on getting Homebridge installed with the plugin and working with the config file. Focus on only one device and get that working. Once you got that working start expanding.

    Leave a comment:


  • randman
    replied
    Originally posted by nl_user View Post
    Thanks, will give that a try. Will the plugin offer an option to add an url towards the Hs3 server? Or how is that working.
    The URL of the config.json file used by the Homebridge-homeseer4 software will contain the IP of the HomeSeer server.

    Leave a comment:


  • nl_user
    replied
    Thanks, will give that a try. Will the plugin offer an option to add an url towards the Hs3 server? Or how is that working.

    Leave a comment:


  • mik3
    replied
    Originally posted by nl_user View Post
    I want to explore the possibilities of Homebridge and the homebridge-homeseer4- plugin. Just a brief question here. Can I run Homebridge and the homebridge-homeseer4-plugin on a remote rpi? Or does it has to be on the same Rpi as where Hs3 is running? I prefer to have it on a remote Rpi, same one which is running the mosquito server.
    Remote is fine. That's how I do it.

    Leave a comment:


  • nl_user
    replied
    I want to explore the possibilities of Homebridge and the homebridge-homeseer4- plugin. Just a brief question here. Can I run Homebridge and the homebridge-homeseer4-plugin on a remote rpi? Or does it has to be on the same Rpi as where Hs3 is running? I prefer to have it on a remote Rpi, same one which is running the mosquito server.

    Leave a comment:


  • wpiman
    replied
    I have used the Apple Script to run JSON commands on Homeseer. Works well- no plug in necessary, No feedback though.

    Leave a comment:

Working...
X