Announcement

Collapse
No announcement yet.

OK, I have a NET Problem, what happens if...

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    OK, I have a NET Problem, what happens if...

    I am pretty sure I have a NET problem, so, if I uninstall all Net versions will HS2 and HS3 automatically re-install as required?

    If not which versions of NET are required to run HS2 and HS3?
    sigpic
    A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

    #2
    What do you mean a "NET" problem?

    Comment


      #3
      He means .NET (dot NET)

      In theory if you remove all versions then the requirements are checked when you do an install and the right .NET is installed. This option have to be included in the installer when the installer was created. However the experience tells me that there are sometimes leftovers when de-installing .NET that prevent this. And not all installers verify the .NET versions and install the missing ones. In general .NET is backward compatible and looking at the timeline of HS2 and HS3 i think that 4.0 must be oke.
      - Bram

      Send from my Commodore VIC-20

      Ashai_Rey____________________________________________________________ ________________
      HSPro 3.5.0
      PIugins: ZMC audio | ZMC VR | ZMC IR | ZMC NDS | RFXcom | AZ scripts | Jon00 Scripts | RFXCOM | BLRadar | BLBackup

      Comment


        #4
        Thanks Ashai_Rey,

        Yes I was referring to .NET

        I will try removing them all except .Net 4 and see if HS2 will run correctly.
        sigpic
        A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

        Comment


          #5
          Here have not played with the dot net on my HS2 boxes.

          Last I recall here HS3 didn't required anything dot net wise above whatever was the last dot net utilized by XP.

          Thinking last dot net update for Windows XP should work fine out of the box.

          Have a look here ==> Dot net checkers

          Might be easier to quit playing with it, copy the directory out for keeping, build a new basic box, install last version of HS2 on it in the same directory utilized, then copy over your backup directory. It is very easy to get to dot net hell. Quit playing with the dot net stuff.

          I would choose the easy button way to do this.

          so, if I uninstall all Net versions will HS2 and HS3 automatically re-install as required?

          Once you get to using W7 you can just turn it on or off. What version of Windows are you using these days for your stuff Gordon?

          I have played some here now with W10 and they have fixed and made the OS lite (take the fluff out of it as it is only an advertisement).
          Last edited by Pete; December 29, 2015, 07:47 AM.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
          HS4 Pro - V4.1.11.0 - Ubuntu 20.01/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono
          6.10.0.104
          HS4 Lite -

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


            #6
            Originally posted by AshaiRey View Post
            He means .NET (dot NET)

            In theory if you remove all versions then the requirements are checked when you do an install and the right .NET is installed. This option have to be included in the installer when the installer was created. However the experience tells me that there are sometimes leftovers when de-installing .NET that prevent this. And not all installers verify the .NET versions and install the missing ones. In general .NET is backward compatible and looking at the timeline of HS2 and HS3 i think that 4.0 must be oke.
            .Net may be backward thinking however HS2 and 3 are not.

            HS 2 requires NET2 and HS3 requires NET3.5 or they do not play Neither of the programmes require .NET4, however some of the accessories do.

            I had to use a Ghost to get the system back after I removed the nets.

            Now have I got this approach wrong. Remove all .NET except 4, uninstall HS2 & 3 then re-install?
            sigpic
            A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

            Comment


              #7
              Simplest way is to use the Windows update and load all .net frameworks that are available.
              -Rupp
              sigpic

              Comment


                #8
                I agree with Rupp.
                Even if you need only .NET 2.0 then the next version contains fixes for the previous version that you still might need. Or install the needed patches by hand.
                - Bram

                Send from my Commodore VIC-20

                Ashai_Rey____________________________________________________________ ________________
                HSPro 3.5.0
                PIugins: ZMC audio | ZMC VR | ZMC IR | ZMC NDS | RFXcom | AZ scripts | Jon00 Scripts | RFXCOM | BLRadar | BLBackup

                Comment


                  #9
                  Originally posted by Pete View Post
                  Once you get to using W7 you can just turn it on or off. What version of Windows are you using these days for your stuff Gordon?

                  I have played some here now with W10 and they have fixed and made the OS lite (take the fluff out of it as it is only an advertisement).
                  Pete, happy New Year, still running XP Pro and apart from updates still as it shipped out of The States.

                  Considering upgrading the machine to W10, have W10 on another PC and quite like it.
                  sigpic
                  A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

                  Comment


                    #10
                    Originally posted by AshaiRey View Post
                    I agree with Rupp.
                    Even if you need only .NET 2.0 then the next version contains fixes for the previous version that you still might need. Or install the needed patches by hand.
                    Apparently require .NET2, 3.5 and 4 as I'm running XP Pro the updater don't work no more otherwise would use Rupp's suggestion as I think I have a problem with one of the .NET's.

                    For example HS2 and 3 can run perfectly for ages, however introduce Jon00's HS2 to HS3 and HS2 wont last more than a few hours.

                    Thinking of upgrading to Windows 10 - don't know if that will solve the problem or W10 will just adopt the problem!
                    sigpic
                    A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

                    Comment


                      #11
                      Do not do an upgrade. Do a clean install or you will continue to have issues.
                      -Rupp
                      sigpic

                      Comment


                        #12
                        Originally posted by Rupp View Post
                        Do not do an upgrade. Do a clean install or you will continue to have issues.
                        Thanks Rupp, I will on this occasion take your advice.
                        sigpic
                        A founder member of "The HA Pioneer Group" otherwise known as the "Old farts club!"

                        Comment

                        Working...
                        X