No announcement yet.

OpenSprinkler Comms Fail

  • Filter
  • Time
  • Show
Clear All
new posts

    OpenSprinkler Comms Fail

    Have an issue with OpenSprinkler and HomeSeer HS3 Pro Edition (Windows) and OpenSprinkler I can control the valves and the device responds, but I continue to see Comms Fail. I have tried searching the forums, and have found a few suggestions with the following results:

    I have changed the Poll to 30 from 5 with no change. I have uninstalled and reinstalled the plugin. I have tried ignoring the password in the web interface. I still see Comms Fail. I see nothing in the log to tell me what might be wrong. Any ideas?

    By the way, I am very new to Homeseer but do have door locks and Linear Garage door controller door controller working with no issues. I have not yet created and interface, but will once I get all the devices working.



    Hi Carl,

    I have it working with HS version OSPI version 2.1.6 and the plug in. I doubt the HS version matters but the version of firmware on your opensprinkler probably does. The don't version the communication protocol and when they change it it breaks anyone talking to it. You might take a look at that. Also I assume your IP address is correct and you are connecting to port 8080.


      My OpenSprinkler firmware version is 2.1.6(1) and the hardware version is 2.2-AC. This information came from the web interface of OpenSprinkler. The http port in the web interface of OpenSprinkler is 80. The port in the plugin config was also 80. Should it be set to 8080 in Homeseer and the web interface? The IP address is the same in Homeseer and the Opensprinkler unit and I can start and stop zones even though it shows Comm Fail. Where would I find information on the communication protocol?


        I reset the ports in both OpenSprinkler and Homeseer to 8080 with no change. I restarted Homeseer and looked at the logs and noticed that there was a warning about the version:

        "OS-Plugin Warning: Firmware detected is 216. Plugin has only been tested up to 215 - be wary of errors."

        Is it possible to downgrade the firmware on the OpenSprinkler device? After initialization, which seemed to complete without errors the following error came up and continues again and again:

        "OS-Debug Error: Failed in attempt to set advanced status - Index was outside the bounds of the array."

        I have attached the log file as a text file.

        Thanks for the help! Carl
        Attached Files


          I probably set the port to 8080 in the web interface so as long as both are the same it shouldn't matter. I assume the password is also set in HS and is the same you manually log in with from the web page.

          I also see the warning - so in this case it should not be a problem because mine works as do others. One caveat though is that I have the OSPi version of the controller and you see to have the "full" version.

          I had some issues with the poll interval although I can't remember the symptoms but I set the poll to 30 and got rid of the problem.

          The hardware vendor should be able to help with a downflash should you wnaat to try that. On the Pi version it's easy, not sure about yours. You might also try this thread as the developer of the plug-in may respond

          Good luck.


            Password is set the same in HS and is the same as when I manually log in from the web page. I have also removed the password and set Ignore Password in the web interface. No change.

            I set the poll interval at 30 with no change in the symptoms.

            I will get in touch with OpenSprinkler regarding a downflash to see if it helps. I also posted in the thread you gave me.

            Thanks! Wish me luck.