Announcement

Collapse
No announcement yet.

Linux running X10 Plugin Remotely

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Linux running X10 Plugin Remotely

    Just an FYI post relating to running the Homeseer 3 X10 plugin remotely.

    This is working Linux to Linux.

    Ideally if it worked Linux to Wintel then you could just connect a CM11A to a RPi2 and run the plugin remotely anywhere in the house wired or wirelessly.

    Currently have a Zee-2/RPi2 in the attic doing Z-Wave + via a GPIO card.

    I have another RPi2 running CumulusMX on the second floor of the home connected to a Davis Weather console (Vantage Pro 2 connection). This could be another RPi2 box near or next to the fuse panel in your home.

    1 - connected a CM11A to the RPi2 via a serial to USB cable
    2 - comes up on the RPi2 as /dev/ttyUSB1
    3 - on Zee-2 I edited the settings.ini file to read: COMPort_X10:=/dev/ttyUSB1 *NOTE - there is no /dev/ttyUSB1 device on the Zee-2
    4 - created a directory on the RPi2 called /hs3x10
    5 - copied the following files over from the Zee-2 to the RPi2 remote machine. Here I created a directory called hs3-x10 in the root.
    HSPI_X10.exe
    HomeSeerAPI.dll
    HSCF.dll
    Scheduler.dll

    6 - on remote machine run
    cd /hs3x10
    mono HSPI_X10.exe server=IPOFZEE2

    7 - connected to Zee-2


    Questions:

    1 - How do I shut off debug mode on the X10 interface? I do not want to see the serial CM11A chit chat.
    Attached Files
    Last edited by Pete; January 2, 2016, 02:51 PM.
    - Pete

    Auto mator
    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
    HS4 Pro - V4.1.11.0 - Ubuntu 20.01/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono
    6.10.0.104
    HS4 Lite -

    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

    #2
    Happy New Year Pete!

    Thanks for the detailed info.

    1) Debug log messages are created when "Developer Mode" is checked on the manage plugins page (just below the menu bar). Try unchecking this and let me know if that changes the CM11a chattyness.

    2) Not sure what you mean by edit the Settings.ini. If you are asking whether there is a setting in X10.ini or settings.ini to control CM11a logging, the answer is unfortunately no.

    I will look into adding an enable/disable logging option to all of the X10 plugins as an enhancement (the Ti103 already has this).
    Best regards,
    -Mark-

    If you're not out on the edge, you're taking up too much room!
    Interested in 3D maps? Check out my company site: Solid Terrain Modeling

    Comment


      #3
      Happy New Year Mark.

      I will look into adding an enable/disable logging option to all of the X10 plugins as an enhancement (the Ti103 already has this).

      Thank you Mark.

      With developer mode on remotely seeing this when turning on X10 device A2.

      Jan-02 2:00:22 PM X10 DEBUG CM11A Sending: 4 6E Size: 2
      Jan-02 2:00:22 PM X10 DEBUG CM11A Got checksum: 72
      Jan-02 2:00:22 PM X10 DEBUG CM11A Checksum OK, sending 0
      Jan-02 2:00:23 PM X10 DEBUG CM11A Got ack of: 55
      Jan-02 2:00:23 PM X10 DEBUG CM11A Sending: 6 62 Size: 2
      Jan-02 2:00:23 PM X10 DEBUG CM11A Got checksum: 68
      Jan-02 2:00:23 PM X10 DEBUG CM11A Checksum OK, sending 0
      Jan-02 2:00:23 PM X10 DEBUG CM11A Got ack of: 55

      By default have always left the developer mode on. I will try to see what happens when I shut it off. This did not do anything to the logs. It seems that changing the x10ini file plugindebug=true worked.

      An x10.ini file is created on the mothership when I run the x10 plugin remotely and it looks like this: (is it just creating this for the TI-103?)

      [settings]
      PluginDebug=True
      Override=False
      COMPort=/dev/ttyUSB0


      Changed it to this:

      [settings]
      PluginDebug=True
      Override=True
      COMPort=/dev/ttyUSB1


      Restarted both boxes and it looks like it shut off the debug. Here is what I see in the logs now.
      When I put a check mark in the Do not log commands from this device then the log entries below go away.

      1/2/2016
      Jan-02 2:18:15 PM Device Control Device: x10 x10remote A1 to On (100) by/from: CAPI Control Handler Threadpool worker
      Jan-02 2:18:37 PM Device Control Device: x10 x10remote A1 to Off (0) by/from: CAPI Control Handler Threadpool worker
      Jan-02 2:18:41 PM Device Control Device: x10 x10remote A1 to On (100) by/from: CAPI Control Handler Threadpool worker
      Jan-02 2:18:45 PM Device Control Device: x10 x10remote A1 to Off (0) by/from: CAPI Control Handler Threadpool worker

      To get the remote plugin running on the mothership I have to change the settings.ini file so that the X10 line changes from:

      COMPort_X10:=/dev/ttyUSB0

      to

      COMPort_X10:=/dev/ttyUSB1

      Even though there is no /dev/ttyUSB1 device.

      It appears that when running it remotely it looks at the settings.ini file for the /dev/ttyUSB1 device running on the remote machine.
      Last edited by Pete; January 2, 2016, 03:24 PM.
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb- Mono 6.12.X - HSTouch on Intel tabletop tablets
      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro - Mono 6.12.X
      HS4 Pro - V4.1.11.0 - Ubuntu 20.01/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb - Mono
      6.10.0.104
      HS4 Lite -

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

      Comment

      Working...
      X