Announcement

Collapse
No announcement yet.

Zee S2 - PHLocation

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    #16
    I get a very quick pop-up saying the site is encrypted and to click on the icon, then it disappears

    Comment


      #17
      HomeSeer Issue

      I'm confident that I'm missing a setting in HomeSeer. I'm not able to get past the login authentification. I've tried many different combinations. I'm using Cyber Duck right now....

      Comment


        #18
        That's a new one on me and I've been using SSH to access my servers for probably 15 years. But I've never had a Z. I'm guessing when you changed your user/password you did so either in HomeSeer or in the OS and created a disconnect. You definitely need help from a Z expert. I would try changing that password back however you changed it before and follow rmasonjr's instructions.

        Once you get it straightened out I would recommend using a pre-shared key for authentication. It is easier (once set up) and more secure.

        Comment


          #19
          Looking at your posts again I think there may be a disconnect on what FileZilla does. Neither SSH nor FileZilla will give you access to your HomeSeer running software, other than you can start/stop HomeSeer by SSH commands. They give you access to the operating system and file system on the Z. With SSH you can input terminal commands as if logged in physically at the remote system. SFTP uses an SSH connection to transfer files between the system you are physically on and the remote system you are logged in to. FileZilla gives you an easy to use dual pane file manager for the SFTP file transfers.

          HomeSeer has no need to know any of those things are going on. It only affects HomeSeer when you change files that are part of HomeSeer and then restart it.

          Comment


            #20
            I'm not trying to control the system. I'm just trying to put 2 files in the file directory but I can't access the file directory.

            I think I may be using the wrong login/password but the only ones I have are what I see in the HomeSeer setup page under network.

            My user name and login does give me access to the program.....

            Comment


              #21
              Presumably that is access through the HomeSeer web server. You are using a browser for that access?

              That is not access to the operating system (OS - sorry if that is obvious but there is no way to know what you already know). To change files that can't be manipulated by the web page you have to get logged into the OS. That's where I think the disconnect occurred. I'm guessing you changed a password in HomeSeer for a user that by default had matching username/password combinations for HomeSeer and the OS. Unless they did something special for the Z changing your password in HomeSeer will not change your OS password.

              You don't need to log in to HomeSeer to transfer files using FileZilla. You need to log in to the OS via an SSH connection.

              Again, don't take offense if that is too basic but basic is usually the best place to start.

              Comment


                #22
                Trust me, I'm not taking ANY offense. Speak to me like a 3 year old. That would work.

                I'm assuming I need the OS user name and password.....I have an idea....

                Comment


                  #23
                  You need an OS username and password for a user that has permissions to write to and create files in the HomeSeer root folder. Usually that will be either root, a sudo user, or the user that owns the HomeSeer root folder. That's why rmasonjr asked you to use the homeseer user.

                  Edit: the alternative is a user in the group with those permissions for the HomeSeer root folder.

                  Comment


                    #24
                    I have a headache.....

                    I tried...

                    homeseer
                    hsthsths3

                    and it did not work

                    I tried root and it did not work.

                    Any other suggestions?

                    I appreciate all the help. WE'LL GET THIS SOON ENOUGH :-)

                    Comment


                      #25
                      Try the recovery procedures on page 6 of the quick start guide. As the other guys have mentioned you are looking for the login / password of the Zee, not the HS3 user/password. http://homeseer.com/guides/HomeTroll...rted-Guide.pdf
                      cheeryfool

                      Comment


                        #26
                        Update

                        I found the correct user/password combination to access the OS. I'm in with FileZilla, CyberDuck and the MacBook Pro terminal program. Will start working on moving the files shortly.

                        Thanks for everyone's help!!

                        AARPaul in Florida

                        Comment


                          #27
                          So close........

                          Originally posted by cheeryfool View Post
                          Paul
                          PHLocation definitely works on Linux and I imagine it works fine on a Zee 2 also, though I haven't tried that. Mr Happy is correct in that you do need to do a manual install for PHLocation (as opposed to many other plugins).

                          As we established on the other thread that you don't have a Windows machine to hand, you will need to use FileZilla from your MBP to access the file structure of the Zee S2. Use the IP address of the Zee as the Host in FileZilla and set the protocol to SFTP-SSH. Use the credentials of the Zee S2 that you established on first boot (per the quick start guide).

                          Once connected, you should see your MBP file structure in the left panel and the Zee file structure in the right panel.

                          On your MBP, download the PHLocation plugin and unzip it. It creates 2 files, updater_override.txt file and another zip. Using FileZilla, drop the TXT file into /usr/local/homeseer/ and then drop the zip file into /usr/local/homeseer/updates3/zips

                          I believe the above paths are correct for the Zee 2, but I don't have one to verify. Note that folder names are case-sensitive in Unix/Linux and I may not have the capitalisation correct.

                          Once this is complete, I would restart the Zee. Then when it's back up, use the browser on your MBP to go to the HS3 web UI and then drill down to >Plugins>Manage. At the bottom of the list of installed plugins (if any) you should see an Additional Interfaces section. Expand that and drill down until you find PHLocation. Click the checkbox and then Install.

                          Once it's installed restart the Zee again and you should have the plugin available via the web ui
                          I was able to move the TXT file but do not have permission to write to: usr/local/homeseer/updates3/zips

                          I'm so close!!!! How do I get write permission to the zip folder?

                          Comment


                            #28
                            pmp350:

                            I am completely new to HomeSeer myself and trying to do the same exact thing. Using a HomeTroller SEL and FileZilla on a Mac mini.

                            What username/password ended up working for you? I keep getting denied access...

                            Comment


                              #29
                              My first time helping........

                              When you change the password as instructed, it does NOT change the user name when trying to log into the OS.

                              So, the user name will always be - homeseer

                              But the password will have changed from hsthsths3 to what ever you changed it to.

                              Example:

                              In your "Setup/Network" tab in the HomeSeer program, your would see your new user name and new password you created. The OS did not change the user name but it did change the password to the one that is in your "Setup/Network" tab.

                              Comment


                                #30
                                You will need some sort of terminal access to manage your system. Instead of using FileZilla, log in to SSH directly with the same username/password combination:

                                homeseer@mgmtmachine: ssh my_Z.homenet

                                enter your password then you should see:

                                homeseer@my_z.homenet:

                                change directories into the Zip directory

                                homeseer@my_z.homenet: cd /usr/local/HomeSeer/Updates3/Zips

                                presumably homeseer is a sudo user, if not you have more steps to go

                                copy file to the directory

                                homeseer@my_z.homenet:/usr/local/HomeSeer/Updates3/Zips$ sudo cp /loc_of_file/file_to_copy ./file_to_copy

                                enter the same password you logged in with
                                change the ownership of the file if necessary

                                homeseer@my_z.homenet:/usr/local/HomeSeer/Updates3/Zips$ sudo chown homeseer:homeseer file_to_copy

                                Comment

                                Working...
                                X