Announcement

Collapse
No announcement yet.

Speaker Client Problem after Upgrade

Collapse
X
 
  • Filter
  • Time
  • Show
Clear All
new posts

    Speaker Client Problem after Upgrade

    Hi All

    I upgraded to v.297 in Win10.

    Now when I double click speaker client - it does not load, and I get no error messages - just seems to do nothing. Even using compatibility options...
    I have restarted the Laptop a few times.

    Is there a way to reinstall it?

    Thanks
    Chris

    #2
    Did you shut down the speaker client when you updated? If not the speaker client couldn't update as well.
    -Rupp
    sigpic

    Comment


      #3
      Interesting.

      This morning tested speaker dot exe version 3.0.0.3 which is the old one and it worked just fine with TTS and VR here on Windows 10.

      Just looked at the speaker download and installed it and it is version 3.0.0.7 and it works fine too in Windows 10.

      I wonder what the difference is between the 3.0.0.3 and 3.0.0.7 versions of the speaker client.
      - Pete

      Auto mator
      Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
      Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
      HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
      Fanless Intel® Celeron N3160 SoC 8Gb
      HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
      HSTouch on Intel tabletop tablets

      X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

      Comment


        #4
        I think I did yes, actually I am sure I did however I did have a few issues with some exe's - HSPI's... It did eventually upgrade after turning off all plugins but now my Speaker exe will not work.

        It does say 3.0.0.7 in Properties...?
        But it just does not open.. it does nothing...
        I tend to upgrade when you start up HomeSeer and it checks for Updates.


        Any idea's what I should do?
        The file size says: 172KB, I have a lot of voices installed.
        About 15 I think.



        I only upgraded because of my HSTouch issues.

        Comment


          #5
          Here have only minor tweaked the PipoX7 Windows 10 box.

          BTW I do believe that Windows 10 provides the ultimate in a user desktop experience (well tablet experience). I still today prefer to shut it off when not using it. That is me.

          I have also let it update accordingly.

          Below in another post were the basic changes I made to the original build

          1 - ran the winlite script (thinking the Win10 update after I installed WinLite disabled the disabling it was doing).
          WinLite looks to have been updated sometime in July, 2016.

          Windows 10 Lite (Better Privacy)

          2 - changed UAC a bit (UAC is still enabled and running fine)
          3 - changed the directory properties such that any user can do anything with Homeseer.

          Not sure if that is why it runs for me and not for you as I do only use the PipoX7 box to test remote plugins to Linux and it is running HSTouch and speaker dot exe.

          Here too collect SAPI voice fonts (32 bit and 64 bit) and bug my wife with non english speaking Jogglers.

          I am currently running (in Linux).

          Only run Wintel clients here and only tested iOS and Android clients but never liked them. (still utilize tablets here of all sorts but shut them off when not using them). My phones do not shut off when I cradle them such that I do not cradle them anymore.

          I am not tethered to my phone and have gone back to Windows Mobile for time bean.

          HS3 lite and Pro version HS3 ZEE S2 Edition 3.0.0.291 (Linux) and HS3 Pro Edition 3.0.0.291 (Linux)
          HS3 HSTouch server V 3.0.0.94 (Many folks are still running V.68 today)
          HS3 Wintel Clients V. 36 (everything above wintel version .36 this wrecked havoc with my 15 touchscreens)
          Speaker client 3.0.0.3 and 3.0.0.7 work fine on my wintel clients (XPe & W10) doing TTS and VR - validated both in the last two days. I also have an embedded W7 client that works fine with TTS but have not tried VR with it.
          Last edited by Pete; September 4, 2016, 05:51 PM.
          - Pete

          Auto mator
          Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
          Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
          HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
          Fanless Intel® Celeron N3160 SoC 8Gb
          HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
          HSTouch on Intel tabletop tablets

          X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

          Comment


            #6
            I tried reinstalling the Speaker Client from the Downloads section; it created a new directory for Speaker.
            I tried to launch it again and still nothing happens.

            Has anyone else had these problems?
            Chris

            Comment


              #7
              @Chris,

              Here tried both old and new versions of speaker dot exe on W10 and they work fine for me.

              Are you using the laptop as your base Homeseer 3 server?

              Was HS3 / speaker dot exe running fine with previous versions of HS3 / speaker dot exe?

              Is Windows 10 SAPI running OK? Have you tested it?

              Are you running Windows 10 32 or 64 bit? Here the PipoX7 and test W10 enterprise are 32 bit.
              - Pete

              Auto mator
              Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
              Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
              HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
              Fanless Intel® Celeron N3160 SoC 8Gb
              HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
              HSTouch on Intel tabletop tablets

              X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

              Comment


                #8
                Originally posted by smokeycoles View Post
                I tried reinstalling the Speaker Client from the Downloads section; it created a new directory for Speaker.
                I tried to launch it again and still nothing happens.

                Has anyone else had these problems?
                Chris
                Are you sure it is not running? When I load it it only shows up as an icon in the tray and in the task manager. I never see any other indication that it is loaded.

                Click image for larger version

Name:	capture.png
Views:	1
Size:	191.3 KB
ID:	1187022


                You only see the speaker controls when you click on Restore on the icon.

                Comment


                  #9
                  Its defiantly not running, in either the icon tray or task manager.

                  Comment


                    #10
                    Have you looked at the event logs?
                    - Pete

                    Auto mator
                    Homeseer 3 Pro - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e 64 bit Intel Haswell CPU 16Gb
                    Homeseer Zee2 (Lite) - 3.0.0.548 (Linux) - Ubuntu 18.04/W7e - CherryTrail x5-Z8350 BeeLink 4Gb BT3 Pro
                    HS4 Lite - Ubuntu 20.04 / VB W7e Jetway JBC420U591
                    Fanless Intel® Celeron N3160 SoC 8Gb
                    HS4 Pro - V4.1.18.1 - Ubuntu 20.04/VB W7e 64 bit Intel Kaby Lake CPU - 32Gb
                    HSTouch on Intel tabletop tablets

                    X10, UPB, Zigbee, ZWave and Wifi MQTT automation-Tasmota-Espurna. OmniPro 2, Russound zoned audio, Smartthings hub, Hubitat Hub, and Home Assistant

                    Comment


                      #11
                      Good idea, the Windows ones?

                      Comment


                        #12
                        Faulting application name: Speaker.exe, version: 3.0.0.7, time stamp: 0x57102c08
                        Faulting module name: KERNELBASE.dll, version: 10.0.10586.494, time stamp: 0x5775e78b
                        Exception code: 0xe0434352
                        Fault offset: 0x000bdae8
                        Faulting process ID: 0x362c
                        Faulting application start time: 0x01d20b9cbc7db667
                        Faulting application path: C:\Program Files (x86)\HomeSeer HS3\Speaker.exe
                        Faulting module path: C:\WINDOWS\SYSTEM32\KERNELBASE.dll
                        Report ID: 7f9adf0b-0e37-4aa8-8079-6b47dfd4f073
                        Faulting package full name:
                        Faulting package-relative application ID:

                        System

                        - Provider

                        [ Name] Application Error

                        - EventID 1000

                        [ Qualifiers] 0

                        Level 2

                        Task 100

                        Keywords 0x80000000000000

                        - TimeCreated

                        [ SystemTime] 2016-09-10T19:51:35.618564200Z

                        EventRecordID 15674

                        Channel Application

                        Computer Eagle54-HA

                        Security


                        - EventData

                        Speaker.exe
                        3.0.0.7
                        57102c08
                        KERNELBASE.dll
                        10.0.10586.494
                        5775e78b
                        e0434352
                        000bdae8
                        362c
                        01d20b9cbc7db667
                        C:\Program Files (x86)\HomeSeer HS3\Speaker.exe
                        C:\WINDOWS\SYSTEM32\KERNELBASE.dll
                        7f9adf0b-0e37-4aa8-8079-6b47dfd4f073


                        Application: Speaker.exe Framework Version: v4.0.30319 Description: The process was terminated due to an unhandled exception. Exception Info: System.Runtime.InteropServices.COMException at System.Windows.Forms.UnsafeNativeMethods.CoCreateInstance(Sy stem.Guid ByRef, System.Object, Int32, System.Guid ByRef) at System.Windows.Forms.AxHost.CreateWithLicense(System.String, System.Guid) at System.Windows.Forms.AxHost.CreateInstanceCore(System.Guid) at System.Windows.Forms.AxHost.CreateInstance() at System.Windows.Forms.AxHost.GetOcxCreate() at System.Windows.Forms.AxHost.TransitionUpTo(Int32) at System.Windows.Forms.AxHost.CreateHandle() at System.Windows.Forms.Control.CreateControl(Boolean) at System.Windows.Forms.Control.CreateControl(Boolean) at System.Windows.Forms.AxHost.EndInit() at Speaker.FrmSpeaker.InitializeComponent() at Speaker.FrmSpeaker..ctor() Exception Info: System.InvalidOperationException at Speaker.My.MyProject+MyForms.Create__Instance__[[System.__Canon, mscorlib, Version=4.0.0.0, Culture=neutral, PublicKeyToken=b77a5c561934e089]](System.__Canon) at Speaker.My.MyApplication.OnCreateMainForm() at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplic ationBase.OnRun() at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplic ationBase.DoApplicationModel() at Microsoft.VisualBasic.ApplicationServices.WindowsFormsApplic ationBase.Run(System.String[]) at Speaker.My.MyApplication.Main(System.String[])

                        Comment


                          #13
                          Originally posted by smokeycoles View Post
                          Its defiantly not running, in either the icon tray or task manager.
                          My feeling it is O/S related rather than HS related.
                          Foolish thought #1 - Have you tried restarting the computer
                          Foolish thought #2 - Is there a chance that it is due to UAC? Try setting it at minimum.
                          Foolish thought #3 - Do you have a full backup of HomeSeer from when it was working you can test to see if it was really the HS update that broke it?
                          Foolish thought #4 - If there have been any Microsoft updates since it last worked, can you use system restore to roll Windows 10 back to a prior date?

                          Comment


                            #14
                            If I restore Windows back to the 04/19/16 (Installation of Critical Windows Update) - will this alter my HS3 settings and directory at all?

                            Comment


                              #15
                              Originally posted by smokeycoles View Post
                              If I restore Windows back to the 04/19/16 (Installation of Critical Windows Update) - will this alter my HS3 settings and directory at all?
                              No.
                              -Rupp
                              sigpic

                              Comment

                              Working...
                              X